Rooms Manager: Smarter Rooms: Personalized home automation with Occupancy

rooms
smartrules
microlocation
project_sensors
manager

(the rooms manager guy) #1609

code is not Published on GitHub you mean?


(Richard Bryant) #1610

No, in my IDE. Should they all be published? Or just the main application?

On another note. I’ve noticed that the Child Settings app will not update via Github. I had to install it manually because it throws and error.


Not a big deal but just making you aware of it.


(the rooms manager guy) #1611

delete the rooms child settings app source and try it again please. publish always.

in your smartapps list what if you check in the rooms vacation code what is the version number? 0.96.0 or 0.99.0?


(Richard Bryant) #1612

Running 0.99.0

Can’t delete because “The SmartApp can’t be deleted at this time because it is installed by one or more users” but no worries, I’m up and running.


(the rooms manager guy) #1613

cant be deleted from the IDE either?

if you check github from the IDE does it show you new code to install for child settings and does it work from there?


(Nathan Curtis) #1614

@bangali

Just updated to the latest - added the new code without issue and published. was going through re-saving all my rooms (all saved successfully)

Got to the screen where the spoken announcement settings is at top and hit save.

Got the ‘error saving page’ and the following error was thrown in the IDE live logging:
8398b138-1ca3-4f26-83d8-67a319c416aa 10:05:24 PM: error groovy.lang.MissingMethodException: No signature of method: script_app_f22987c643e9db656071f89f5feb5553614d6355016b53ce49a031de849e5bbc.getChildRoomOccupancyDevice() is applicable for argument types: () values: @line 709 (getChildRoomOccupancyDeviceObjects)


(Richard Bryant) #1615

From the IDE is where I tried to delete it. And before I installed it manually from code, I tried installing from the Github. it shows as a new app like in the screenshots above but it fails to install. I’m not sure where the errors are logged.


(Nathan Curtis) #1616

@bangali

Additional Error:
Master Bedroom will not change state. Manually tried to force state from Engaged to Vacant, threw the following error in log:

222bf507-43b5-49c5-9d76-5b2899a86095 10:42:14 PM: error groovy.lang.MissingMethodException: No signature of method: script_app_f22987c643e9db656071f89f5feb5553614d6355016b53ce49a031de849e5bbc.handleSwitches() is applicable for argument types: (java.lang.String, java.lang.String, java.lang.Boolean, java.lang.Boolean) values: [engaged, vacant, true, false]
Possible solutions: handleSwitches(java.lang.Object, java.lang.Object), handleSwitches(java.lang.Object, java.lang.Object, java.lang.Object) @line 529 (stateUpdate)


(the rooms manager guy) #1617

i changed something between the time you tried earlier and the post. please try again.


(Nathan Curtis) #1618

Yep - this is happening to all rooms. Can’t change state at all.


(the rooms manager guy) #1619

update code and try this again please:


(Nathan Curtis) #1620

That squared both errors, sir. Thank you.


(Richard Bryant) #1621

All good now thanks. Now let’s go find something on sale for Cyber Monday to buy. :grinning:


(the rooms manager guy) #1622

nothing like a couple of happy users. thanks guys.


(Richard Bryant) #1623

I just tried to make a change to Device connectivity check settings. At the top when trying to save out I receive “An unexpected error occurred

Log :
c1755d3a-7a99-4053-8b3b-965336e29e0d 8:18:32 AM:error groovy.lang.MissingMethodException: No signature of method: script_app_0c3cce081528867295c93124e3684b6c7eb42f3f7589f60da6d789d2992d208b.getChildRoomOccupancyDeviceC() is applicable for argument types: () values:
Possible solutions: getChildRoomOccupancyDevice() @line 709 (getChildRoomOccupancyDeviceObjects


(Tony Fleisher) #1624

Did you update to the latest code?


(Nathan Curtis) #1625

Indeed- it looks like one of the two messages I was seeing last night. If so, @bangali squished that bug in the newest code…


(Richard Bryant) #1626

Of course, that’s when I started getting it.


(the rooms manager guy) #1627

try again please. sometimes ST invokes the old code for a couple of hours after updating the new code
that method takes no params and there is no call to that method with params in any of the code.


(Richard Bryant) #1628

I updated the code yesterday. I’m still getting the same error and log entry. “ERROR @LINE 709.

BUT I’ve noticed that the rooms-child-settings.groovy installed and in your Github is 0.96 where all else is 0.99, is that relevant?