SmartThings Community

Rooms Manager: Smarter Rooms: Personalized home automation with Occupancy

rooms
smartrules
microlocation
project_sensors
manager

(the rooms manager guy) #1549

thank you. more spoken things is coming. :slight_smile:

absolutely. what acceleration sensor are you using and which DTH?


(the rooms manager guy) #1550

hmm … anything in the logs?


(Richard Bryant) #1551

During click on “Temperature Settings”

Mbd261066-7f47-49fa-aa89-b2dbb9a08e92 3:32:07 AM:error groovy.lang.MissingMethodException: No signature of method: script_app_2cb1b14e41916629f52167b8b950a6d7aab78aee789eef754af7d44105137836.getChildRoomThermostat() is applicable for argument types: () values: @line 710 (checkThermostatValid


(Barry) #1552

Just using the original SmartThings multi-sensor (open/close, 3-way accellerometer, temperature) with the standard ST DTH (runs local).

Thanks!


(the rooms manager guy) #1553

thanks. questions:

  • do you have other rooms with thermostat?
    – if yes … none of them throw the same error when going to temperature setting?
  • if you click on temperature settings multiple times in succession does it consistently throw the same error?

(the rooms manager guy) #1554

ok … i dont have those … i use the aeon multisensor for acceleration with a custom driver.

to confirm on the acceleration values … when there is acceleration it shows active and then when acceleration stops it shows inactive?


(Richard Bryant) #1555
  • All the rooms have remote ecobee thermostats and Iris sensors.
  • Clicking the button again logs the same error in this room only

(the rooms manager guy) #1556

strange … every room calls that method from one place and one place only. let me see if i can figure it out.

EDIT: is this thermostat the same one as used in any other room settings?


(Richard Bryant) #1557

No, each room has it’s own, checked all rooms for duplicate, deleted the thermostat, swapped thermostats and re-added the thermostat.

We both know we can clear this issue by rebuilding the room but the coder in you wants to know what the cause is right? :slight_smile: me too.


(the rooms manager guy) #1558

seems to make no sense … could always be chaos monkey :wink:

without deleting this room if you create another room with the same settings … same error?


(Barry) #1559

Exactly…


(Richard Bryant) #1560

Added a test room with the exact same setting and no problem. Do you want me to just remove the errored room or you want to figure it out?


(the rooms manager guy) #1561

if that works just delete the original room. since its working for every other room and this new room … suspect infra issue which i have no way to debug or control over.


#1562

Bangali,

I did it again, updated to your latest code and installed and published the Vacation Manager. Issue is that I’m seeing the following error when attempting to update each room by navigating to Automation --> SmartApps --> rooms manager. I select said room and proceed to save save save it .

Under room manager on the IDE logs, it displays the following:

groovyx.net.http.HttpResponseException: Forbidden

Further, upon entering said room from the ‘My Home’ tab --> Selecting SmartApps. Where traditionally one would observe room manager to be able to configure said room, it now only displays #rooms vacation.

Lastly, it appears that everything is broken and timers hang at 5 seconds, failing to take action.

Thanks for your help!


(the rooms manager guy) #1563

this one is happening from too many calls to github to check for code update … can be safely ignored.

so in ST app under rooms manager only # rooms vacation shows but none of the rooms?


#1564

Navigating to --> Automation --> rooms manger. All rooms are listed.

However from an actual room --> SmartApps, only #rooms vacation is listed.


#1565

Bangali,

The smartapp does appear to be functioning as expected now. Rooms are entering occupied and successfully returning to vacant. Maybe it was coincidence between the updating of the app and this error message that many users have reported to be an issue with the smartthings platform.

java.util.concurrent.TimeoutException: Execution time exceeded 20 app execution seconds: 270725557532790 @line 5038 (switches2Off)


(the rooms manager guy) #1566

ok.

yeah sometimes when there is a lot of load on ST these can randomly happen.


#1567

Bangali,

Still dunno why when in a room, only #rooms vacation shows under the SmartApps where before said update, rooms manager settings where present. Now I must enter Automation -> SmartApps -> rooms manger.


(the rooms manager guy) #1568

share a couple of screen shots of what is showing and how you are having to go?