Rooms Manager: Smarter Rooms: Personalized home automation with Occupancy


(Jane) #988

I must have to update the app. I will do this and report back.

(Jane) #989

Something isn’t working right. Even though my Basement Motion sensor sees motion, the room is changing to Vacant and turning the lights off. This is just when the lights are turned on with the rule not if I dim them after they turn on. I think it has something to do with the Power values set in “Engaged Settings”. I have Light Traffic set for When room is busy and Power Value to set room to Engaged is 20 and Power stays below for 60 seconds to reset Engaged state. Also, Require Motion within 360 seconds when room is Engaged. So right now my TV plug is showing 0 Watts and my motion detector is showing motion but I am sitting in the dark.:smirk:

(Jane) #990

This seems to be doing this as well when I change the dimming of the lights.


after updating the software from the ST app in things find the basement room “device” and click on the vacant button once … then try it from there.

Process execution rule(s) only on state change?

do you have this flag set? what happens if you unset this?

(Rowan Godfrey) #992

Hi Bangali, not sure if this is the change to be able to select a motion sensor or just me missing something but last night when I clicked my button to go to sleep, the lights went to night lights and never switched off. I was drunk & didn’t notice until 3am but still :joy:. The motion sensor being used did stop registering motion correctly. Any ideas? Thanks!


if a leaf falls in the forest and you dont hear it … did it really fall? :wink:

can you set the room asleep and try it? what is the setting for Turn on night lights when? in asleep settings set to?


i have a room setup exactly like your basement … except instead of a TV its a mac mini. not seeing the issue there. could you please go in to rooms manager from the ST app … click on the room and save the settings then try it?

(Rowan Godfrey) #995

Yeah definitely not working right… set to asleep, night lights go on (motion getting into bed), night lights stay on, motion finishes, time (60 secs) finishes, night lights stay on. Tried ‘Motion in asleep state’ and that with ‘State Changes to asleep’.


looking …

(Jane) #997

I did this but something strange is happening with my motion sensors. They seem to be stuck in detection of motion even if I take the battery out. So even though the sensors are saying there is motion, the lights turn off. Very weird. Weird things have been happening lately with ST. Last night my God Night Routine didn’t run when everybody went to bed. Lights were still on when I got up. Very frustrating!

(Jane) #998

OK I went into Rooms Manager and saved it again and as soon as I did this the lights went out. Sensors are showing motion which they should because I have them right in front of me.

(Jane) #999

It is also showing Active on the Basement Rooms interface beside the room motion box.


yeah when a room is saved the room state is reset to vacant. with the next motion everything should start over and room should change to occupied.


please update from github and try again please.

edit: after updating both apps from github please check the night turn on setting for that room in asleep settings is set correctly and save the room.

(Rowan Godfrey) #1002

Hi Bangali,

Awesome customer service as always! Doesn’t seem to have changed… if there is no motion when the button is pushed, the lights go straight off though?


(Rowan Godfrey) #1003

Don’t worry about it tonight Bangali, I’m off to actual bed, up in not very many hours :sleeping:


sorry … had typed in instead of evt.deviceId when matching motion sensors for night lights only. fixed and updated to github.

(Rowan Godfrey) #1005

Thanks Bangali, will update & test shortly when I go to sleep! Cheers again.

(Rowan Godfrey) #1006

All good, everything now working correctly & the ability to choose a motion sensor greatly appreciated. Cheers


@MEarly did you get a chance to try this?