Rooms Manager: Smarter Rooms: Personalized home automation with Occupancy

rooms
smartrules
microlocation
project_sensors
manager

(Jane) #968

I think this would be a good option. So let me explain what I want to happen…
When we enter the room there are motion detectors that will turn on the lights. Here are my settings right now…


In Room Devices: I have my motion sensors under “Which Motion Sensors” and “Last Motion Active” under the Use which motion event for timeout? I have Basement TV Plug selected for “Which Power Meter”.

In Occupied Settings: I have 4 Basement Lights(hues) selected for “Which switch turns ON”
and Timeout of 360 seconds.

In Engaged Settings: When room is busy is set to Light Traffic; Powervalue to set room to ENGAGED state is set to 20 and Power stays below for how many seconds to reset ENGAGED state is set to 60; Require motion within how many seconds when room is ENGAGED is set to 360.

Checking Settings: For how many seconds is set to 10

This is all the settings right now. However, when I go into the room, it isn’t turning on the lights at all right now.

What I would like to happen is that when I enter the room, the lights will turn on (100% white). Then if I remain in the room with the TV not on, the lights will still remain on. If I set the lights to a different colour and dimming, I would like them to stay that way until the room is Vacant. I would also like the room lights to stay on if I am watching TV (sometimes we don’t move enough and the lights might go off). Also, if I change the colour or dimming of the lights(or both) while watching TV, I would like them to stay that way until the TV is turned off and the room is vacant. So in other words, I should be able to change the lights and the don’t revert back to the turning on state. I did have a Webcore piston also setup to help with this but I was having problems with the lights going back to 100% white every so often after we had changed the colour and dimming. Hope this makes sense.

What IS happening right now is nothing. The lights aren’t turning on when I enter the room but the room is changing to Occupied.


#969

will do.

this setting is to set room to occupied when any of those switches turn on. assuming you want these 4 lights to turn on remove them from there and add them to the existing rule for occupied rule in switches to turn on. once you do this it will work fine.

also on the rule add both state occupied and engaged. right now i believe only occupied is selected for the state on the rule and that is the only rule. optionally you could create a new rule with engaged state selected and a different light settings from the occupied light settings on the rule.

that will turn on the lights.

this feature is not supported today. today the lights are always set based on the rules conditions and trigger. so if you change the lights from the rule setting and then there is subsequent motion it will reset the light back to the value in the rules. this is the first time i have had this ask. :slight_smile:

will take a look.


#970

done. will be in the sunday morning-ish release.


(Jane) #971

I have made the changes but when I try to save everything it stops me on Announcement Settings and wants me to select something for “Lights for announcement with colour”?


(Jane) #972

I just selected one of the lights to be able to save the whole thing. I checked and the lights came on when I entered the room.:grinning: Good start! If some sort of Lock on the settings could be set somehow that would keep the lights from changing once they are on until the room is vacant, would be great! Maybe using the Wattage for the TV being on to Lock the settings and then the lights could be changed to anything and stay that way. Once the Wattage goes to zero the Lock is removed and the room is set to Vacant.

Your program really has sooo much to offer that I can see it having so many options which makes it much easier than having to write a complicated piston using Webcore. Thanks for the great app!


(Jane) #973

Or also maybe having it Lock if the lights change from original state to something else? But then you would need something to Unlock the lock setting. Hmmm!


#974

sorry there was a typo on my part … fixed now.

thanks.


#975

may not even need locked settings for this … will work on supporting this later tonight.

as much as i enjoy using pistons / smartlighting for one off tasks … through experience it got to a point it was just not practical to set those up in a way where it could handle all of the needs in a consistent and reliable way. thats what gave rise to this app. happy to hear you are finding it easier and useful.


#976

that will soon get confusing for most users … so probably going to stay away from it. :slight_smile:


#977

this looks pretty decent :slight_smile:

thank you to everyone that contributes by using this app, giving your feedback, asking for new features or contributing code. that is much appreciated.

also thank you to everyone that has donated to support development of the app. very much appreciated. since its hard to tell which forum you live on … i just go across and thank you on all three forums. thank you. :slight_smile:


(Jane) #978

For some reason, the Basement Room is getting stuck in Occupied. Motion was last detected at 1:07 pm and it is now 1:50 pm and the lights are still on and it says Occupied. This has been happening lately.


#979
  1. did you remove those lights from the occupied settings switches?
  2. do you have timeout set in occupied settings?

(Jane) #980

Yes, I took the lights out but I also took the timeout out. So, I put in 360 seconds and we will see how that goes.


#981

since there was no timeout it was not timing out from occupied to vacant. now that you have added the timeout back everything should be good.


#982

UPDATE: updated to github with the following changes:

*  Version: 0.35.0
*
*   DONE:   5/11/2018
*   1) added option for buttons to set a state but not toggle from that state.
*   2) added option to set locked state with power value.
*   3) added option for contact sensors to not trigger engaged for use with landing or hallway areas.
*   4) added option to use only selective room motion sensors for motion during asleep mode for night lights.
*   5) changed options for when to turn on night lights.
*   6) added option to only run `execution` rules when state changes. this means once the state changes and the lights have been set, if you change the light settings those will not be reset till the room changes away from the current state.
*   7) added timer display to rooms occupancy device for asleep state.
*   8) organized settings in rooms manager.
*   9) updated docs.
*   10) couple of bug fixes.

#983

please update to v0.35.0 and test.


#984

please update to v0.35.0 for asleep timer.


#985

in mode and other settings turn on Process execution rule(s) only on state change? for this. i have tested this only for a few minutes but not over hours. if you do try this please share some feedback on how it worked.


(jay yankacy) #986

Wow, I’ll give it a try! Thanks a million!


(Rowan Godfrey) #987

Thanks Bangali, will test tonight. Looks good though.