Rooms Manager: Smarter Rooms: Personalized home automation with Occupancy

Then do whatever it is that generates the error. Thats what hes going to want to see.

Ah, I see what you’re saying. OK, unfortunately still not getting anything even with debug logging.

Steps I took:

  • Create new room “Test Room,” Save it
  • Go back into “Test Room” > General Settings > Turn on Debug Logging, Save it
  • Go into “Test Room” > Asleep Settings > "Set room to asleep at time” to 11pm, Save it
  • Go back into Asleep Settings > “Wakeup room at time” to 8am, Save it
  • Go back into Asleep Settings > Fail with “Something’s Wrong” error screen.

I also tried setting “Wakeup room at time” BEFORE “Set room to asleep at time” and the problem did not occur. So the issue appears to only be when BOTH of these times are set.

This is the only logging I got in the IDE:

  • For Test Room:
    1:14:24 PM: debug Test Room updated: 3185 ms
    1:14:22 PM: info updateRoom Test Room

  • For rooms manager - v1.0.1:
    1:15:07 PM: debug perf scheduleNext: 54 ms
    1:15:07 PM: debug [[type:time, time:Fri Jun 26 20:30:00 UTC 2020, timeS:13:30], [type:next, time:Fri Jun 26 20:30:00 UTC 2020, timeS:13:30, options:[time]]]
    1 1:15:07 PM: debug {“option”:"[time]"}

Anything else to try?

@bangali

I’m getting the same thing with “Something’s Wrong” when I set asleep settings.