Roomie Agent hardware/setup

I am starting to integrate ST with Roomie Remote. The Roomie app -> ST integration works well and overall I like the Roomie service. The thing I am missing is a Roomie Agent setup to allow the ST-> Roomie control when i am not home/using the Roomie app.

I don’t have an OSX computer sitting around which seems like the best option to run Roomie Agent. They have recently released an Android version but again I don’t have one sitting around. Does anyone have Roomie Agent running on an Android device? I am willing to buy an Android device to use as a dedicated Agent box (much more economical than buying an OSX computer) but have little to no knowledge about Android.

The Roomie forums didn’t have much information about Roomie Agent…

1 Like

Are you able to control ST devices from the Roomie (Simple) remote?

I just got this integration setup and all seemed to go well but I can’t figure out how to send a command to ST from roomie. Nothing I’ve tried has worked anyway, and it doesn’t seem to be documented anywhere by Simple Control.

They seemed to have solved your problem potentially BTW. Simple is now offering a little device running their simple hub software, or you can buy it as a software license to run on a mac.

I ended getting an old Nexus 7 to use and it worked okay. It took a lot of tinkering to get the Simple Sync software to run more than a day or two (eventually got it up to two weeks). This is a problem with Android not the Simple Sync software.

Here are the instructions if you haven’t seen them:

You can setup triggers in ST to run activities in Simple Remote. For my use case, my son gets up in the morning and watches TV. I setup a virtual switch in ST that triggers an activity in Simple Remote to turn on the lights in the room, turn on the TV, change to the correct channel and set the volume at the right level. It worked really well as long as I checked the Nexus every week or two to make sure the Simple Sync software was running.

I have checked out the Simple Hub but it is pretty pricey for a one trick device. Simple Remote recently released SimpleCam software for the 4th Generation Apple TV that also doubles as Simple Hub software. I can justify buying an Apple TV because I can use it for other things if I want down the road (while you are using it as a Simple Hub you pretty much can’t do anything else with it since the software has to be running in the foreground).

I am new to SmartThings. Just set up the Hub and a few Leviton Decora light switches (a Switch and a Dimmer), which I am using for testing. They work fine. I am considering using SmartThings to control light switches (and create scenes invoked by pressing the light switches). So far, this appears as if it will work (may need to create a few Smart Apps for additional flexibility).

But, I use Simple Control for most of my home automation, and would like to integrate with SmartThings so that I can control the SmartThings light switches from Simple Control. But I am having difficulty getting them to “pair”. I upgraded to Version 5 (of the Simple Hub software on a Mac) and Version 5 of a Simple Control iOS client app. When I try to add the SmartThings hub (as a Cloud Service) from the Simple Control iOS app, it is clearly communicating with SmartThings, and presents me with an authentication screen. When I enter my credentials, it provides me with an Authorization screen, which lets me select the name of my “home” and which SmartThings devices I want to control from Simple Control. When I select Authorize, it appears to work.

But, it then presents an Add Device screen with a “Pair” button (as well as a Manifest and Advanced button). When I select the Pair button, nothing happens. So, I am forced to exit from the Add Device screen with no device added. I did notice that this causes the SmartThings App to show Simple Control as a SmartApp, and then to show SimpleSync as a device. But, they dont seem to do anything either.

Has anyone else experienced this problem? Simple Control tried to troubleshoot it, but said that once I get to the Add Device screen (where I try to select the Pair button), there is no further communication from SmartThings. They told me it should work, and that no other users have reported this specific problem. They thought it could be a firewall issue, but it seems clear that SmartThings is communicating with Simple Control (since it shows me the name of my “home” and devices). And I cant get tech support at SmartThings to help. They just say they dont support Simple Control, and said to try the Community.

Any ideas?