SmartThings Community

Ring Alarm released! (Integration project in post 13)

So I have a house full of Smartthings, zigbee and z-wave devices. I wanted a better alarm system that has monitoring. A friend told me about Ring Alarm with Cellular Backup. So I went on a mission and did a lot of research and learned the Ring alarm will work with my devices, but unless it’s a Ring device it will no call Police or Fire. Bummer.

All I want is the Ring Alarm Hub and use my devices, but want to keep using my ST Hub and as you know you can’t share devices on 2 hubs.

After researching and realizing nobody has a solution to this so I created one.

I installed the Ring Hub. I threw the Keypad, motion and range extender in a box and threw it in my closet. Don’t need it.

I took the Door Sensor apart I unsoldered the magnetic reed switch. Then soldered 2 wires in it’s place and attached them to this:

Connected the wires to Com and NO because the Door sensor is Normally Open circuit.

Now I told Smartthings to Trigger the Wireless Z-Wave Multi-Input/Output Dry Contact Bridge when an alarm goes off.

Perfect. Now all my ST sensors trigger the Ring Alarm. The Ring alarm thinks it a real Ring Alarm Sensor. I could care less Ring always tells me Door sensor tripped because ST tells me which sensor tripped.

Also had someone say Ring has battery backup and ST doesn’t, Well that’s true but I’m using ST Hub V2 which does have battery backup V3 doesn’t have battery backup.


Also, the Ring Alarm has its own cellular backup as well. Keep in mind if you want to tinker, there’s an unofficial integration between ST and the Ring Alarm in this thread.

You could have skipped un-soldering the magnetic reed switch - you can solder right to the board. If you open the Ring contact sensor, there are 5 pads. Wire to G (ground) and O (open), and you’re set. You can do this for any kind of sensor (C is for normally closed sensors). I have mine tied into my wired contact sensors already installed in my house (through Konnected, but you don’t need a Konnected board to do this).

Thanks, this one got me stumped as well. Thanks for the clarification.

I’ve had trouble with this also and deleted everything and recreated just to be sure. I’m too getting the same response from SmartThings logs:

Ring Alarm Status check Error: Bad Gateway

I got the Ring Alarm into Smartthings, now how do I get “Good Night” routine trigger Ring Alarm to “Arm-Stay”? Any help is appreciated

To sinc see Superhell2001’s reponse at 41 above. You need to load the simplesafe alarm smartapp.

  1. Has anyone figured out a way to sync SHM -> Ring Alarm State? I’d like to be able to use SHM to set Ring states.

  2. I got the integration working but I see a bunch of “unknown tiles” in the device. I am not seeing any updated status in the device as well. It is working fine though when I change the state (off, away or home) within the device. I have since added 4 motion sensors and 6 more contact sensors. I am seeing in the IDE logs - Ring Alarm Status check Error: Bad Gateway

My devices all show up the same way as well except for the motion detectors. Anyone know how to make the devices show properly?

Also, is there any way to tell smart things that a smoke alarm has activated? I would like the doors to unlock, lights to come on, and some smart plugs to shut off.

Does anyone know if this method still works? I can see the status of my Ring Alarm from the SmartThings app but I can’t change the modes. I’ve tried both v1 and v2 and I can’t change modes with either of them.

From v1 I get this - {“message”: “Internal server error”}
From v2 I get this - Unprocessable Entity

How do I actually arm the alarm?

I went to automatons -> custom automation

If -> Based on a member’s location -> When all selected members leave

Then -> Control a device -> Ring Alarm System

The only options I see are:

  • Off
  • Strobe
  • Siren and strobe
  • Siren

If I look at my alarm from the dashboard, this is what I see.

Mine is still working great

I gave up and found a homebridge thing for it. I wish the smartthings integration was like it. It’s instant both ways. I rigged it to work with smartthings to use the ring sensors via virtual sensors and was able to get rid of the dual sensors everywhere. Again it would be nice if I could do this without HomeKit as the middleman.

Can you elaborate on your setup?

is there any more info on this?

Ive deployed the Simplisafe smartappand connected to my ring alarm device and still no go on the ring alarm device showing any status

This works beautifully.

I am having a hard time figuring out how to set the alarm to Stay mode, im using the hubs location mode to set trigger the alarm.
To disarm i have to use the off command, to arm away, i have to use a custom “Do” that was available in the list.
By setting smart house monitor status to stay, Ring does not respond.
Any ideas? or help?

With the addition of light switch support and sensors showing up in Alexa, ring is really starting to round out their platform nicely.

1 Like

I have both SmartThings and the Ring Alarm in Homebridge. I created some virtual door/window sensors in SmartThings. When the Ring Alarm sensors open/close I have a Home Kit automation to open/close the virtual sensors in SmartThings. I also have virtual switches for Home/Night/Away. When I change modes in SmartThings one of those virtual switches will turn and using those I automate my Ring Alarm modes through Home Kit. Not the cleanest but it works and it works pretty fast.

Perhaps someone can check out the homebridge code and make it work with SmartThings? It’s so simple and doesn’t require all those API keys and stuff.

Interesting. That’s a lot of bridges. I’m already running a node server on my Pi for something else. Is it possible to run multiple nodes on one Pi?

Any help from the community on this?

I have a physical switch in my bedroom that changes the mode to night at bed time, which then triggers the above piston to put Ring into Stay mode, but the ring does not change status.
However Home and Away modes work perfectly.

Any help would be greatly appreciated.