[RESOLVED] Could not parse the service response


#1

So things have been going well with the ST platform for a good number of weeks now, then I try to open the ST app and I get this lovely F***ing error…needless to say I have not been able to log in all day, and what’s even better is that ST support emails me every 3 hour asking me to delete devices and apps from my account…Great!

If anyone else feels my pain, please chime in because this is unacceptable!


(sidjohn1) #2

Idk if you have already done this, but this is where I’d start.


#3

Got the same issue… Removed the App, reinstall… even reseted my password, and still cannot login…


(Ule) #4

In my app show, “Internet connection issue, please try again” but my internet its ok and I have tried with 3 different providers and 3g , nothings the same error.
And if I going to developer page the error after login

Oh No! Something Went Wrong!
Error
500: Internal Server Error
URI
/device/list
Reference Id
xxxxxxxxxxxx-xxxx-xxxx-xxxxxxxxxx
Date
Sat May 21 15:19:33 UTC 2016


#5

Nope. That did not work either. My automations are running but if an alarm sounds of something happens that I need to get in the app for, then I’m SOL at this point.


#6

I contacted support via Email back and forth, they looked at it, tried some stuff, but I still cannot connect on my mobile iOS App…
It’s now escalated to developers… great…


#7

Same here. They need to look into the code that triggers this error message. I don’t get why this is such a problem. I haven’t been able to use ST since yesterday, I’m Not confident it will get resolved today either. This is a total mess!


#8

No doubt that nothing will be done until Monday, best case…
The only thing I did before having the issue was updating my Ecobee Device Handler, but I don;t think this came from that since support looked and deleted it.

More to follow, but ST is very disappointing since several weeks… I have many times issues to login, but a single retry was enough to get me in…

More to follow


#9

ST Support got back to me today and they said that the developers have pointed the source of this error to a Device Type Handler: rboy : RBoy Foscam IP Camera

I just removed the DTH in IDE (first changed the device type of the cameras using this DTH) and was able to log in finally.

You may want to try this if you are using RBoy’s Foscam DTH @Francky


#10

Yep, that was it! Support didn’t get back to me about that, so thanks for the feedback!
I cannot remove all the Smartapps attached to the device, like Smarttile, Amazon Echo, Light on Motion, but I can now connect at least.
I’ll also report to @RBoy.


#11

I did realize that I had an older copy of the code. It’s a bit cumbersome to keep his code updated when any changes are made, especially without GitHub integration.


#12

I think I had a recent one, but let’s see what he thinks about the issue, I posted in the official thread.


(www.rboyapps.com - Make your home your butler!) #13

Honestly I have no idea. ST architecture forbids one App from directly communicating with another one so I’m really lost what’s going on here.
I did report one funny problem I faced with my foscam DH to @slagle some time ago but he wasn’t able to replicate it. I wrote it off thinking its a peculiarity of my ST account.

Maybe he can help figure out what’s going on.


(www.rboyapps.com - Make your home your butler!) #14

Okay try version 3.2.4 of the device handler, that “funny” problem I was facing was also bring reported by some other users and it looks like the ST platform is randomly calling the updated() function of the device handler and also messing up the state variables and event states which is causing other “random” issues also. Your issue could be related to this problem. In v3.2.4 I’ve disabled the updated() function all together. It solved all the issues the other user was facing and mine. Likely it may solve your issue also.

Downside of this, everytime you change the device preferences settings you’ll have to manually click on the refresh() button (not often I guess but one more step. Thanks ST :rage:)


#15

Thanks I will try once I’ll be back home.
Here is what support told me today about the issue, if that can helps:

“It seems this device type stores the image in such a way that our system can’t quite handle, causing you to be unable to log in”