Reset Cooper Aspire RF switch?

Hello, I have finally gotten all of my devices reconnected after some problems I was having. The only one I cannot get to reset is a Cooper Aspire RF9534 Dimmer. Does anyone have any idea how to restore it to factory defaults? I have contacted cooper but they have not gotten back with me. In the instructions it only addresses how to remove it from hub when active, since I did not do that before It is still linked up to old settings I guess.

Thank you

The manual for the device normally covers that.

@sidjohn1 Yes you are correct, usually the manual does tell how to do it. But on this one it does not! Only if you are excluding it from the hub which I did not do first so I need to manually reset it.

Simple devices are reset by excluding it… That’s is why there aren’t extra steps in the manual for it.

So how do I go about doing it? Any idea’s?

@sidjohn1 I appreciate you trying to help me, but you do not understand what I am asking, I think. Do you have any cooper switches like this? I think that the switches in question were developed for another type of hub controller or hand held controller to remove from a specific network. If you read my first question (post) you would see that I had problems with my smartthings hub and support helped me restore it to factory defaults. But I was having so many problems that I did not first exclude the cooper switch from my hub so the switch now thinks it is part of a different network and it will not exclude from a network that now does not exist. So I need to know how to make the switch go back to factory defaults within itself.
Thank you


I had the same problem with the cooper RF smart dimmer and found the answer. You are right the manual is useless for this problem because the answer shows how insecure the product is.

Any Z-Wave controller can hijack a Cooper RF smart dimmer. Just put the Alien Z-wave controller in “remove” mode and push the button. Then put it in “learn” and press it again.

That’s right… someone with a z-wave controller in the same environment (apartment building) can take over your system when you press the on/off button…

I just did it. On my system and it worked. My new controller just had to be in “remove” mode while I hit the button.


1 Like

Just figured out how to fix this.

Thanks for the information. I had one of these switches come out of the box new, already homed to some network. (all wire covers and stickers were in place) Anyway, placing the hub in exclude mode, and turning the switch on/off cycle, worked.

sidjohn1 You put it out there first. But, thanks to all of you. I just installed 18 of the switches, and got them for the bargain price of $7.50 each. I could not be more pleased.

Sometimes a brand new device gets paired to a test network at the factory and then just never gets excluded before it ships out. It can happen. A general exclude is usually the first thing we do when troubleshooting Z wave device that won’t pair. It’s one of those “can’t hurt, might help” things. :sunglasses:

1 Like

I have calluses from installing the 18 (from the wire nuts). I learned a lot about the wiring in my 10-year-old home. There were a few places I wanted to put these, but the wire loop is just that. 3-wire electrical, where they loop in with black and out with white through the switch, thus missing a complete set (hot/neutral/ground/load) to make these things work.

Now that is done, when I have time, I will look for a device handler to take advantage of their programming (delayed off, lockout, panic) These are RF9501 and so far I have seen handler for the dimmer version of the switch.

Thanks for your input also.

1 Like

Thank you guys for this post! I thought I just had a faulty switch. These dimmers are great though.

1 Like

I have literally spent hours trying to figure this out on my Eaton RF9540-N dimmer switch. Your answer finally helped me! Can’t believe it was this simple. I was digging for so long trying to figure out how to do a factory reset on the switch. Thanks!!!

I’m glad I could help

I spent a few hours trying to get my RF-9501 switch to work. It was programmed to an IQ Control Panel and I wanted to add the switch to my new SmartThings Hub, but I did not have access to exclusion mode on the IQ control panel nor could I get the switch into an add/pair mode. I did as you suggested and first put the SmartThings Hub into exclusion mode. It found 1 device to delete and sure enough, it was the switch (even though it had never been connected to the hub before). I deleted it and the pairing LED started flashing on the Switch. I then was able to add it to the Hub. Thanks!

Glad my post helped. These switches are built well and hold up in abusive environments. 4+ years and mine have stayed reliable.

1 Like