[REMOVED] Nest Manager 4.0

Awesome! Sending some paypal love your way :grinning:

Hello, I am also having issues with the Nest login. I had NestManager working but something with my routines behaved funky (getting wrong heating setpoints), so I decided to remove all devices created by NestManager from my ST app and just wanted to re-install the smartapp (I am on v4.5.2, no update available), but hitting “Accept” for the Nest authentication only results in the “Ooops!” error as seen in the screenshot a few posts earlier.

I have been reading through this discussion for the past 2 hours … I tried logging out of the app and back in … I checked the Nest app for configured/allowed services … At this early stage of the installation I do not even get any logs in the IDE. Any ideas what else I might try?

Thanks in advance!

Nora

@tonesto7
I have got some problem about Work with Nest permission.
I can find an error message ‘Can’‘t reach nest.com right now. Try again soon’ when I login to Nest (accept button).
Some people have same problems I think.
Nest Manager is 4.5.2 version.
Any other good solution for this matter?

1 Like

It should be fixed. we are running out of tokens while we are trying get approved. sorry for the troubles.

1 Like

Awesome, it worked! Thank you!

Hi @tonesto7 - amazing job on this.

I have just added 2 newly installed Nest Thermostats into my ST ecosystem via your device handler and app. Instructions were great, process was smooth and so far so good.

I noticed however that there is no element of control for Hot Water? I am not sure if this is available in other regions - but certainly in the UK we can control hot water schedules & boost if required. This isnt going to apply to everyone as not all set ups or houses will warrant it, but i notice back in October 16 another user asking about water control.

Is this something you plan to add in at a later date?

Many thanks,
Ant

1 Like

I have installed the latest version of Nest Manger (fresh install), and it seems to work fine, except…The tables and charts do not render consistently and sits in a “refreshing” cycle.

I have to quit the app and reload it to get it to refresh correctly.

Nest does not give us an api for seeing the hot water / boost temperature.

Some folks have done things in other areas where nest has not given an api to create a custom DTH, and using unapproved APIs to try to control things (they way a the nest mobile app would).

If you see / learn of a public API, we would add this.

Unfortunately this is an Android client issue. Since they don’t “support” HTML in device handlers it will take some time to get resolved.

Just got this and running and left a donation. Great work!

One concern I have… Is there any way to get the live camera feed to work without enabling public sharing of the camera? This is a bit of a security issue…

Thanks!

I have been able to get Nest Manager set up and working except for the nest weather device. When I go into the Manage Devices & Location screen I am able to select “Add Weather Device”, however, after hitting next, the button next to “Add Weather Device” returns to the un-selected position.

Wow! Very impressed with this. I just setup a thermostat today for a friend. :slight_smile: Kudos to you all.

1 Like

Thanks @E_Sch,

I will message Nest UK and see if they have any plans to expose this via API.

I am having an issue with the NestMode automation. I’ve noticed that nest manager will place the Nest into away, ECO successfully, back into home mode, but will NOT switch it out of ECO mode. Is this the way it is supposed to be set up or am I missing something. Thanks.

I most say thanks for this. Love the presence sensor, works much better and reliably than others, cheers

Is there a way to use the Cam as a motion sensor to trigger a light.

Update…I found how to use it with Stringify

I keep getting camera unavailable. It works in the Nest app and online. I’ve also tried to reauth. Anyone got any ideas?

Things to check:

When you update, you update both Nest Manager and the device handlers, so ensure you update both.

Sometimes things need to be refreshed in the IDE (especially with github), so check that github checked again both for the smartapp directory and the devicehandlers directory.

Assuming that you’re talking to me, I installed everything fresh a week ago.

The methods used to even get the device to stream on ST are highly ‘frowned upon’ :wink:
The issue is with the unsupported methods required to allow it to stream using the ST mobile client seem to have issues on iOS. Android client works 100% (This is the only function that android supports better than ST)

The best you can do for now is to keep refreshing. Once it starts working it usually works for a while afterwards.
I will continue to see if I can make it more stable.