[REMOVED] Nest Manager 4.0

There is a button in the thermostat in Nest manager to turn on the fan. Nest by default
has a fan run timer, so it should run for xx minutes when you turn it on, and the thermostat will turn off.

You can do the same thing but turning the fan on in ST with
the attribute thermostatFanMode setting it to “on”

Thanks guys! I figured it was something like that. Eric filled in the blank I needed there. Probably seems obvious…

Unrelated to this but related to my earlier issues. Overnight and this morning I’ve been getting a warning that NM hasn’t refreshed data in the last 917 (one time more) seconds and that I may need to refresh my Nest Authentication settings. This warning has been sporadic so I know it is eventually refreshing. This warning is what prompted me to refresh my token last time which I definitely know now is not the right thing to do. So, is this warning referring to the authentication that you sometimes have to refresh actually in the Nest app? I’m guessing so. I don’t have any messages to authenticate in the Nest app though. However, it did take a minute or so for the Nest app to show my thermostats so I’m guessing it is either Nest being wonky or my wifi network (or both).

Boiling it down to a question, if i get that warning and there are no authentication messages in the Nest app is it best to just let it fix itself?

we would need to see logs to answer your question. It is strange.

If you want to share IDE logs, do it in a private message to avoid sharing too much data publicly.

I am having the same issues. I sent a PM with log access. Great app, thanks for all the development.

@E_Sch Do i have to have a nest thersmostat to use the NM smartapp? I have a few protects that i will would like to integrate with smartthing

No. I just have protects as well and it works great.

Thanks, I just tried to install the nest manager but i’m getting this error.

1 Like

May want to try again, as I see others saying they had platform issues today.

If it persists, share IDE logs via a Private message.

Thanks I will keep trying see if it works

I too am getting this error after an update from an older 4.x… To the current one…

Mine however is saying it can’t reach nest.com now… It was saying same as yours moments ago.

And I did try a refresh token. As a last ditch effort…

Same here. When I go to “Agree” to the permissions it says, “Can’t reach nest.com right now. Try again soon.”

I tried everything short of removing the hub location… reinstalling and all did nothing…

FYI: This is the first time I’ve ever installed it, so it has nothing to do with updating.

Wonder if anyone has encountered the same issue that I have, getting constant nonstop notifications about “upgrade available”, but have several times copied the code from github to my IDE, saved and published off course, but still getting several notifications every hour about this.
I’m on UK hub, so no integration with github either, have to do it manually.

It would be good to see your IDE logs (via a private message)

Ensure you upgraded both Nest Manager, and your device handlers to the current version. Be sure to follow the instructions to both save, and publish for me.

http://thingsthataresmart.wiki/index.php?title=Nest_Manager

I am trying to use my Nest Thermostat with Ask Alexa but having issues with getting the “Alexa, ask Smartthings for the Nest Report”. I noticed that my Nest Thermostat is now named “Nest Thermostat - Living Room”. In order to get the report to work I need to say “Alexa, ask Smartthings for the Nest Thermostat Living Room Report” and it fails. If I rename “Nest Thermostat - Living Room” to “Nest”, the report functions fine but a minute or two later, the device renames itself back to “Nest Thermostat - Living Room” and the report fails. Is there a way to rename by device and have it stay renamed?

Thanks

I had this same problem. Renaming to it to “thermostat” worked for me. Its never changed its name back but it did not like just “nest” as its name either.

@Xtropy @scpickle

There is a bug that broke this. I will try to push out the patch for it tonight.

2 Likes

@tonesto7 Any idea if we could adjust humidity via Nest Manager? Nest no longer auto adjusts humidity settings based on outdoor temperature. Automating that adjustment via SmartThings would fix my biggest issue with Nest. Not looking for a new smart app, just a additional control for Nest Manager that I could adjust from another smart app. If you don’t have a humidifier I’m happy to be a guinea pig :slight_smile:

It’s something being worked on for the massive v5.0 update

2 Likes