[REMOVED] Nest Manager 4.0

Just noticed on my device page that my thermostat is showing a status of “offline”…Not sure what I did to cause this to happen. My smart app and device handler are both up to date. My last successful check in/ data received was 12/9. Thanks!

I installed Nest Manager, without enabling OAuth first, and got a notification to remove app and enable OAuth and then reinstall again. However now I can’t even remove the app. All it says is “You are not authorized”. I already enabled OAuth, but since I can’t remove the app, I can’t also reinstall it. I’m stuck. What shall I do?

My weather is crashing too now

In the earlier report of weather issues, they were using a personal weather station that was not providing proper api data. When they pointed to a “normal” weather underground station it worked fine.

1 Like

That might be it I read BloomSky was having api issues on another thread

my next is down it is up in the nest app on my iphone but the ide is giving errors

Those errors look like firebase (Nest’s API) is having issues

Hi all,

I’m hoping someone can help. I figured I’d update to my thermostat and nest protects to version 4.2 from the GitHub code and thought the IDE. The devices all updated fine, but the smart app causes and error when you try to save the app inside the IDE:

org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
script14819164392112029599436.groovy: 11572: unexpected char: 0xFFFF @ line 11572, column 138.
ngs["${autoType}_Alert_1_Alarm
^

1 error

I’ve tried cut and pasting several times on different devices, always the same. I even tried creating a new smart app from scratch and it has the same issue,

Any ideas how to get the nest manager smart app updated (my thermostat currently cannot be controlled via smart things).

thanks

Jon

While I use Nest Manager for some things, for Home/Eco status on my Nest Thermostats, I use Simplisafe’s “Works with Nest”(since it’s an officially supported method) and it has worked flawless until this week. Is anyone having an issue with Nest Manager and automatically switching between Eco and Home when arriving home? There was a Simplisafe update this week that mentioned enhancements to Works with Nest and their integeration connection is now called “Simplisafe Test” which is not giving me a lot of confidence. I wanted to see how you guys who use Nest Manager have fared with this lately.

We have seen a couple of things recently with Nest.

The home/away assist seems do make random jumps out of away mode for reasons unknown. Folks have commented on this in this thread.

To that end, in our upcoming release, we have updated the nestmode automation to not only set Set home/away, but to have the option that when away, we directly put nest in eco mode. We have a couple folks testing this, and it seems to be working now in the tests.

Once this is released, you could consider disabling home/away assist completely.

My view, is Nest is still figuring out how h/a assist is to work, and we are all “testing” it… It right now is showing the worst behaviors of auto-away (actually it seems to be doing auto-home whether you are there or not).

1 Like

Testing version still sets Home/Away on Nest but also has a toggle (optional) to additionally pass an ECO mode set so this should make all parties happy. I’m no longer using any Nest native Home/Away assist and saw a successful ST Away to ECO and ST Home to resume (heat in todays case)

It seems to happen to me if the schedule has a new set point while in away.

Interesting. Are your schedules running from Nest or Nest Manager?

Schedules as set on the Nest app

My Nest Manager is not working correctly. Whenever I expect a change or want to know the current temp in the house, I have to check in the Nest app to make sure the change happened or make the adjustment (which is becoming more frequent) or see the temp.

  1. It shows that it was last updated on 12/1/16 but I have updated in IDE a few times since then, the last being on 12/12/16. It shows my house is constantly 72 degrees no matter what the real temp is. Nest app and the Nest thermostat show the correct temperature. My AC unit is in auto heat/cool mode and the NM is showing to only be in heat mode. The bottom half of the app will not load showing the history chart, which is also stuck on 12/1/16, or the data below it.


  2. My routines show to be setting the temp to the right set points but it’s not.

  3. Nest Weather has not updated since 12/1/16 either.

All the screenshots were taken from 8:07 am to 8:12 am on 12/18/16.

Thanks to @E_Sch my Nest Manager is working again. It took a lot of time yesterday and a lot of messages to troubleshoot the problem.

If anybody has similar issues as to what I described above, I suggest reinstalling completely. I removed it from all routines and smartapps then deleted it through IDE. I did a complete fresh install. Now my Nest Manager works the way it’s intended to.

Maybe someone can point me in the right direction and help me out with an issue I have been having. I have a Nest thermostat in my living room that also provides heating/cooling for my daughter’s room. I put a temperature sensor in my daughter’s room and created a virtual Nest to control the temperature in there. My issue is Nest Manager appears to control the temperature based on an either/or rather than an and logic. My furnace cuts off when either room reaches it’s set point. Is there any way to change it so that it only cuts off when both rooms reach their set points?

The way the remote sensor works is that when multiple remote sensors are selected it averages those temps.

You can create schedules, and adjust at different times of the day what sensors are used (and what setpoints).

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.