[REMOVED] Nest Manager 4.0

So far with 4.1, the NestMode automation has been flawless for me as well! Thanks!

Seriously excellent work @tonesto7!

-Ben K

1 Like

Thanks for letting us know… Seriously though this project has gotten so large and complex that it takes a few of us to make it what it is. So I want to make sure that @E_Sch and @desertblade get their due credit as well.

4 Likes

Thanks for pointing that out! @E_Sch and @desertblade: Excellent work as well! Thank you!

2 Likes

Thanks for all the great work on 4.1 and the previous versions of this app.

Like many people I’ve had a lot of issues with Nest since their introduction of “Eco” temperatures. My main problem is that the thermostat now “pops out” of the Away functionality. It doesn’t matter if it’s set manually or through an app like Nest Manager. I have all the Thermostat sensors and Protect sensors disabled (pets) but it doesn’t seem to matter. After 1-2 hrs it’s back out of Away mode into Home mode and then Eco turns off as well.

None of this is your problem, it’s with Nest. I’ve had conversations with their support about it but have been told multiple times this is “expected” - even though it never did it before. In any case what would really help is a way to use the Presence sensor to toggle the Eco mode directly instead of toggling the Home/Away functionality. I’ve noticed if you set the thermostat into Eco mode directly it works until told to turn back off.

Is this something that could be added, or is modifying the code for this basic enough I could attempt it? I’ve done some basic App writing but this one is way more complex. Just a pointer on where to look or what to change and I’m willing to add it myself. The thermostat is basically useless without automating itself when I’m not home. Thanks! (sorry for the length)

1 Like

@robwrberjr I have found this to work fine so far. I have my setup set to run the routine ‘Goodbye!’ when me and the wife leave home (set by being outside the geofence). That routine sets the mode to ‘Away’. In Nest Manager I have Precense enabled and in Nest Automations I have Nest Mode Automation Config set to ‘Away’ for when away:

In the Nest app itself I have switched off the Protects in Home/Away assist so the the dog doesn’t trigger Nest to think someone is at home.

I just updated via IDE and noticed that you recommend removing the virtual thermostat device and then delete the virtual device code from the IDE. How should I go about doing this?

On IDE, under Device Handlers, I see tonesto7: Nest Virtual Thermostat listed directly below tonesto7: Nest Thermostat. I could click on that and delete it but I want to make sure that this is the right thing to do as I don’t see anything about removing the device and then deleting the device code.

Do you mind spelling this out a bit?

just disable the virtual thermostat under Nest Automations > Thermostat Automation > Remote Sensor Config

Once you do that and press Done until your back to the smart app list it will automatically remove the device from your things list (Only if it’s not used in any routines or other smartapp) then go into the IDE > My Device Types and delete the virtual thermostat device.

If the device is in use just go to those routines/apps and change them temporarily to your physical thermostat and then you can change them back afterwards.

I apologize for the inconvenience but we have learned some things that helped simplify this process and use the same device as the physical thermostat. So in the end it’s easier for us to maintain and easier for the end users to only have to update the one device.

A little confused. Do this under Nest Manager in SmartApps in my Android app? Do I do this for each Thermostat in “Manage your Automations”? When I’m in each thermostat, there is a section titled “Remote Sensor” but it is not turned on but I still have the Nest Virtual Thermostat under Device Handlers in my IDE.

Thanks. Before the Eco update this is how I had things working and it did work great. Since then (even with the protects and thermostat sensor disabled) the device refuses to stay in away mode. It will work for 1-2 hrs and then suddenly it’s “Home” again with no intervention. There aren’t any schedules set or anything. I honestly think it is a software bug but can’t get Nest to agree. The only solution I’ve found that works is putting the device into Eco mode manually, hence my question. If I could get the Home/away functions on the thermostat to work I’d use them.

A little confused. Do this under Nest Manager in SmartApps in my Android app? Do I do this for each Thermostat in “Manage your Automations”? When I’m in each thermostat, there is a section titled “Remote Sensor” but it is not turned on but I still have the Nest Virtual Thermostat under Device Handlers in my IDE.

I see the same thing. Away mode no longer sticks and the nest changes back to Home whenever it thinks there’s someone/thing at home. You can see that the the request to revert to Home does not originate from smartthings so is clearly a Nest bug.
Like @robweberjr if you directly set the mode to Eco rather than “Away” in the native nest app then it never reverts. Is there some way to do the same via Nest Manager?

If you plan on using ST and Nest Manager to modify your home/away it is highly suggested that you turn off home/away assist under the Nest Mobile app to prevent the tug of war

Those details simplify this greatly. Since you are not using the virtual device you can just remove it from My Devices Types in the IDE and all will be well :slight_smile:

Thanks. So now I go to “My Device Handlers” and delete “tonesto7 : Nest Virtual Thermostat” from that page?

Thanks. So now I go to “My Device Handlers” and delete “tonesto7 : Nest Virtual Thermostat” from that page?

that’s correct

Done! Thank you!

1 Like

Like both @robweberjr and @a4refillpad, I am seeing that the Nest is automatically going back into Home mode without being instructed to by ST/Nest Manager. Clearly, this is not an issue with Nest Manager, but rather with the Nest software itself.

It certainly explains why things have appeared to be acting weird since they “upgraded” to Eco temperatures.

Well that was awesome… I opened up a chat with Nest and explained the issue in detail. The support agent hung up the chat without saying anything.

Hopefully this next agent is a little better…!

@triphius I really doubt Nest will listen as it works fine if you change the mode to eco manually.

I believe we have already disabled this in the app. The away mode is behaving like auto away and ignoring the fact that we have disabled all our stats and protects from detecting presence. This is not a Nest Manager bug but a nest one.