[RELEASED] Arlo Assitant - Arlo Enhanced management from smartthings

@willieu

As far as a disarmed mode that is in effect just not having a Active mode in Arlo Assistant. Part of the setup for Arlo Assistant is to set your Smartthings mode to be active, but to also set the mode to take no action or notification when motion/audio is detected on the cameras. This in effect is a disarmed state. If you wanted to represent this in Arlo Assistant you could have a mode that is triggered by whatever in Smartthings you want to represent Disarmed, but it isn’t needed. SHM integration only works with the Classic app. You can use virtual devices in the new app though with STHM, and then use that virtual device with Arlo Assistant to integrate with the new app.

@Scott_Chapman

It is just a smartapp that uses the official integration. So if the official integration is having a problem then Arlo Assistant will be impacted as well.

Mavrrick, thanks for the response. My experience has been that I could leave the cameras on all the time. During the day I would set the Arlo mode to Disarmed which seems to basically turn off the motion/audio sensors in the cameras. When the ST alarm was turned on the Arlo mode would be set to Smartthings (or Armed). Arlo Pilot managed this. My batteries still lasted for months. However if the Arlo mode was set to something other than Disarmed during the day (ongoing motion around the house) the cameras would pick up on the motion even though the notifications were being blocked. The batteries would only last days/weeks. I will just continue to turn the cameras on when I set the ST alarm and turn them off when the ST alarm is turned off.
As an aside I’ve discovered that I can leave the Arlo Smartthings mode configured as it was for Arlo Assistant with no notifications and sensitivity set to 0. It has proven to be simpler to configure those things only through the Smartthings app.
Thanks again for your help.

Bill

@willieu

Sorry i misunderstood

You want to use the option in Arlo Assistant to set what cameras are on and off in the given mode. So you would set a mode to trigger with SHM going to disarm. Then set the cameras to be turned off when in the mode. Just remember to set the other mode to have them turn on. The option for what cameras are active and not active is on the first screen when setting up the modes.
This will have the same battery saving effect as the disarm mode in Arlo.

I recently migrated to new SmartThings app (not classic app) and ever since Arlo assistant stopped working. In the new app, is Arlo assistant still able to trigger recording?

I honestly haven’t tried it, but the Smartthings app shouldn’t make a difference. Also i have been exclusively used the new app for some time so it has been working there.

Two possibilities. 1. Arlo has made a change on there side with the camera connectivity. Earlier this year arlo broke camera recordings on certain hubs. 2. Is smartthings disabled the ability to trigger recordings from a smartapp. I will set something up so i can test the recording module

I just noticed something strange. It appears that my cameras got disconnected. Not sure when that happened, but i don’t remember doing it. Make sure your cameras are still visible through Smartthngs. The camera devices in Smartthings look very different as well. I am wondering if all of the cameras got turned off and and need to be reconnected.

I did validate the methodology is still working with my simple triggered recording app. it does seem to continue to work.

2 Likes

I have Arlo Assistant appearing in my SmartApps on the new app. However, when I try to setup anything, I get the following error message and am bumped back to the SmartApp page:

“We’re having trouble connecting, Check your network connection and try again.”

I tried using my cell network and two different wi-fi networks.and get the same error.

I just went through the process of installing a Arlo Assistant test mode and it worked fine. Can you provide some clarity as to what is exactly happening when that error occurs.

I would suggest you make sure you have all of the code loaded in the IDE, and that it is the latest copy. I would also suggest you make sure you have the latest version of the new smartthings app.

What is the latest version and where can I get it? I am showing 0.1 prerelease. I am new to ST and SmartApps via Groovy, so please understand. That said, I have been working with computers and programming for decades, so I can learn quickly.

.

The latest version is in the github repo listed in the first post of this thread.

I guess I was in the wrong repository. I pulled it from Master and that seemed to fix it.

Is there a way to capture snapshots periodically like there was in Arlo Pilot?

How are you going to use the snapshot. Do you just want it in your arlo library.

I want to make it show up on my Sharptools console. I would like it to take a photo on motion detection that is stored in a location accessible to Sharptools, say via a URL. That way I am not burning up the camera battery with video or timed photos.

Ok. So you can use a smart app to take snapshots in a variety of ways.

The problem is making them avaliable to external apps. Simply put that requires interactions with a device in smartthings to have the pic. Arlopilot used a virtual camera device that acted as a proxy to the image. I have yet to figure out that part of the integration. So Arlo Assistant doesn’t have a way for you to make it avaliable to external app like sharptools. I have looked into it a few times and so far haven’t figured it out yet.

I’m having a difficult time logging in to Arlo through Arlo Assistant. I imported the smartapp through SmartThings API and settings in the smartthings mode (though it has to either send notification or e-mail or it doesn’t let me save).

When I go to Arlo Assistant in the new SmartThings app and attempt to log in with my Arlo user name and password, it doesn’t seem to connect and and says “Login Error, ArloPilot was unable to login to the Arlo cloud. PLease check your credentials and try again.”

I’ve disabled two-factor authentication to try to get it working as well as updating my password. I’ve even removed arlo from SmartThings and readded it to no avail. I’m using the lastest master branch from Oct 25th

Honestly I am not sure what you are looking at. There is nothing in the code that does a log in to the Arlo Cloud. The only log into the Arlo cloud would be the official Arlo integration.

It also isn’t written to use the Smartthings API, but to use the Legacy Groovy IDE.

Are you using some new tools to convert it from the IDE to the Smartthings API?

He did mention arlo pilot and arlo assistant in one paragraph, two different apps.

I must have had a blind spot in my mind every time I tried settings things up. I was selecting the old ArloPilot smartapp whenever I did it, but it just never registered that I was selecting the wrong one.