[RELEASED] Arlo Assitant - Arlo Enhanced management from smartthings

@BobbyGraph
I use the standard DTH that loads when setting up the integration.

OK so the below quote answers my question.

Now that I think about it I wonder if it is something about a different IDE shard. What region are you in. Perhaps the shard has a different DTH because of some sort of regional thing.

This potentially has far reaching changes. This will impact the Helthcheck app as well. You might as well turn that off as well

@BobbyGraph

I have updated the recording routine to account for what you have uncovered. As of the last update the recording routine will now submit a recording if it can’t validate the status. Before this last update the app would never have worked for you. This may also be what is causing @tweason problem.

Keep an eye on your recordings if it does work for you. I don’t know if the same issue will be present for you that created the need for the health check child app in the first place. If your recordings stop working we will need to do further research to find out what we can use to identify what is the bad state.

I look forward to hearing how this goes. I will really need your help as from what you can see above I can’t produce this environment myself.

Sorry for being late to the party, but yes, those were the errors showing up in my logging as well. Just updated the child apps. Will give it a go.

Also, as a workaround, if you create a second set of virtual switches(I actually used momentary buttons) just like the ones for the health check, and trigger those as the Light action, it recorded for me (at least once).

This means you need an IFTTT Rule that records when each switch is triggered. If you do not have too many cameras, that might be a viable solution.

@Mavrrick58 it works! :smiley:

I will test more deeply but it looks good.

debug Capturing at Sat Jun 22 19:20:06 UTC 2019 to Sat Jun 22 19:22:06 UTC 2019…
debug Sending cameras message to record with 120 second capture
debug Camera is not recording. Submitting clip to record.
debug Camera Status is Completed
debug Ruleset 1 event

  • [clipStatus]: Completed now appears in my Device states

Thanks

If it Is creating the state once it runs make sure you setup the health check again. Also make sure the re ipie in IFTTT isn’t disabled.

@Mavrrick58

Ok I tested even more today.

Motion are detected and the recordings are started.

First obversation, I find that the Health Check is launched often, even after every registration. And sometimes, even with IFTTT, the status does not come back so I have more than one IFTTT record in my Arlo library.
I have the impression that it is probably my time settings that are involved. Currently, I have 60 sec records in my modes and I have configured the Health Check with Setup 300 sec and IFTTT 300 sec. (And a record of 10 sec at IFTTT). Can you give me some advice?

Second, I use a virtual switch and I realized that when I close my switch, the mode does not stop.

I looked in the code and I added this line to line 480 and now it works:
subscribe (virtualSwitch, “switch.off”, modeTriggerEvt)

From what I realized, there is a trigger only when you put a switch on and not when you put it off.

Thank you

It is great to hear it is working well for you.

The health check does run often, and is something I really don’t like but keep in mind that it is there to fix a issue with the arlo integration we don’t control. So basically making the best of it unfortunately.

My suggestion is to set the health check between 10 and 20 seconds longer then your actual record time in the mode. If your modes trigger 120 second clips set the Health check to 130-140 seconds. The second value for the IFTTT should be similar so I always keep min between 20 and 30 seconds.

Having the values longer will just prevent you from being able to record until it is corrected.

That is a good catch for the virtual switch. Prior to the last big update that introduced real modes the switch state was used to validate if the action should take place. This makes allot of since considering how the app works now. One thing I will change though is to remove the specific state of on or off. instead of adding the other. It just reduces the lines of code. I will validate this before I post it out there though.

Thanks man :blush:

ArloPilot 1.4 had “Last captured image external web links for ActionTiles.” I literally just bought ActionTiles only to find out that ArloPilot just stopped working.

Can we do this with your Arlo Assistant?

As of right now, no. That functionality is also likely what got Arlo pilot axed.
I would love to bring it back, as I used it myself. I just dont see how to right now.

Landed here after searching for an ArloPilot fix. I see that Arlo plugged up that hole and it’s gone forever.

I’m trying to figure out what Arlo Assistant does now. Can’t you achieve the same results using the official Arlo integration and WebCoRE?

The goal with arlo Assistant is to mimic modes in the smart things environment with the triggers arlo pilot provided.

The official integration does not provide you a way to initiate recordings or control how the cameras work from Smartthings, for the most part it simply allows you use the cameras for information, or to interact with smartapps like Arlo Assistant or SHM.

You may be able to use webcore for some of the features but not all of them I suspect(or atleast not easily). Plus it is just one more cloud component to fail. If you want to attempt to use webcore to do so I am sure there are a few that would like to see your scripts when you are done.

I have found a last image thumbnail url provided by the official integration. I am trying to figure it out in my spare time.

Also the more I look at that I don’t see how the images are related to arlopilot being axed.

2 Likes

They were claiming too much bandwidth because people were setting the refresh rate to be too often. I actually think they just said that and banned ST because they did not want outside access to their modes. It happened coincidentally about a week after someone posted of the existence of the ST app in one of the Arlo forums where people were complaining that it has been a request and “in the works by their engineers” for several years.

Just another reason I am migrating to Nest. They may be proprietary, but the app actually does everything it claims to, and the feed is almost instantaneous. Oh, and there is a chance (slim) that once they switch to Works with google assistant from Works with Nest, that we may even have the same features as we used to have with Arlo. I know I am loving what I have so far. Action Tiles integration is AWESOME. Too bad Arlo doesn’t allow that either.

Yea. I get that. I have even repeated that a few times myself because it was the only thing that made sense. The problem I am having is as I dig through the code for arlo pilot to understand how Steve did it I am not sure that is what was happening.

It appears every time a clip is created, a image URL and a clip url is created in Smartthings on the Smartthings servers. It seems possible this action never left the smartthings servers. I still haven’t fully figured out what Steve did though yet so I could be wrong.

I just need to figure out how to externalize those URLs That are created with each clip. If I can figure that out i may be able to bring back external access for the image tiles.

1 Like

I was more interested in the mode management.

Did you contact this guy?

Yea. And actually implemented his solution for a little while. But what his suggestion requires is a always on server you manage to handle the communication. It simply uses ssh tunneling to route the traffic to Arlo servers and hide the connections source. So it doesn’t fix the issue and potentially could get allot more connections blocked

Yes exactly! Like presignedLastImageUrl or presignedSnapshotUrl or presignedFullFrameSnapshotUrl.
I tried playing with those myself after toying with the arlo python from jeffreydwalter on github but I don’t know anything about coding.

Oh I’m not using the SmartThings with Arlo anymore. Arlo now allows you to use GeoFencing with the Schedule mode. So when I’m away it sets the Arlo to Armed. When I’m home it’s set to scheduled so there’s no notifications until between 10pm and 6am. It’s not the best but it cuts down on the notifications and I still feel somewhat protected.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.