[RELEASED] Arlo Assitant - Arlo Enhanced management from smartthings

I have just posted a update to the Camera Ready Check Child app. So the update is fairly simple, but requires a bit of other setup to fully implement. Details below

First the problem with the Cameras getting stuck in a bad state is unfortunately not something that i have found a fix for from smartthings. Every command that i see we can submit from Smarttthings doesn’t trigger the bad state to reset. It appears this is a value that doesn’t refresh from Arlo unless a recording is completed in the arlo cloud. The good news is that there are other integrations. IFTTT can trigger a recording based on a switch or contact being triggered. The latest update to the camera ready check will allow you to specify a switch to be triggered when the camera is in a bad state. With IFTTT setup to trigger from that switch you will get the camera back to a good state.

The setup steps would be

  1. Create a virtual switch for each camera’s health check
  2. Setup IFTTT with a task that when that virtual switch is tripped to trigger a 10 second recording for the camera you want to fix. You may need to add the device to IFTTT before you can associate it.
  3. Update the Camera Ready check smartapp to trigger the virtual switch when the bad state is found.

I also didn’t find a standard recipie on IFTTT for this, so i had to build the recipie myself from the IFTTT Mobile app

I am testing this method now, but it appears that it should work fine.

Mavrrick - I installed the Smart Apps via github, but when I attempt to launch them through Smartthings Classic I get a something went wrong error.

I will need a bit more information.

  1. I need to know exactly what you are doing when you get the message something went wrong. Are you doing the initial setup of the parent app, or are you trying to setup a mode or the camera check part
  2. What are the exact actions you are taking when it occurs.

I just installed the app to an extra location I have for testing. So it makes me think something hiccup’d with the install from github. You may want to compare what is in your instance of the IDE with the total lines from github.

Initial setup, but to clarify which app is the parent app? The error happens on launch of app, before trying to configure anything.

I will 2x check the IDE line counts.
Thanks

The parent app is the one labeled Arlo Assistant. That is the only one that needs to be published. The needed child apps are: Arlo Camera Ready Check and Arlo Smartthings Mode.

The other apps in the repo are apps that I had used for reference from other activities I have worked on in the past. Some of there code was barrowed to create Arlo Assistant and its child apps.

With that said the only app that needs to be in your IDE and published is the parent app. The 2 child apps just need to be in your IDE. If either of those child apps are missing that may cause the problem you are experiencing as well.

The parent app is pretty much just a container for the others. I do that so you dont clutter your app list with a bunch of apps that serve the same general purpose. Between the camera check apps and the mode apps I have about 15 instances. It can grow quickly. I am still toying with the idea of providing the option for rule sets in a given mode. It will balloon out the code if I do it though.

Thanks I think I have it working now. Now the fun part of figuring out how to activate and deactivate cameras based on the Smarththings Modes.

Just remember that the way Arlo Assistant works is by matching the current state to the mode values you set in the app.

Think of the flow of how it works like this.

  1. Your smartthings device has an event. Lets say motion. Smartthings tells your Arlo Assistant Mode app, Hey i got this device.
  2. Then the program says ok do i match the criteria for me to do something. If the current state of your location matches those criteria, it will then trigger the actions
    a. The actions are to any combination of: Trigger a recording, Turn on Lights, Activate alarm, Send a notification.

With that understanding deactivating is simply to not configure a qualifying mode.

There is also the act of turning off the camera’s switch value. That effectively turns off motion and audio detection. That is something I haven’t actually added yet, but i do have plans for it. right now though i have been focused on the other items.

How did you get it working? I’m getting the same message when I attempt to a Arlo Smartthings integration mode.

Ok so based on what you said above your issue sounds different. To confirm I am understanding you right can you can confirm if this is right.

  1. Go to manage your smartapps.
  2. Click on Arlo Assistant
  3. Then click on “Arlo Assistant Mode Management”
  4. That will take you do a new screen. And here you click on “Create Arlo Smartthings integration mode”. Make select some conf options and click on save and get the error is that correct?

If the above is true can you help me understand what options you are using so I can test the combination myself to find the error.

If it happens before that point I would suggest you check each piece of the app as I listed them out above. You only need the Arlo Assistant parent app loaded in the IDE and published, but you do have to have the camera ready check and Arlo Smartthings Mode child app in the IDE.

Update: It’s working now. The child apps were missing in the IDE, I must’ve removed everything and started over, and forgot to add those back in. I’m not sure what the original issue was, but it’s working now!

I have published the parent app, and have both child apps in the IDE. The error occurs immediately after I click on ‘Create Arlo Smartthings integration.’ (Also, if I click on ‘Create Arlo Camera Health Check.’) I have ADT Tools 2 working, and verified it works properly with the Arlo cameras. I’ve deleted / recreated my location, and reinstalled both Smartthings apps on my phone. I’ll try what you suggested. Thanks.

When I hit ‘Update From Repo — ArloAssistant (master)’, nothing shows up. Am I the only one? Thanks!

Are you in Smart Apps? Or Device Handlers? You should be in Smart Apps. (I had the same issue then realized I was on the Device Handlers page.)

1 Like

I have updated the Camera Ready Check app with a new variable and added a new function to ensure that the camera comes back to a good state.

Simply put I was seeing several instances of my cameras getting stuck in the bad state and even though the IFTTT applet was being submitted to fix the issue, they camera was not getting updated. This update adds a recheck basically to validate the IFTTT action worked and completed.

I suspect this whole problem is related to some kind of timeout or rate limit of the connections. That just seem like the most likely cause at this point. My guess is that something is busy on the Smartthings side. When the update comes back from Arlo it runs to long at some point getting back and just get dropped.

Thank you! Yep, I was in the wrong page.

Does this mean we need the “Smartthings” mode in Arlo for this to work? I deleted mine because it was alerting everytime motion was detected on any of my cameras (I did this Pre Arlo assistant back when ST Flubbed everything up by deprecating the Arlo Pilot app)

Also, for the IFTTT trigger, what to we need to set up in the app to get that working. Assuming we can create our virtual switches and name them anything as long as we associate them in the assistant app. How do we do that (Or did I miss an option in the assistant app?)

This is a great update! I am trying to decide if I should go through the effort of removing Arlopilot and moving to this…or even switch back to the stock smartapp. The reason is because I only use the integration to activate/deactivate the motion/audio detection and recording based upon the SHM and Routine changes in SmartThings.

I leave Arlo in “active” mode 24/7, but have specific routines that switch the cameras on and off at certain times. They also switch on and off when I leave the house or return.

Should I leave it as is, switch to this new SA or maybe go back to the stock SA since I am not using any of the other functions?

Does your arlopilot still work? Mine broke when they deprecated

@tweason

I am trying to spend some time creating documentation at Arlo Assistant at Things that are Smart.com right now. There is no doubt there is a fair amount of setup. And unfortunately there isn’t a one size fits all setup.

The way to setup the cameras depends on which ones you have. The gist of it though is you want the Arlo Cloud to have the cameras in a mode that will allow them to be enabled for motion and audio detection, but limit their recording and notifications. I have a setup explained on things that are smart.com that I used for my arlo cameras.

To create the virtual swtiches follow the below steps

  1. In the IDE go to the My devices page
  2. Click on the “+ New Device” button in the upper right
  3. Provide a Name, Label, and Device Network ID. They don’t have to be anything specific, just let them be unique from other devices you have. I would make them the same though.
  4. for the Type click in the drop down and scroll down until you find virtual switch or momentary button. And select that.
  5. Click on the location and hub drop downs and select your location and hub.
  6. Click on “Create” you should now have a new device out there.

If that device does not work you can also use the virtual device i am using for it from here ADT Tools virtual button. Just remember if you do it will be at the bottom of the type list when setting up the virtual device.

I really wish the IFTTT thing wasn’t needed. It complicates things. I have been tweaking it as I have been going trying to make it bullet proof. So what you will need is the virtual switch or a virtual button device in the IDE. Then to create the recipe in IFTTT. To create the recipe in IFTTT you will need to have it linked to both your Arlo Cloud account and Smartthings. Once that is done you will want to log into IFTTT either on your mobile device or the web. On the web click on your user name in the upper left and click on “New Applet” From the mobile app click on the icon in the lower right to display your Applets, and then click on the bit + in the upper right corner of the screen. At this point you should see “If +This Then That” Click or tap where you see the “+This” and you should be taken to a screen to select your service. Select Smartthings(or search for it if is not visible) and you can select the Smartthings Trigger. Now select “Switched On”. Now you will need to select the Virtual switch you created in smartthings and click on “Create Trigger”. Now you will go back to the If This Then That display, but the + is next to That. Click on “+That”. You are again selected to select the service, but this time you will select Arlo (or search for it if not visible). Select the option for “Start Recording”. You will be taken to another display that will give you the option to select a cameras and set how long to record. I set this to 10 seconds. Now select “Create Action”. You will get a Applet Preview where you can name it, and click on Finish.

@mejifair

Unfortunately it is hard to say if you should or not. Arlo Assistant will certainly allow you to trigger actions based on SHM Alarm Mode, and you could set your routines to trigger virtual switches for them to define how/when things will happen. I am also still tweaking the app allot. to find the best balance of functionality and complication of setup. You are more then welcome to try it out though as it can’t hurt anything.

Got it.

Now, does the health check automatically turn the virtual switch off? Or should it be a momentary switch?

Momentary switch would be better. That way you don’t have to turn it off after the fact. The health check does not turn that off automatically.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.