[RELEASE] Zooz Smart Chime

I did some testing and Routines execute the on command and then the set level command which explains why it wasn’t working as expected.

I’ll add the setting I mentioned when I have a moment, but in the meantime you should be able to just use Smart Lighting.

2 Likes

Hey Kevin,

It seems the routines fire the turn on chime and then the beep with selectable tone (by the dimmer.) So the beep is firing but it just fires the turn on chime first. Idk if that helps at all.

Thanks again for checking it out!

I’ve released a new version that allows you to set the Switch On Sound setting to 0.

If you set it to 0, the Switch On command will be ignored which will allow you to play a specific chime using the Turn on and Set Level action in Routines without it playing the switch on sound first.

Let me know if that doesn’t solve your problem.

Thank you for the update. I’m sorry, I am having problems updating the code. I’ve tried editing the code in the custom device handler, saving it, and publishing it but that didn’t work. I also tried excluding the chime and re-adding the new code in the device handler but that didn’t work either. I see in the code that you changed the input for the chime in range to 0-10, that’s how I notice it isn’t working. In the ST app, the settings are still only allowing 1-10. I’ve googled the heck out of trying to replace, update, exclude and re-add. Nothing. What am I missing?

Thanks again

All you should have to do is click the edit link for the existing device handler, copy and paste the code over it, click save, and then click publish.

There’s no need to remove the device.

Make sure you’re looking at the “Switch On Chime Sound” setting because that’s the only one that accepts 0.

Thank you. I have updated the code Kcopy, pasted, saved, published) in the
custom device handler but it hasn’t updated in my Smartthings app. I don’t
know why. I will have to walk away for now and see what’s going on later.

Thanks again.

When you come back to it:

  1. Open the device in the IDE and change the type field to a different device handler.

  2. Delete the zooz smart chime device handler and verify that they’ve all been deleted (in case you created more than one by mistake)

  3. Create and publish the new device handler.

  4. Open the device in the IDE and change the type to Zooz Smart Chime.

  5. Open the device in the mobile app and change the value of setting “Switch On Chime Sound [0-10]” to 0.

Ok now I’m getting annoyed. I am logged into the graph.api.smartthings etc.
I even changed the definition parameters to Zooz Smart Chime1, resaved,
published etc. That was after I followed your instructions. It is still
showing up as the original. But in looking into the other options, My
Devices aren’t showing up nor is My Hubs. I am logged in under my account
for both the web portal (graph etc) and for the ST app. What am I doing
wrong? There seems to be some sort of disconnect between my ST app and the
smart things website.

It looks like you are not logged into the correct shard server where your hub is actually found. graph.api.smartthings.com gets you to the IDE, but not to the shard that your hub actually connects to. The correct URL should say something like graph-na01-useast2.api.smartthings.com. Only when you access the correct URL for your shard will you be able to see your hub and actually publish DTHs to your individual hub.

To get graph.api.smartthings.com to redirect you to your shard, try selecting My Locations at the top of the IDE and then select your individual location from the list. You should see the URL change to your shard and your location will show on the screen. Once the URL changes, you should be able to see all your devices and update DTHs, etc.

Alright, I figured out the issue; multiple locations. I was able to delete
the erroneous location and see all of my devices included the zooz. It’s
updated with 1.2.2.

However… Now when I set the on chime to 0, nothing plays in my routines.
Although when I set it to 1-10, the beep never plays as well. Idk if it is
something with the code or something I’m doing.

Ok now I’m getting annoyed. I am logged into the graph.api.smartthings etc.
I even changed the definition parameters to Zooz Smart Chime1, resaved,
published etc. That was after I followed your instructions. It is still
showing up as the original. But in looking into the other options, My
Devices aren’t showing up nor is My Hubs. I am logged in under my account
for both the web portal (graph etc) and for the ST app. What am I doing
wrong? There seems to be some sort of disconnect between my ST app and the
smart things website.

The Beep Chime Sound setting is only used when the device is selected as a Tone Generator and none of the built in SmartApps support that so it doesn’t matter what you set it to.

Set the Switch On Sound setting to 0 (do this in the SmartApp, not the IDE)

In your routine, use the Turn on and set level option. If you use 20% as the level, it will play Sound #2.

If this still doesn’t work, post screenshots of the chime settings and the routine you’re using to play the sound.

Unfortunately, it doesn’t play anything when I set the chime on to 0. Here is the screenshots of both the settings and my routine.

Ditto here…my setup matches the screenshots, and the results are the same. That is, with the switch on chime set to zero, I get no chime. With it set to something else, I get that specified sound, and the dim setting is ignored.

Using those same settings, when I tap the routine to execute it, everything works as expected.

If you’re seeing different behavior, use Smart Lighting or SHM instead of a Routine.

Sweet! Using SHM gave me control over the chime! With Smart Lighting, I could get the configured sound only. Thanks for the hint. So…Using a Routine or Smart Home Monitor, I have control over setting which chime to use. I have the “Switch On Chime” setting in the Zooz config set to 0, and then I choose the “Alert with Lights” option in the SMH config or the Routine definition, and set the dimming percent to correspond to the desired sound. Under Smart Lighting, I can get the beep defined in the Zooz config, but I cannot select a sound for a lighting function using the dimming settings. Using the SMH config or a Routine work perfectly, and accomplishes exactly what I want. I love the Zooz Chime/Alarm!

Sorry, I’m a noob, can someone explain what a SHM is and how to use it?

Thanks!

Sorry, I should have googled that first. Smart Home Monitor, got it. How can I set separate chimes for armed (home) and armed (away)?

Hi Josh,

You can set different tones for different scenarios if you choose Alert with Lights in the Smart Home Monitor app instead of alarms - the Smart Chime will come up as a dimmer and you’ll be able to choose different tones by adjusting “brightness” percentage (0% brightness is equivalent to Tone 1, 20% brightness is equivalent to Tone 2, 30% brightness is equivalent to Tone 3, etc.).

1 Like

Smart Home Monitor doesn’t provide a way to provide different alerts based on home or away so you’ll have to use a different SmartApp like @TheSmartestHouse recommended or use a Custom Monitor in Smart Home Monitor instead of the Security Monitor.

Playing different sounds using the Level/brightness has worked fine for me with Smart Home Monitor, Smart Lighting, and Routines, but it seems like others are still having trouble with some of those SmartApps.

I just released a new version that temporarily changes the switch status to on when the on command is executed which might solve the problem that others are experiencing.

I’d appreciate it if those users could try it again in the SmartApps they were struggling with and let me know if it’s working now.

2 Likes

That did it! I set up a routine with various dimming levels and heard different sounds. Of course, in the settings of the zooz, the chime on level was 0 (for other users that may be struggling.)

Thanks again! I had the SHM working with custom monitors with different sounds triggered by the current state (home, away, night) STs was in. That works quite well too.