SmartThings Community

[RELEASE] Zooz Power Switch / Zooz Smart Plug

dth_powermeter
dth_sensors
dth_outlet

(Kevin) #161

The caching issue is when you turn it on through the app and the device turns on, but the tile still says off. Or you physically turn it on/off and the tile in the mobile app doesn’t change. If you check the IDE it shows the correct state and if you go back to the things screen and re-open the device it usually refreshes to the correct state.

If it was working flawlessly for weeks and then this device and other switches are having the same problem, it’s definitely the platform and has nothing to do with the device or DTH.

You may be back up, but that doesn’t necessarily mean that everything is working the way it’s supposed to.

All I’m saying is that any time SmartThings actually reports that the platform is experiencing problems, that’s a really bad time to start troubleshooting problems.

Last time the issue of the state changing in the app without the actual switch changing came up, it was happening to all switches and a couple of users had support tickets for their Aeon switches since they’re supported by SmartThings.

We also realized at that time that something was executing the device’s refresh command every 15 minutes and it ended up being the Alexa SmartApp, but SmartThings finally fixed that.


#162

I do understand your point. However, it has not worked flawlessly for weeks. Further up this thread I showed evidence of this issue that has been around for a long time. It comes and goes.

Fair point.

And I do see this on many devices - not limited to the Zooz. However, in my case, that is not the issue I am reporting. Mine is where the ‘system’ suddenly thinks the device has changed state when it hasn’t.


(Kevin) #163

I was quoting the other user…


#164

Got it, thanks,


(Kevin) #165

Last time we had this discussion you reported the problem happening with other switches and you posted some emails you had with support about another device and they blamed the device.

@johnconstantelo did the same thing, but SmartThings blamed his problems on a bad hub.

That’s why I don’t get why all of a sudden you both think there’s an issue with your device’s firmware or the DTH…

As soon as the platform stabilizes these problems will most likely go away again.


#166

I haven’t apportioned blame to anything. I’m just stating what I see happening. I apologize if it seems I’m blaming the handler. That’s not my intention.

Yes, ST blamed the device but that’s nuts because it’s across all sorts of different devices. I believe there is some systemic issue in ST.

I have seen this issue consistently at times outside of these platform instabilities.


#167

Well, kind of. 2 weeks ago my garage fridge stopped cooling and it’s on a Zooz device. I powered it down via the ST app to replace the fridge’s controller board. The switch did indeed turn off, but the state in the IDE and app was still “on”.

This problem has been lingering, but I haven’t toyed with it because I never turn these off, until my fridge incident, and now this updated post got me thinking about it again.


#168

So for me, the situation was that the switch was on but was showing off on my ios mobile apps. It was also failing to respond to repeated automation calls to to the switch off (I use a thermostat app to control the switch which powers a space heater). When I discovered the situation, I tried several “turn off” commands through the mobile app, with no effect. After I physically toggled the switch on and off, it seems to be behaving again both to the app and to automation commands. None of my other smarthththings devices were working improperly, bit this is the only ZEN15 I have.

Things had been working fine since I got the switch, which has been just for ~3 weeks.

Not sure if that adds anything to folks ideas as to what the issue might be. Just wanted to clarify my situation.

Thanks


#169

I’m sorry, I also did not mention I am using krlaframboise’s driver - thanks for your work btw


(jeubanks) #170

I wish I had remembered zooz… I just ordered an aeotec plug that cost a lot more. Hmm…too bad it’s already shipped or I’d cancel.


(Kevin) #171

I know, but it definitely sounds that way when you make a statement like “We got no where trying to get it sorted out. Just scroll up in this very thread and you will see a ton of posts on it.” without mentioning that the reason you didn’t get anywhere was because it’s a platform issue.


#172

Given we’re in your RELEASE thread here I see your point. But I think my earlier posts do make it clear this is an issue affecting other devices too and seems to be systemic. I didn’t think I needed to repeat my earlier posts after referring to them.

To be fair, I have no idea where the problem lies. All I try to do is provide accurate information on what I see so maybe others can figure it out. While ST Support were responsive they really did not help and I hit a dead end on getting a solution, thus my comments earlier that you quoted.


(Kevin) #173

SmartThings just posted that the platform issues have been resolved so if it acts up again let me know and I’ll look into it.


#174

Sorry we missed the post and tag somehow! There’s only one version of the firmware released to date. We haven’t seen any issues with reporting status on SmartThings or other platforms except for HomeSeer where it reported correctly but the report was not included in the “mother node” but rather in one of the “child nodes” created by HomeSeer. We sent a sample to them and it was fixed within a day on their side.

The wrong images you saw was a computer generated graphic based on an earlier design (that’s how it’s done these days for most product). There has only ever been one version of the Power Switch in mass production. But if we’re seeing more complaints on this issue, we’ll definitely do some in-depth testing to make sure the firmware doesn’t need to be updated to work with the ST platform better.

Thanks for everyone’s input to the discussion and special thanks to @krlaframboise for the support!


#176

It’s in the settings … $/kWH Cost:. Note, I seem to have a bug in this and several other handlers that puts that long decimal in after I input a correct value.


(Joel W) #177

Thanks, looking forward to getting this working.


(Warren) #178

Hey @krlaframboise, I saw a few mentions about having a “Forced On” mode for the DTH. Did that ever happen?

I just reskimmed the thread and didn’t see if you actually did that or if you decided not to or what exactly. Like you, I use it for the sump pump and would want it always on. I’d rather not constantly have to blindly turned on by SHM or similar.


#179

I’m sure you thought about it already but what I do is set it to default to on in the settings when power goes off and I also have a smart lighting set up that automatically turn it on if it is ever turned off. Since you can trigger a smart lighting automation to turn a switch on trigger by that same switch being turned off. Just make sure you uncheck the bottom option of turn off too.


(Kevin) #180

I was about to make the change, but I thought of a few scenarios where that change could cause problems so I didn’t end up making it.


(Warren) #181

Ok, gotcha.

LOL, like the one in the cartoons where you can see the guy’s skeleton as he’s getting shocked?

-Warren