SmartThings Community

[RELEASE] Zooz Power Switch / Zooz Smart Plug

dth_powermeter
dth_sensors
dth_outlet

(Kevin) #245

I have a general idea of how often my sump pump runs so I’m also using CoRE to send me a notification if acceleration stays the same value for more than x minutes. I have to adjust x a few times a year because it sometimes runs every 1-2 minutes and other times it runs every 30-45 minutes. (Acceleration isn’t vibration, the handler just uses that attribute as a way to indicate whether or not the device is using power)

I also have a pvc pipe vertical in the pit with 3 water sensors hanging at different heights. (My groundwater has really bad iron algae so the pipe prevents build-up caused by occasional splashing)

If the water goes a little higher than normal it sets off the first one. The second one gets wet right before the backup pump kicks in so if the backup pump is working that sensor changes back and forth between wet and dry. If the highest one gets wet I’m in trouble because that means both pumps failed and my basement is about to flood.


(Court) #246

That’s pretty sweet. Looking to accomplish the same mission essentially, but my pit is outside to stop standing water from pooling up on the side of the house during heavy rains and causing flooding if it sits for to long. Might rig up something similar so if all else fails I have that to tell me water is over the top and I need to light my hair on fire!

Thanks for the pointer on using “Last Event Threshold”!


(Paul S.) #247

Hi all,

First post here. I just got a ZEN15 that I am trying to use to detect when my TV is powered on and off. I got the plug setup in Smartthings using the custom device handler from this page and it seems to be working fine. The only problem is, I cannot get it to self-report any data. The data only seems to change when I hit the “refresh” button after clicking on the device in the Smartthings app. This is the case no matter how low I set the reporting interval or value change interval.

I tried using the standard Smartthings “metering switch” device handler and another custom one as well, and they behaved in the exact same way. (In other words, everything worked, but the data only updated when I hit the “refresh” button.)

Has anyone else had this problem? Any help would be greatly appreciated.

Thanks,
Paul


(Kevin) #248

What do you have the Power Reporting Interval set to?

Do you have the “Display Power Activity?” setting enabled?


(Paul S.) #249

I have tried the Power Reporting Interval set at 5 secs, 30 secs, and 1 min… none of them seemed to work.

And yes, I have “Display Power Activity” enabled as well.


(Kevin) #250

Open the device in the IDE, click the “power” link, and check to see if it’s creating power events.


(Paul S.) #251

It is, but only at the times when I manually clicked the “refresh” button within the Smartthings app.


(Kevin) #252

It sounds like the group associations might not have been assigned properly during inclusion so I recommend removing the device and joining it again.


(Paul S.) #253

That did the trick! Thanks so much for your help… it is working perfectly now! =)


(Warren) #254

Hey @krlaframboise, I was looking at some IDE logs for the Power Switch and noticed the following warnings:

warn Unable to parse: zw device: XX, command: 3200, payload: 21 64 00 01 8F FE 01 2C 00 01 8F FE
warn Exception ‘java.lang.NullPointerException: Cannot invoke method parse() on null object’ encountered parsing ‘cmd: 3200, payload: 21 64 00 01 8F FE 01 2C 00 01 8F FE’

Seems like an unhandled status from the Zooz. Thoughts?


(Kevin) #255

I’ll look into it.


(Thenebulous) #256

I have a fun one going on right now that I am working with Zooz Customer support with, but it is stumping all of us.
I have a couple of ZEN15 switches I bought on black Friday, they seem to be fine, the Device Handler looks good (thanks Kevin!) but here is the issue I am having:
I have a network switch in my furnace room (yes I know there are better places but this was all I could do) so the room temperature sometimes gets up higher than I want it to. So when a temperature sensor tells me the temp gets above threshold value “x” it sends a notification to the ZEN15 to turn on & it runs an AC powered fan. (Approx 18W load as it is not a big fan). This functions just great.
I am using the smartthings ‘built in’ app for power consumption exceeded to switch the switche(s) off as I am actually trying this with both of my ZEN15’s and it won’t switch the ZEN15 off. Ever. I know that the signal is being sent as I added a spare GE outdoor plug to the same power consumption exceeded routine & that turns off exactly as commanded at the time set.
Zooz had me try changing the designation of the switch in the IDE to generic Z wave or just Z wave switch & all it does is removes the device handler functionality that I was enjoying. So I didn’t waste much time with this as it is, to me, not a solution.
I am no software genius, I am very much more the mechanical end of things, so I cannot tell where the issue is coming from, but my gut feeling is that it is not the handler, it is something on the actual chip programming in the plug itself.
Anyone else seen this issue, or have any thoughts on it?
Kevin, do you have any thoughts on this?
Zooz / Smartest House are working with me so don’t think they are not, I just wanted to try to tap into the wider knowledge base of everyone else to see if there is anything that might work, or if I am the patient zero for this particular issue, or that I may just have a couple of defective units.

The other thing I noticed is that even with zero load on the plugs, the puck itself runs warm. I measured mine at 30 degrees C steady state in a room that was 19 - 20 degrees C (Sorry, engineer here, I work in deg C!) They could not tell me if this warm feeling is normal or not. Both of them do it.

Thanks in advance to everyone!


(Jim Gaudette) #257

I’ve been trying to limit communications on my hub and although this isn’t a crazy issue can you shine some light?

I have a zen06 with all power reports set to none but it reports a change when it goes from 0w to .76w.

Any ideas?

I am still on old fw, fixing that tomorrow.


(Kevin) #258

After you upgrade the firmware you should switch to my Zooz Smart Plug VER 2.0 handler. (I’m not sure why I haven’t created a topic for it yet…)


(Jim Gaudette) #259

Do the 06 and the 15 use the same dth? I currently show 1.5 and 1.4. If so can I switch both to 2.0?


(Kevin) #260

No they don’t, but I should be posting the ZEN15 VER 2.0 handler this weekend.


(Kevin) #261

Zooz Power Switch VER 2.0

I just released a new version that supports the new configuration parameters of the Zooz Power Switch VER 2.0 (ZEN15).

I’ve displayed “(FIRMWARE 2.0)” next to all the options that are only supported by the new firmware and if you select an option that is not supported by your device it will display a warning in live logging when you save and ignore the setting.

The new settings are technically supported by firmware 1.3, but I don’t believe any devices were sold with that firmware.


(Warren) #262

There might be some confusion for others so I thought I’d add that the most recent Zooz ZEN15 firmware is v1.3 - there is no v2.0 firmware. The model number of the switch is v2.0 but the firmware it runs is v1.3 according to what I was told.

@krlaframboise:

  1. I only see one setting in the new ZEN15 DTH that has the “(FIRMWARE 2.0)” note next to it - the Manual Control option. You mention “options” so am I missing something perhaps?
  2. After updating the firmware, at the bottom of the settings screen in the new DTH, I noticed that the version changed from v1.2 to v1.3. I haven’t looked at the code but does the new DTH explicitly look for the text “2.0” in the version number when deciding to make settings or what exactly?

(Kevin) #263

I was told by Zooz that the VER 2.0 model would have version 2.0 firmware, but apparently I was given bad information. I’ll change the option labels in the code to reflect 1.3 and above.

The LED Setting has 2 new options.

The new settings work with version 1.3 and above so everything should work as expected after your firmware upgrade.


#264

Hi @krlaframboise,

I’m trying out your DTH, and caught these in live logging:

Any ideas where that’s coming from? My device is reporting firmware v1.2 for my ZEN15.