SmartThings Community

[RELEASE] Zooz Power Switch / Zooz Smart Plug

dth_powermeter
dth_sensors
dth_outlet

(Beau Thompson) #203

The problem is i can not get to were the device is i was hope there was some thing i cold look at on smartthigs


#204

While SmartThings doesn’t offer a network map tool, you can try Network Repair and if there are any connection issues, it should display errors for given devices:

  1. Click on the Menu icon on your app.
  2. Tap Hub is online
  3. Tap Z-Wave Utilities
  4. Tap Repair Z-Wave Network
  5. Tap Start Network Repair

(Beau Thompson) #206

what is checkInterval: and how is it set is a higher number better or lower?


(Beau Thompson) #207

Here what i got how do i fix this?


#208

It looks like the device may be out of range. How far from the hub is it? Do you have any other Z-Wave devices that aren’t battery powered installed between the ZEN15 and the hub? Is the ZEN15 surrounded by metal or glass surfaces?


(Beau Thompson) #209

I have run in to a problem
I am using two zen15
pump 2 reads Raw Description zw:L type:1001 mfr:027A prod:0101 model:000D ver:1.02 zwv:4.38 lib:03 cc:5E,25,32,27,2C,2B,70,85,59,72,86,98,7A,73,5A role:05 ff:8700 ui:8700
It is work fine i can read power
pump 1 Raw Description zw:Ls type:1001 mfr:027A prod:0101 model:000D ver:1.02 zwv:4.38 lib:03 cc:5E,98,72,86,73,5A sec:25,32,27,2C,2B,70,85,59,7A role:05 ff:8700 ui:8700 this i can not see power i think its in secure mode what can i do to be able to read data


#210

Hi Beau, it looks like the other one is added securely and it may be causing some issues for you. Please try excluding it from the hub and re-add it, making sure you keep the ZEN15 plugged in and DON’T use auto-inclusion. Instead, triple-click the Z-Wave button quickly to add it to the system (don’t press and hold, just press and release 3 times quickly). Hope that helps!


(Beau Thompson) #211

it is in a place that is hard to get to is there any thing i can do to the dth to make secure work


#212

This unit looks like it’s out of range based on the network repair report so unfortunately the only way to address this now would be adding a signal repeater between the hub and the ZEN15 to improve range. If you have another Z-Wave plug or any non-battery powered Z-Wave device that can be temporarily moved, please try plugging it in half-way between the ZEN15 and your hub to see if it improves communication.


(Beau Thompson) #213

i known in testing before put in place with the s it never worked


#214

Hi Beau, are you saying the switch never worked correctly even before you installed it at the remote location? If that’s the case, we recommend getting in touch with our support to have it replaced: https://www.thesmartesthouse.com/pages/contact-us


(Warren) #216

It’s a property, just go into the device’s settings page and enter the $ per kWh. As long as you’re using the bespoke community DTH, it will be in there.

In the Groovy IDE, the setting aka preference will be also visible here:


(Beau Thompson) #217

What i was saying in all my test before move if it was zw:Ls it never worked if it was zw:L it was ok


#218

Right now, if the ZEN15 is showing unavailable, this is most likely a range issue. If there’s a problem with reporting if the switch is included securely, it may be a SmartThings firmware bug and we’d suggest including it again not in the secure mode. There is no way to change between the secure and unsecure communication type once a device is already included, this is established at the time a device joins the network.


(Oli) #219

Thank you for sharing this code - I just got a ZEN15 and created the device handler. I’m using the latest Smartthings app on iOS 11.4.1, and when I manage to pair the power switch with my Hub it remains stuck in a “checking status…” state (when tap on that message it says check device and try again).

I’ve tried re-adding the handler, re-pairing and I don’t know what else I can do. Any help would be appreciated!


(Kevin) #220

I just posted a new version of the code that should work with the new mobile app, but the new mobile app doesn’t officially support custom code so if you want full functionality you need to use the Classic SmartThings app.


(Warren) #221

Unbelievable (almost). I looked at the diff and it’s like just a few seemingly nonsense properties. Any idea what’s the logic behind the Manufacturer ID (mnmn) and Vendor ID (vid)? I, apparently, didn’t get the memo as it were. And the only docs I found on it (https://smartthings.developer.samsung.com/develop/guides/manifest/requirements.html) are pretty basic. As far as I can tell, it’s just to control who is doing what when you’re using their cloud but since you can freely assign the values I’m not sure I get it completely. It’s almost like code signing where you could use any signature…useless.


(Kevin) #222

The Hub Connected devices aspect of the new platform isn’t finished yet so this is an undocumented trick to get custom handlers to work with the new platform, but it could stop working at any time.


(Oli) #223

Thank you so much! It worked on the first try. Enjoy a beer on me mate! cheers :slight_smile:


(Kevin) #224

Thank you, I really appreciate it.