[RELEASE] Zooz Power Switch / Zooz Smart Plug

Thank you for the help. I changed the settings in the device handler all back to default values in order to reduce the reporting. I changed the piston to use “Acceleration” instead of “switch is on” and I increased the time required to shut off the plug to get closer to the actual hour I plan on setting it to once it is working. I also set up your simple event logger app to a Google sheet (which works great btw).

I am now stuck with setting the “Report Inactive when power…” . I searched all over the forums for how to set up Report Inactive in WebCore and just could not find anything. I am also not sure what triggers an acceleration is active or inactive. Sorry if that is a dumb question but this is my first piston so I am still learning. If you had an example both the “acceleration stays active” and “report inactive when power” that would be very helpful.

I attached the current state of the piston. With these changes the only notifications I get is if I turn the plug on or off manually. So the condition of power stays greater than 10W for 10 minutes and acceleration stays active for 10 minutes must never register as true. My guess is that it is because I am not using the acceleration correctly and I can’t figure out the report inactive part.

The acceleration stays active line looks fine…

You need to set the “inactive below” setting in the handler to 10 and then delete the “stays greater than 10W” line from your piston.

Just closing the loop here. Using acceleration instead of power in the Piston and then setting the inactive below in the device handler is working well. I have to admit I don’t really understand why using power stays active did not work in the first place but I am happy to have a solution and happy to find your simple event logger app.

Thank you for the help!

1 Like

Hi, I recently got two ZEN15s and just updated the DTH to the latest version today. Now that a firmware tile has been added, I noticed that one of my devices has firmware 1.04 and the other 1.4. I also noticed in the DTH code:

private isFirmwareVersion2() {
    return safeToDec(device.currentValue("firmwareVersion")) >= 1.3

This means one of my devices has the new “FIRMWARE 2.0” features (e.g. disabling manual control) and the other does not. However, the official Zooz ZEN15 changelog shows 1.04 as the latest firmware version, with version 1.03 adding the “options to disable manual control and on/off commands from the hub”. So… I’m confused. Do firmware versions 1.3 and 1.4 actually exist, or are they actually 1.03 and 1.04 with some typo having occurred behind the scenes?

That’s my fault…

The device reports it as 1.3 and my older handlers didn’t add a leading zero, but some of the changes I made in the last update were copied from a newer handler which changed that.

Changing that line of code to 1.03 will solve your problem and I’ll post a new version later tonight with that change.

If you drag down on the device details screen it should force the refresh method to execute and change the device showing 1.4 to 1.04.

1 Like

Got it, thanks! I’m in no hurry so I’ll just wait for the update.

Edit: Send you a PR: https://github.com/krlaframboise/SmartThings/pull/51

The other device is stubbornly showing 1.4 instead of 1.04 even after several refresh attempts. Curiously, the first half of the “Raw Description” in the IDE is

zw:Ls type:1001 mfr:027A prod:0101 model:000D ver:0.00 zwv:0.00 lib:00

whereas the one showing 1.04 has

zw:Ls type:1001 mfr:027A prod:0101 model:000D ver:1.04 zwv:4.38 lib:03

Does this indicate some kind of pairing/communication issue with the former? The networkSecurityLevel for both is ZWAVE_S0_LEGACY.

I don’t accept PRs, but I just posted a new version that fixes the version number and it also requests a version report when refreshed.

If you drag down on the device details screen it should quickly show a refresh symbol when it executes the refresh command which will cause the firmware tile to update within 10 seconds.

1 Like

Thanks! Not sure why refreshing didn’t work; deleting and re-adding it did.

The latest version of the handler will fix the version number when you drag down the screen to refresh it. If it didn’t then the refresh command most likely didn’t execute and that’s something you could have verified by having log living open while you tried.

My hypothesis is that refreshing didn’t work because the device wasn’t properly paired to the hub in the first place (as evidenced by the IDE “Raw Description” showing ver:0.00 instead of the actual version number, as all of my other devices do). In any case, thank you for the update!

Something happened during inclusion that prevented the raw description from fully populating, but that has no impact on the functionality of the device.

The handler was configured to only request a version report if the firmwareVersion attribute was empty and yours was set to 1.3 which is why it wasn’t possible to refresh it with the previous version of the handler.

The change I made in the last update requests the version every time the refresh command is executed and I’m 100% sure that change would have solved the problem.

1 Like

I just set up my new ZEN15 today and I noticed that none of the boolean settings are sticking. Every time I turn off “Display Voltage Activity” or debug logging and return to the settings page, they revert back to on. I checked the device preferences list in the developer console and the correct values are reflected there. Is this because I’m using the new app? I read that the new app is not fully supported in a comment a few months back but unsure if that’s still the case.

Last time SmartThings broke boolean preferences they’d revert back to off every time you opened the settings screen, but they fixed that about a month later.

I just checked the Android app and those settings are working as expected so are you using the iOS mobile app?

The classic mobile app was retired so the new mobile app is now the only mobile app, but this handler is fully functional with it.

I’m using the Android app, latest version. I did more testing and it seems like the “Disable on/off control from the hub” settings are working. It’s just the “Display XXX activity” and “Enable debug logging” settings that are broken. I’ve tried resetting and re-enrolling the plug multiple times to no avail.

It looks like they broke boolean settings that have the default value true.

Deleting line 159 should allow you to set them to false.

That fixed the settings UI, thanks for the help! Gotta love samsung’s move fast break everything strategy with ST at the moment.

What do the display voltage activity and similar settings do? I had assumed that they would control the visibility of the corresponding tiles in the device screen, but turning off display voltage activity did not hide the tile.

At the moment, it’s not possible to dynamically hide tiles like that.

With the old mobile app those settings prevented those events from appearing on the history tab, but I’m not sure if they actually do anything in the new mobile app…

I see, thanks for the clarification.

Hello, Thanks for this. Not sure if this is still maintained but I just used this for first time and noticed the settings will not accept my kwh rate of 0.081 and will not accept anything less than 0.10 as an kwh rate.

Not critical but thought I would mention it, otherwise working great

There’s a driver available for the ZEN15 and ZEN06 on Zooz’s Edge Driver Channel.

1 Like