[RELEASE] Zooz Power Switch / Zooz Smart Plug

I think it must be something in the new firmware then. Using the new DTH, I have one ZEN15 that is reporting status normally as it used to with the old DTH. Also using the new DTH are several ZEN15 that have been upgraded to v1.3 which basically send next to nothing - even after a complete reset and repairing. Sounds like some QA is happening here.

One thing I will add is that old firmware or new, with the new DTH, I don’t see reports per the set intervals. For instance, if I set all of them to the minimum (like 5 seconds), I still get nothing much unless I hit refersh in the app. For instance, here is what I am seeing on a device with the old firmware:

Hitting refresh at 9:50 got me those two events at the top (and then the ST app updated) but in reality I should have been getting lots of stuff, no?

Uncomment the log.trace line at the bottom of the code and see if that makes a difference.

Ok, so there is definitely a difference here but not sure what the deal is. Here are three different devices, all with the new DTH:

  1. Old firmware idle device (sump pump) with default reporting

  2. New firmware idle device (sump pump) with maximum reporting (every 5 sec, etc.)

  3. Old firmware device off and then on (should be 300W+ on) with default reporting
    image

I have no idea what is going on since log 1 and 3 above are very different and log 2 is just odd IMO.

If I had to guess, having the device send 4 reports every 5 seconds is most likely flooding your z-wave mesh causing ST to drop most of the reports.

To test that theory, change them all to 30 seconds and see if the reports become more reliable.

1 Like

I’m getting something slightly different …

ZEN15 firmware 1.2.

Just wanted to check in to see if there were any updates or anything further on this?

We were able to replicate the issues when performing an OTA update from 1.2 to 1.3 and are still testing a new corrected file for 1.3 OTA. We hope to have it ready by the end of the week. We’ll post here as soon as it’s done.

4 Likes

We now have the new OTA file available for updates between 1.2 and 1.3 so just get in touch with us if you’d like to upgrade your 1.2 device: https://www.thesmartesthouse.com/pages/contact-us

2 Likes

I have noticed that interval reporting does not take place at zero watts. So it appears that my freezer completely turns off when it is not running. This leads to no reporting, and makes my energy plots look a little funny. Is there an easy fix for this?

You could disable power reporting based on threshold and use the frequency-based setting only, this way you’d get regular reports even if nothing is going on or if the value is 0.

@krlaframboise does this handler allow control over the USB outlets for turning on and off? Thought I had seen that somewhere but not sure if it was in this device or the power strip V2. Do not see any populated items either in the smartapp or webcore to acess those USB outlets at the moment.

The Zooz Power Strip and Zooz Double Plug report activity on the USB ports, but they don’t allow you to control them. I’m unaware of any z-wave devices that allow you to control USB ports…

2 Likes

What can i do if device status show hub disconnected?

Try tapping the refresh tile.

I have 2 ZEN15 switches, pretty much located right next to each other. After a few days, SmartThings will show ONE of the switches as HUB_DISCONNECTED/device health will show offline. The power readings, however, are still being reported and I can toggle the switch from the app. The only thing that fixes it for me is to power cycle the SmartThings hub. Next time the other switch will show offline.

I’ve reached out to both Zooz and Samsung and have been told it could be wifi interference (correct me if I’m wrong but Z-Wave and wifi don’t interfere with each other), repair z-wave network (which I’ve done numerous times), exclude then re-add to Z-wave network (works fine for a few days then the problem returns)… clearly it’s a common enough problem that there is a FAQ on this subject for this model.

I have plenty of Z-wave plus devices that should properly blanket my house with signal, so I think it’s just wonky and I have sort of accepted that this is how things are going to be for me.

After joining the device you should go into the settings and save to ensure that the reporting interval get sets properly. That can only be done from the Classic mobile app.

What do you have the reporting intervals set to?

I have 2 in my basement that are touching each other and I’ve never had a problem with them so I don’t think that’s the issue.

Where are you seeing the “HUB_DISCONNECTED” message because I’m pretty sure the only time I’ve seen that was when my internet was down or ST was having issues.

I’ve never seen the ZEN15 randomly report “offline”, but I’ve seen it with some of my other switches and toggling them fixed it.

If you toggle the switch and it responds, open the device in the IDE, click the “List Events” link, and see if there are “DEVICE” events from when you just toggled it. If it logged the events then the device should change back to online the next time ST checks it, but that might take a few hours.

Also check the date/time of the most recent “DEVICE” event that occurred before you toggled it. If there are recent events then the issue is definitely on ST side.

WiFi interference is only an issue with Zigbee devices. As far as I know, the only thing that can cause z-wave interference are objects that the signal can’t penetrate, like refrigerates, dense piping, furnace, etc., but if you have a strong mesh the signal should be able to work around them.

If you’ve never saved the settings then saving them might solve your problem, but if it doesn’t, try replacing the “2” with a “4” on line 271 so that it looks like below.
That will allow it to miss a couple more check ins before ST marks it offline.

def checkInterval = ((minReportingInterval * 4) + (5 * 60))

Please report back either way because knowing if any of those suggestions solve the problem will be helpful to other users. Zooz also monitors these topics so they’ll be able to let their support people know how to solve the problem for next time.

Thanks for your reply, Kevin. I am only using the classic app.

All intervals are set to default, but settings have been changed/saved in both of the ZEN15 switches (like kWh cost, disabling debug logging, etc).

In the SmartThings IDE under My Devices, Status column. In the app, it shows as unavailable and has the little red dot.

When Device Health is disabled in the app, the device looks and functions completely normally (but I also won’t be able to tell when other devices have disconnected due to battery, etc). It can be in an unavailable state in the app, but still be regularly reporting in under the “recently” section in the device, or even in the IDE (under last activity). And, as I mentioned, power toggle works just as effectively as the non-offline device, though I don’t use the switch in that way–I only want it for its energy reporting abilities.

Last night, when I noticed the switch offline, the last activity was about 8 hours prior. But the appliance connected to it hadn’t been used since the day before. As soon as I turned it on (it’s a washing machine), the switch began reporting power immediately, but remained in an offline/unavailable state.

I’ll give that a shot. I think I mentioned before that once one of the switches is showing offline/unavailable, it will remain in that state indefinitely until I reboot the SmartThings hub (which I did last night, so everything is working normally now). I’ll be sure to update this thread if it hops offline again.

If you set the energy reporting interval to something like 2 hours it should report every 2 hours even when it’s not being used so that might also solve the problem.

Energy reporting level is currently set at 5 minutes. I’ll change it to 2 hours as well. Thanks again!

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.