SmartThings Community

[RELEASE] Zooz 4-in-1 Sensor

dth_humiditysensor
dth_motionsensor
dth_security
dth_sensors

#163

It should be ok with 3.6V but battery reports may go crazy (showing over 100%). The ZSE40 is a 4-in-1 sensor so it reports temperature, humidity, and light levels next to motion.

We’ll be releasing 2 new motion sensors this year, one of them similar to the HomeSeer product but with more features. The other one will be a multisensor, similar to our ZSE40. Both will have the ability to accept USB power if this is something you’re looking for.


(Jared) #164

Awesome, that’s great to hear.


(Eric Dalquist) #165

Where do I find my current firmware version for the sensor? I’m not seeing it on my IDE page or in the app.


(Kevin) #166

It’s shown on one of the middle tiles in the mobile app. It’s also shown in the raw description in the ide.


(Eric Dalquist) #167

Found it, just hadn’t waited long enough for the sensors to update, overnight three of the four now show firmware version info. Not sure why the 4th hasn’t gotten that far yet.

Thanks for the great device handlers!


(Kevin) #168

Manually wake the device up by pushing the recessed button on the bottom of the device using a paperclip.

I’ll be releasing a new version of the DTH next week that enhances the UI and it should fix those types of problems.


(Jeff) #169

Kevin, I’m a big fan of your work. Thank you.
Since this thread is regarding the Zooz ZSE40 and about the humidity I thought I’d chime in. I have one and have been trying to get it to kick on/off a Samsung SmartThings outlet but can’t seem to get it to go it consistently. I am using your DH (tried others too) and using a smart app called Sheikhsphere : Smart Humidifier to get it to turn on/off @ 25/30%. I also tried to to a simulation in IDE but when I switch over from virtual device to the 4 in 1 it shows that I cannot run a simulation.
I can see RH on ST App and AT too. But cannot trigger the outlet to switch over. Maybe I’m barking up the wrong tree thinking it’s DH and maybe SmartApp.
Just wanted to bounce this off of you since you are on the subject of 4-in-1 and humidity.
Thank you,
Jeff K.


(Kevin) #170

The Simulator is way too buggy to be useful so I don’t waste time adding support for it to my DTHs.

Open the device through the IDE and click the humidity link to see if the device has reported values that should have triggered the SmartApp.

What are you using for the Humidity Change Trigger? If the bottom tile shows pending changes then you need to use the paperclip to wake it up.


(Jeff) #171

Kevin,
Thanks about the Simulator.

2018-01-26 6:32 PM MST - 3 hours ago humidity 35.16 % %
2018-01-26 5:55 PM MST - 4 hours ago humidity 34.06 % %
2018-01-26 5:22 PM MST - 4 hours ago humidity 35.22 % %
2018-01-26 5:03 PM MST - 5 hours ago humidity 34.79 % %
2018-01-26 4:43 PM MST - 5 hours ago humidity 34.55 % %
2018-01-26 4:37 PM MST - 5 hours ago humidity 34.48 % %
2018-01-26 4:34 PM MST - 5 hours ago humidity 34.44 % %

Interesting, after 5:56 my time it stopped (3 hrs ago) reporting but in App it shows 35.2% currently. (9:57PM).
Bottom tile shows 0 pending.
Trigger settings 30 hi, 25 low. Outlet didn’t turn off as should above 30%. Yes, 30% and 25% in correct fields.


(Kevin) #172

What’s the humidity trigger set to in the device settings?

The events page in the IDE doesn’t refresh automatically so if you haven’t refreshed that page then that explains why it looks like it stopped reporting.


(Jeff) #173

:roll_eyes:Trigger was at 10, changed to 3. Don’t know how I missed it. Probably by being inpatient and bouncing through different DH’s.
So, I changed though IDE, saved and seen 1 pending. Paperclipped the sensor and now 7 pending. I wait and check later due to having to be pulled away for other commitments. I will post results when I can.

Thank you.
Jeff
(NYBuzzNM)


(SimonS) #174

Is it possible to add decimal adjustment for the temperature offset? Right now we are stuck with +/-1,2,3…Need 0.5


(Kevin) #175

The DTH only sends the settings to the device when they change so switching to another DTH can cause the device settings to become out of sync with the actual settings and the DTH won’t know about it.

Tapping the Refresh tile twice clears the cached settings causing it to show 7 pending changes and it will resend them all the next time it wakes up.

SmartThings often drops off some of the commands sent to the device when a lot are sent together so you’ll most likely have to wake the device up multiple times to completely clear the pending changes tile.

I looked at the code of the SmartApp you mentioned and no problems jumped out at me, but it looks like it was initially created in 2014.

That SmartApp was necessary back then, but humidity can now be used as a trigger in Smart Home Monitor’s Custom Monitors so you might want to try using that instead.


(Kevin) #176

I don’t believe that will hurt anything so I should be able to add it to the version I’m currently working on.


(Joel W) #177

Will this version also work with the MonoPrice version?


(Joel W) #179

(MonoPrice Version) I am unable to get the motion detector to show motion. The motion detector shows in my ST app, but not in ActionTiles. In ActionTiles it shows as a ?. Can someone steer me in the right direction? Below are my logs. I changed the following in config, trying to get motion to work. Log below.
New setting


Original settings


(SimonS) #180

@TheSmartestHouse
@krlaframboise

Regarding the light level reports - after a week testing, I think I know what the problems. I moved the sensors so there is a light directly into them. For example, the sensor is now on the wall facing the window, 7 ft away and it is very quick (under 5 minutes) to report the change. It used to be on the wall adjacent to window, facing the away diagonally from the window. Good thing I only need night/day scene and nothing in between. I could be wrong, will continue testing.


(Jeff) #181

Awesome Kevin. Thanks for your patience, I’m still learning.
I removed all of the humidifier SmartApp’s I had. I know they are all old, but all I could find to use a humidity sensor to trigger an outlet.
I took you advice and went into the Smart Home Monitor and made a custom using the 4 in 1 sensor. The action for should happen choices was limited though. The nearest one that I thought applied would be Alert with Lights action. Let’s see what happens.


(Kevin) #182

If I remember correctly, you were just turning on and off a dehumidifier. Lights and outlets are both switches so using the alert with lights action is correct.


(Kevin) #183

Based on my testing the sensor maxes out at 100% ambient light somewhere between 45lx and 65lx which is sensitive enough to determine if a light is needed, but that’s about it.

If you’re looking for a device that can handle small changes in light you really need to get something like the Zooz Motion and Light Mini Sensor which can detect up to 60,000 lux.