SmartThings Community

[RELEASE] Zooz 4-in-1 Sensor

Did you use the paperclip to push the recessed button on the bottom of the device after making the change? That wakes the device up and it has to be done after every time you save the settings screen.

Yes the sensor is in the same room as the hub….10 or so feet away. And the temp is definitely changing….up to 4 degrees different.

I did push the reset button, but will try that again.

Hi Dan, something doesn’t seem right here. We’d recommend removing the sensor from the hub, performing a factory reset, and then re-adding it to leave close to the hub for 24 hours with all default settings and see if it reports more often.

Thank you! This brought my sensors back to life in ST!

1 Like

I can’t find the setting for this. Is there a way to get the light values more often than every 3 min?

Hi Jon, the sensor will check for temperature, humidity, and light changes every 3 minutes, there’s no way to adjust that. More frequent polling would cause the battery to drain quickly. The sensor was designed to track natural light changes so it’s not going to work well if you’d like to get notifications of instant brightness changes from light fixtures for example.

2 Likes

@krlaframboise with the new app update that came out last week, the ZSE40 device was assigned an icon that looks like the SmartThings multi. Looks like you need to add ocfDeviceType: "x.com.st.d.sensor.motion" to the metadata to get the motion icon. SmartThings is doing the same for their Aeon device handler. Tested it on mine and works.

2 Likes

I’m having issues with at least two of my Zooz 4 in 1 Sensors. I’ve only tried with two so far, so it could be that they are all seeing the same issue.

I had my ST Hub v2 die, I’ve purchased, configured, and moved most of my hardwired zwave devices to a new v2 hub, just now getting the motion sensors moved. They where previously running fine on other old v2 Hub.

I hard reset the devices, ran exclusion, included, discovered devices no issues. They show up and take settings, and report temp, rh, ect all fine. Changes in temp, rh, light, all seem to report just fine. Motion though, always shows Active - it never goes inactive. I’ve removed, reset, excluded, retried, ect. Both sensors seem to work, but never report motion inactive. I hide them in a box for awhile and they still report active.

I’m certain I’m either overlooking something obvious, or am running into some edge case scenario.

Sensors report FW: 17.9, I’ve swapped fresh batteries, running current version device handler 2.1.

Thanks for any help.

Are you using the new or classic mobile app and is it iOS or Android?

Does it show that there are any pending changes?

If you remove “//” from the log.trace line near the bottom and then trigger motion, does anything get logged to live logging?

Have you gone into the IDE and clicked the “motion” link to see if there are any events?

Anyone have any tips to get the unit to update battery % after replacement? My unit is clearly work but still shows 1% battery left. I’ve tried the paper clip reset already.

Tap the refresh tile and then use the paper clip to wake up the device.

I’ve gotten it to show that it took a recent settings update after a button push but no change in battery reported percent. Also I just remembered that this is technically the mono price sensor on the zooz handler that is supposedly the same Device or not depending on who you ask.

I believe it requests reports if you tap refresh once and wake it up, but tapping refresh twice and waking it up causes it to resync all the settings. Open live logging, wake it up and see if it requests anything, if not, tap refresh and wake it up again.

The first version Zooz released was identical to the Monoprice device, but Zooz has released 3 versions since then and each one has had a lot of improvements.

How well does motion sensing work on the latest revision of this device for people?

I have the older revision Monoprice version of this device, and it is driving me up the wall with how often it switches to no-motion when I’m in the room. I’m not a very still person either, I fidget and shift around a lot and the room is only about 10x12. I’m debating if I should get one of the newer revision Zooz devices to replace it, as I like having an all-in-one sensor (also have a heater in the room that is triggered by the temperature reported by the device) or if I’m better off looking for a totally different device. I’m getting sick of my lights turning off while I’m working.

I see where you state that everything else besides motion takes about 3 minutes to display once they trigger. Is there anything I can do to get a quicker temp alert?

The sensor checks the environment in 3-min intervals, that means if temperature changes rapidly within 3 minutes, you may not receive all of the changes even if they meet the reporting threshold. That obviously would apply to unusual settings, not natural environments where such rapid changes are extremely rare. To have the sensor report as often as possible, it’s always best to decrease the reporting threshold for temperature to a lower value in the advanced settings (just click on the gear icon in the Classic app view of the sensor to access the settings).

Mine doesn’t check environment in 3 minute intervals, more like 9 minutes.
At least for humidity.

What are you using for the humidity threshold?

The device takes measurements every 3 minutes and if light, temp, or humidity exceed their threshold then it reports all 3 values even if the other 2 values are still within their threshold.

If I remember correctly, the handler ignores duplicate events so the Recently tab will only show the values that have changed.

Humidity change is set to 2 and offset 0.

I have a ZSE40 V2.0. I loaded the device handler. I closed my shade and set my dimmer to various levels. As expected, with no light on it read .21%, 50% it read 23%, at 100% it read 39.2% and at at 30% it read 11.5%. I decided to go from 10% on my dimmer to 50% in 5% increments and log all of the readings. I left the dimmer at 10% for over 10 minutes, and it still reads 11.5%. I set the dimmer to 100%, still 11.5%. I opened the shade, 30 minutes later, still 11.5%.

I have not changed a thing other than my dimmer level. It worked great for a few readings and is now stuck at 11.5%.