SmartThings Community

[RELEASE] Zooz 4-in-1 Sensor

dth_humiditysensor
dth_motionsensor
dth_security
dth_sensors

(Brian Harding) #328

@krlaframboise
I had an exhausting day so I will be brief. They are both reporting now so I will start experimenting with them over the next couple of days. I am sure I will have lots of questions. I think what solved the problem was waking up the sensors immediately after changing the device type but I am not sure. I know almost nothing about adding Custom DTHs. I see you also have a DTH for the Dome Siren. I might purchase one of these later.
Thanks very much for your help,

Brian


(Brian Harding) #329

Here is where I am at in my testing, ( I am using a box to cover the sensors in my office).
In the Smart Lighting app if I select Motion as my trigger the cameras turn on immediately when motion is detected with no box covering the sensors.
With the box covering the sensors the first sensor reports .5lx and 1.2%.
The second sensor reports .4lx and .9%.
After removing the box and waiting a couple of minutes the first sensor reports 37.9lx and 58.5%.
The second sensor reports 39.9lx and 76.6%

The cameras do not turn on. I have illuminance selected in the Smart Lighting app as the trigger.
Any ideas what I am doing wrong?
Thanks in advance.

Brian


(Kevin) #330

If I remember correctly the “illuminance” attribute that SmartApps look at defaults to the % values (58.5%/76.6%) so if you’re triggers are based on the lux value (37.9lx/39.9lx) that would explain why they’re not working. You can either enable the “Report Light as LUX” setting or change your Smart Light trigger so that it’s based off of the 58.5/76.6 values)

Another possible issue is that Smart Light doesn’t like decimal places so you could always try setting that round values setting to 0 places. It’s worth trying, but I doubt that’s the issue because if I’m pretty sure other users would have noticed it.


(Jimmy) #331

@krlaframboise does the lux capability update on its own? Or does it require a check in from another capability? On mine, lux, temperature and humidity always check in at the same time. But I can’t tell which is actually causing the check in since the values are usually a tad different for each capability.


(Kevin) #332

Light, Temperature, and Humidity have their own threshold settings, but the device takes measurements about every 3 minutes and if any of the values exceed their thresholds the device sends all 3 values to SmartThings.

I’m not sure if repeatedly reporting those small lux changes will re-trigger the action in a Smart Lighting rule, but if it does, rounding to 0 places and using higher thresholds might help.

You could prevent duplicate actions if you were using a SmartApp like WebCoRE, but there’s a steep learning curve to that SmartApp and you might not have enough automations to make it worth learning. I believe it has its own forum so you can easily get assistance if you try it and run into problems.


(Brian Harding) #333

@krlaframboise
Thanks Kevin

Update. The both sensors are now working perfectly as expected. The cameras turn on when the Lux value changes. I did have to set the reported decimal places to 0 instead of the 2 places. That, plus setting the Primary Status to round the numbers to a whole number and reporting the Light Level to Lux.
Thank you for your patience and all your help,

Brian


(Kevin) #334

SmartApps don’t use the Primary Status so it was either the report as lux and/or round to 0 places that solved the problem, but either way I’m glad everything is working now.


(Jimmy) #335

Has anyone tried using either of the default Aeon Multi Sensor device handlers with these? Obviously wouldn’t be able to set the configuration stuff with it, but may be good to use once setup so that the device runs locally.


(Jimmy) #336

Just to follow up, the Aeon Multisensor Gen5 device handler is working fine with my Zooz ZSE40 gen 2 (the newest one with CR123A battery). Obviously can’t adjust the settings, but all capabilities report and it now runs local.


(Tom) #337

After setting up the sensor I would get the following error and nothing but motion would be reported.

error groovy.lang.MissingMethodException: No signature of method: java.lang.Double.round() is applicable for argument types: (java.math.BigDecimal) values: [2.0]
Possible solutions: round(), round(int), find(), trunc(), mod(java.lang.Number), and(java.lang.Number) @line 1145 (roundVal)

I changed the reported decimal places to 0 instead of the 2 places and that seems to have fixed the problem. I would love to have non-whole numbers back though. Any way to fix this and keep the 2 deciaml places?

Thanks for all your work. It’s great.


(Kevin) #338

I thought I fixed that bug a couple of weeks ago so are you sure you’re on the latest version of the code?


(Tom) #339

Just copied it on Sunday. Says it was updated about 2 weeks ago. version 2.0.2


(Kevin) #340

If you replace 2.0 with 2, it should solve you’re problem, but I’ll look into why it’s still doing that.


(Kevin) #341

I just released a new version that should permanently fix that problem.


(Rick Johnson) #342

Temp offset -1 to subtract 1 degree
When I try to set this the - changes to a . then when saved its 0.1 not -1


(Kevin) #343

Have you tried entering -1.0 ?


(Rick Johnson) #344

Within 1 second the - changes to . so it does not matter what I type


(Kevin) #345

That’s an issue with SmartThings, but if I have time this weekend I’ll change it into a drop down field which will eliminate that problem.


(Rick Johnson) #346

Thank you no hurry when you get a chance
Rick


(Shane Korbel) #347

This sensor is such a pain. I originally had a v1 4 in 1 sensor but the motion detection delay was at least three seconds despite it being much closer to the hub then many of my other z-wave devices. I contacted support and they said they came out with a version 2 of the sensor. I asked to evaluate it and it worked marginally better. I really only need the humidity aspect of the sensor to work since i’m using it to control a bathroom fan. The sensor sits OUTSIDE the shower and worked for a couple of months but now i’m running into issues where it will get “stuck” set in a “MOTION DETECTED” state and won’t do anything else. If i manually trigger the Z-Wave button with a paper clip the other parameters will update but the motion detection status stays stuck. Moreover, this is not at all a solution. I have everything updated and am using the latest DH in this thread. The batteries are new, I’ve unpaired and repaired the sensor. I’ve factory reset the sensor. I’ve tried not adjusting any of the settings on the sensor after a reset, and am still coming up empty handed.