[RELEASE] Zooz 4-in-1 Sensor

dth_humiditysensor
dth_motionsensor
dth_security
dth_sensors

(Jane) #288

I did the paperclip thing again and the it went to -1 changes pending and then back to 2 changes pending. It has stayed on that. It is still taking a long time to go from Motion to No Motion. Seems to be defaulting to 16 minutes.


(Kevin) #289

The DTH defaults the re-trigger time to 15 seconds, but prior to the 17.9 firmware that setting used minutes so it sounds like the device still hasn’t received the setting change you made.

Go into the IDE, open Live Logging, wake the device up again, wait until that status tile goes through the normal change (about 15 seconds), click the name of your device in Live Logging so that only that devices log entries are shown, and then post the log results.

It sounds like you’re using the correct version of the DTH, but you might want to verify that the DTH shows v2.0 at the top just in case.


(Jane) #290

OK, i will do this but won’t be able to until tomorrow. I will post the log. Thanks!


#291

Also make sure your sensor is very close to the hub when you do the forced wake-up. I always used to dismiss the advice to be close to the hub on things like this as in most cases I found it wasn’t necessary to have success. But for this device I found it very important to have it close to the hub when trying the paperclip wake up.


(SimonS) #292

FYI, I installed freshly charged Eneloops in 2 of my bedrooms (equally used) on Feb 17 2018. 1 months later battery was reporting at 1%. One of the rooms lasted till 5/24/2018 - batteries were at 2volts combined. But the other room total batteries combined was at 2.4 volts - still not fully discharged (around 1.1v for NiMh). Both sensors are same version (firmware 17) and have 100% identical settings. They primarely report temperuture change (0.2F difference trigger) and humidity, some light too. Motion is at the most battery saving mode, all LEDs are turned off.

So A) - probably one of the sensors is not as power efficient as the other.
B) Rechargable batteries are OK with it and it’s a shame the Z-Wave chip or whatever is hard to set to report low battery at 2.6 volts.

Anyone knows how to turn off low battery notification for specific device in SmartThings? It’s annoying to get notification daily


(Marcus) #293

Anyone have issues with it showing motion all of the time? I set the sensitivity level to detect a person and it was working well for the first 4 months. Now it basically shows motion all of the time (with a break for the timeout). I haven’t changed the sensitivity.


(Kevin) #294

Which firmware version and what’s the battery level?


(Marcus) #295

It is 17.9. The battery level is the reason I noticed it. It shows 1%. I just put new batteries in about a month ago.


(Graham) #296

I just bought 2 of the Zooz multisensors (so they are v2) and have added them using this device handler. I’ve had no problem adding them and motion detection is working perfectly on both of them, but the other sensors are not updating. On the first sensor it gets an initial reading, but after that it never changes with light/temp changes (not sure about humidity … more difficult to trigger that). The other multisensory shows no readings at all other than for motion (in the mobile client or in the IDE). I have tried waking them up with the paperclip and that does work to make sure that any changes in the settings get processed. I tried removing them, factory reset, removing and re-adding the DTH, but nothing seems to work. Any suggestions?


(Jimmy) #297

any chance they are falling off the mesh? are you pairing in place, or pairing close to the hub and moving?


(Graham) #298

Motion is working perfectly and without any delay, so it seems to be well-connected to the mesh. The second time I added them I did it from the location they are being used. I’m also not having any problem updating device settings.


#299

Hi Graham, sorry to hear about the issues you’re having! Just to make sure, are you using the Classic app or the new ST app?


(Graham) #300

At first I was trying the new ST app, but reverted to using ST Classic when it didn’t work with the new app at all. I am using this with the ST Connect Home hub. Also have temperature set to Celsius (it seemed to pick that up automatically and return the initial temp value in Celsius even though the sensor was still configured to report in Fahrenheit … not sure this is relevant but trying to give all info I can think of that might make my setup any different than others who have these working).
BTW, I did buy them from TheSmartestHouse.


(Jimmy) #301

Any other z-wave devices in the house? How far from the closest connect home hub or repeater? Pairing in place or moving after pairing?


(Graham) #302

Yes, there are about 25 zwave devices in my network. I’m not having any issues with other zwave devices on my network, other than very occasionally losing contact with the front door lock). The closest connect home hub is directly below (one floor down) one of the sensors, and the other one it is in the next room over (through gyproc interior wall) perhaps 15 feet away.


#303

Can you try resetting the sensors to factory defaults and re-including them, this time not changing any of the advanced settings (like temperature scale) to see if it helps? We’ve heard from one other user who experienced similar issues after changing some of the advanced settings so we want to rule this out first.


(Kevin) #304

The DTH converts the temperature into the temperature scale specified in your hub’s location settings. I kept that option in the settings in case it effects the unit of the temperature reporting threshold.

If your device shows “pending changes”, use the paper clip to wake up the device about every 30 seconds until it goes away.

Once you’ve done that, perform the steps below:

  1. Go into the IDE and remove “//” from the log.trace line at the very bottom of the code and then save and publish.

  2. Open Live Logging.

  3. Go into the Mobile app and tap the Refresh tile ONCE.

  4. Use the paperclip to wake up the device.

  5. Wait about 15 seconds and if you didn’t see any entries written to live logging then wake it up again.

  6. Click the name of your device on the Live Logging window so that just that device’s logging data is shown and then post the data.


(Graham) #305

I should have mentioned that I made no changes to any of the settings until it was clear that it was not working properly. I’ll try doing the factory reset again anyway.

The device was processing config changes and not showing any “pending changes” after doing the paperclip, so it seems to be communicating ok. I’ll try enabling the logging when I get home tonight and will report back.

One thing that did seem strange was that the factory reset behaviour was not the same on both sensors - the lights flashed differently, so perhaps there is actually something wrong with one of them? What is expected in terms of lights when doing the factory reset?

Thanks everyone :).


(Graham) #306

I followed Kevin’s instructions and it now seems that one of the sensors is working (the one that previously got initial readings, but then never changed as light/temp changed). The difference this time is that I did not add the second one. Is it possible that if the second one is defective that it could mess up the DTH’s processing of the working sensor? I’m going to leave it tonight to see how it goes and then try adding the second sensor tomorrow.


(Graham) #307

Update: I added the second sensor around 9am and everything was working! Both sensors were reporting in motion, temp, light, and humidity. Unfortunately it didn’t last … the 2nd one now has not updated temp/light/humidity since about 1:30pm. I pressed the button to wake up the sensor and here is what I saw in the log:
‎9‎:‎31‎:‎07‎ ‎PM: trace SecondaryStatus is
dc6d6c4b-034c-486d-b79d-a8d69c6e2754 ‎9‎:‎31‎:‎07‎ ‎PM: trace PrimaryStatus is No Motion
dc6d6c4b-034c-486d-b79d-a8d69c6e2754 ‎9‎:‎31‎:‎07‎ ‎PM: debug Motion is inactive
dc6d6c4b-034c-486d-b79d-a8d69c6e2754 ‎9‎:‎31‎:‎07‎ ‎PM: trace Motion inactive
dc6d6c4b-034c-486d-b79d-a8d69c6e2754 ‎9‎:‎30‎:‎56‎ ‎PM: error groovy.lang.MissingMethodException: No signature of method: java.lang.Double.round() is applicable for argument types: (java.math.BigDecimal) values: [2.0]
Possible solutions: round(), round(int), trunc(), find(), mod(java.lang.Number), trunc(int) @line 1144 (roundVal)
dc6d6c4b-034c-486d-b79d-a8d69c6e2754 ‎9‎:‎30‎:‎56‎ ‎PM: error groovy.lang.MissingMethodException: No signature of method: java.lang.Double.round() is applicable for argument types: (java.math.BigDecimal) values: [2.0]
Possible solutions: round(), round(int), trunc(), find(), find(groovy.lang.Closure), mod(java.lang.Number) @line 1144 (roundVal)
dc6d6c4b-034c-486d-b79d-a8d69c6e2754 ‎9‎:‎30‎:‎53‎ ‎PM: error groovy.lang.MissingMethodException: No signature of method: java.lang.Double.round() is applicable for argument types: (java.math.BigDecimal) values: [2.0]
Possible solutions: round(), round(int), trunc(), find(), and(java.lang.Number), mod(java.lang.Number) @line 1144 (roundVal)
dc6d6c4b-034c-486d-b79d-a8d69c6e2754 ‎9‎:‎30‎:‎52‎ ‎PM: trace Battery is 100%
dc6d6c4b-034c-486d-b79d-a8d69c6e2754 ‎9‎:‎30‎:‎50‎ ‎PM: trace configure()
dc6d6c4b-034c-486d-b79d-a8d69c6e2754 ‎9‎:‎30‎:‎50‎ ‎PM: debug Device Woke Up