[RELEASE] Zooz 4-in-1 Sensor

dth_humiditysensor
dth_motionsensor
dth_security
dth_sensors

(Magnus Back) #267

Lol.
I switched to light as secondary. Now it reports humidity every 27 minutes or less.
It’s also not showing any changes in light (as secondary) during the period I’m in the bathroom showering and with the light turned on. It randomly changes 10 minutes after I turned on the light.
I mean I’m sure it saves battery but what’s the point of this sensor?


(Kevin) #268

It sounds like there’s a bug in my DTH for the secondary status so until I have a chance to fix it you shouldn’t choose any capabilities for the secondary status.

The secondary status is cosmetic so not using it won’t hurt anything.


(Magnus Back) #269

Sorry it seems you misunderstood what I was after, I don’t care what the 2nd status says.

The problem is the unit doesn’t report humidity (or light) changes for very long stretches of time.
Even when the humidity or light is changing more than the set values they’re still stuck.
Supposedly it’s going to update every 3 minutes but it isn’t, at best it’s changing after 9-10 minutes.
So as a sensor for light and humidity changes it’s doing a horrible job. The new unit is (much) slower than the old unit.


(DAN) #271

I cannot get this to trigger events based on illuminance (using Smart lighting app).

I have report illuminance as Lux enabled.

I am trying to get it to turn on a light when illuminance is less than or equal to 1… but nothing happens.

It seems to take a long time to update. Once motion stops, it can take 2+ hrs for it to say that there is no motion. Lux values take 15-20 mins to update… this is despite hitting the refresh tile and pushing the pin on the bottom of the sensor.

I have exluded the unit and readded it. I have also reset it, but still no luck. Maybe I got a dud? The lux values it reports do not seem accurate.


(Lee Florack) #272

My ZooZ 4 in 1 Sensor reports between 0 and 80 Lux. Those readings don’t correlate to any ‘normal’ lux levels that I’m used to seeing, but it’s consistent in what it reports.

What I’m currently using is a lux level of 25 as a “Low Lux Threshold” - or dark enough for turning on certain lights. For some lights, I also turn lights off when the lux level goes above 25. I also use 40 for my “High Lux Threshold” to turn lights back off once it gets ‘bright enough’. A lux level of 1 would be very dark. But, keep in mind that there may be differences between Sensor units and your Sensor may produce different readings than mine.


(DAN) #273

what do you use to trigger these events? I was just testing it out with the Smart Lighting app within SmartThings app. Putting the sensor in a drawer where it is completely dark.

I’m not able to get it to trigger anything using motion or light.


(Lee Florack) #274

I use webCoRE. However, I just ran a quick test with Smart Lightning too. The test was to turn on a light if the ZooZ Sensor indicates 25 lux or lower. It worked. You said you were using a low threshold of ‘1’. That is very dark and for my sensor, that won’t occur until much later. You need to use a lux level that will work for your Sensor’s readings.


(DAN) #275

Thanks for the help. The current lux reading in my drawer is 0.5 , so it should have worked. I’ve changed the reading to 25, without success though. It is also registering motion despite being the drawer for Over an hour now. Im leaning toward this being a bad sensor.


(Lee Florack) #276

Sound like it to me.


(Kevin) #277

What firmware version does it show?


(DAN) #278

version 5.1.

I think I should have installed the deivce handler correctly… it is reporting values. The motion seems to be the only one that is stuck on/never changes.

I do have the monoprice 4 in 1 sensor, which supposedly is compatible with the zooz 4 in 1 DH.


#279

Make sure the motion retrigger time in prefs is set to a decent value. Options for FW 5.1 are 1 to 255 minutes. I think mine was set to 15 minutes by default and that made me think that something was wrong initially.

And, I can’t remember for sure but that may be one of the settings that does not update immediately and will wait for the next device wake up (unless you force it per various posts above). If it goes pending you will see it noted on the device tiles.


(SimonS) #280

@krlaframboise
Kevin, thanks for the update. The battery reporting interval is still not properly working (I’ve reported this couple months ago) - max value that can be entered is 67. Instructions says 167. Can simply modify this in the code?

Edit: Found the error around line 105 “1…67”. Chanfed to “1…167” and I can save value 167 now.


(Kevin) #281

I could have sworn I fixed that a while ago, but I guess not. It’s not worth releasing a new version for that, but I’ve updated the original file so that change will definitely be in the next release.


(Jane) #282

I am having the same problems with this motion sensor. Battery is stuck to 1% even though I just changed it and motion is stuck in Motion. I am going to try taking the battery out and see what happens. Mine says Firmware 16.9. How do you update the firmware?


(Jane) #283

It does seem to go back to no motion but it takes a long time. How come it is taking such a long time to check for no motion? I have the setting at “1” for 1 minute. Sensitivity is set at 2. It detected motion at 9:07 and it is now 9:16 and it is still saying “motion”.


(Greg) #284

Are you monitoring for the change in the logs or in the mobile app? If the mobile app, are you using iOS? if so - the iOS is horrible about updating status without first going to another section in the app and then returning.

Pulling down to refresh doesn’t always work. Sometimes exiting the room/group isn’t even enough.


(Kevin) #285

Did you wake the device up using the paperclip after you changed the settings?

The firmware can’t be updated because there were hardware changes in the latest version.


(Jane) #286

I did the paperclip “wake up” I don’t think it did anything. It says 2 changes pending in the dashboard of the motion sensor. I can’t understand why it takes so long to reset itself to no motion. It used to work fine until I changed the batteries. So I updated the DH to this current one and it is taking a long time to reset.


(Kevin) #287

Most likely because that setting change hasn’t been sent to the device.

If it shows pending changes then it needs to be woken up again.