[Release] Z-Wave.me, Popp, & Devolo Wireless wall Controller & Key Fob (EU), with button controller dimming apps and CoRE integration

As long as you wait 1 – 2 sec before each command you should be good

1 Like

Thanks to this thread, I think I’m nearly there on setting up a Z-Wave.Me KFob.

  1. Device Type and SmartApp added/published via IDE.
  2. Fob is now labelled as “Controller” within Things list, and “Secure Wall Controllers & Key Fobs (Z-Wave.me, Popp & Devolo)” within IDE.
  3. Fob shows up within both the app in this thread and Button Controller Plus.
  4. I’m not able to get any functionality out of the fob. I’ve assigned various buttons/clicks/long presses to various devices using both apps, no luck.
  5. I believe the “Set Up” instructions were mostly clear in original post, excluding 4 and 5. Going to SmartThings app, Things, Fob, I see a Configure button, but it is never clickable. Which inclusion mode should I be using here? I used the first (include KFOB as secondary controller) during initial setup.

Appreciate all the help!

What do you mean that the configure is never clickable? - it should always be clickable - in fact there is no way for it not to be!

The way to do it is to put your key fob into inclusion mode again (not the hub). This will be the same key combo that you had to do to include with the hub - something like holding down all 4 buttons for either 1,5, or 10 seconds until the red light starts flashing and then pressing button 1 again to enter inclusion mode. Once in inclusion mode that’s when you hit the configure button - and the red light will start flashing all over the place for a few seconds - you’ll have to wait for it to stop to see if its worked

1 Like

Well that’s odd, maybe I’m in the wrong spot. I tried to repeat the inclusion process a few times, but the configure button doesn’t change. This is what I’m referring to - device page within ST app, configure is never clickable:

I’ve installed a second fob and hit the same wall. Unable to make it past step 5. On both device pages “Configure” is greyed out and unclickable.

That screenshot looks normal to me… other than the pinkish hue - which I’m guessing is due to some setting on your phone.

That button is clickable! - to prove it - go to live logging in the ide and hit the button - and see that it will say something about sending configuration settings to the fob.

That step is tricky - and its not the fault of Smartthings or this DH - its just a dumb design by the manufacturer. You have to be in the device’s inclusion mode (not ST inclusion mode) and tap configure (maybe hit it quite a few times to be sure) - and it will work eventually

1 Like

Thanks, I just gave that a shot! Live logging shows nothing referencing “Configure” when clicking that button for either key fob. That isn’t surprising though, as other buttons in SmartThings animate in some way when pressed. As an example, if I open one of my lights I have a greyed out “refresh” button that animates when clicked, and “debug refresh” instantly appears in live logging.

Perhaps this is an ST app issue?

Ok - you are definitely right - I just checked myself and can see the same error

This must be some platform change - I’ll look into it

2 Likes

I’ve fixed it - there must have been a platform change to be stricter about what button types are tappable. I’ve added a nicer icon as well now just for good measure:

2 Likes

Fantastic! I’ll give this a shot tonight. Thank you for the help on this - I can’t wait to get these fobs working.

This works perfectly now. For anyone else setting up a Z-Wave.Me KFob stuck on step 4 or 5: redo inclusion mode by holding down all four buttons for 5 seconds, then button 1 for a second to opt for secondary controller inclusion. After that tap configure within the device page under Things. Should sync and be ready for setup via your preferred SmartApp.

Appreciate all the help!

Anyone know where to buy these devices in the US? I’ve searched quite a bit and can’t find any. Thanks.

They are not made on the US frequency or for the US market. You might find some secondhand from someone who had bought them in Europe, but they would not work with the US frequency SmartThings hub anyway. If you want them to use with a UK frequency hub in the UK, you’ll need to order them from Vesternet or another European supplier.

If you are looking for something similar that will work with the US frequency SmartThings hub, see the buttons and remotes FAQ. The Aeotec wallmote, for example, is available on both the US and UK frequencies. As is the Nodon Octan. (This is a clickable link.)

1 Like

Hi I’ve been pointed in this direction for wall controllers I’m looking for something to control some smart bulbs manually. Also it would be great if I can hard wire them in as I have a neutral at my switch location.
Where can you buy these switches in the uk
Thankyou

These ones use coin batteries - which in my experience last about 1-2 years. You can get type 1 or 2 at vesternet or amazon… or most UK smarthome stores. They will either be branded by Popp, Z-wave.me, Devolo (there are a few others as well). That is for the innards. For the nice looking bits, the store with the largest range of faceplates and rocker switches that are compatible is http://www.schalterversand.de - see my detailed post above for information on finding compatible rocker switches.

The good thing about these is that they use a very standard EU size so you’ll find that you can get matching faceplates and rockers for all your real switches as well… and can also occasionally mix and match devices (or have multiple of these within these). For e.g:

If you need something hard wired then this isnt for you… why not just use a standard switch with connected to a relay (like a fibaro or a qubino or aeoon one). Even if there is no load, I’m pretty sure that they can still report the switch state… which is all you care about right?

2 Likes

@AdamV is that a clock in with the switch on the middle picture? I like that idea

It’s an Under Floor Heating Thermostat - also Z-Wave and connected to Smartthings. (see here)

The reason they can be placed together is that both the wall controller and the thermostat conform to the standard EU 55 faceplates and mounts - there are quite a lot of other products out there that fit as well so worth looking into - its a bit of a minefield trying to find all the right bits but well worth it in the end

1 Like

Update 1.7.5

NEW: Battery Uptime timer - double tap to reset
NEW: Configuration code that sets the device to wakeup and send battery report at least once every 4 days
FIX: Configuration of wakeup notification to Smartthings node rather than broadcast

You should probably do a new configuration (have to put it in inclusion mode) to get the new features working their best - and don’t forget to double tap the timer to see how long your batteries last.

1 Like

Hello @AdamV,

I have this Z-Wave.ME device - http://www.zwave-shopping.com/en/switches-installation-required/z-waveme/4504-switch-insert-set-everlux-2-wire-zmee05434-0019962011900.html

It is not battery powered, but I believe it has all the same options as what your DTH is built for, plus it is a switch in and of itself connected to a load… any idea if there’s a way to get double tap/holds/etc working on this too? I see it in the manual as options, but the default “Z-Wave Switch Secure” DTH doesn’t capture those (as far as I can tell) - and nothing in ST sees this as a controller w/ the default DTH.

I’m technical, but I’m not a coder - and it looks like your DTH is 90% there, maybe?

If you PM me the manual that has the info re: double clicks for your device, I’ll see if I can modify the DTH to work for you