[Release] Z-Wave.me, Popp, & Devolo Wireless wall Controller & Key Fob (EU), with button controller dimming apps and CoRE integration

This DH is not designed for those switches unfortunately

Hi. Thank you for the DH and Smart App.
I’ve installed both.
The Popp and Z-Wave.me switches are working great (with click and hold).
With your Smart App called “Button controller with dimming, double clicks, & click-holds” is not working if I assign double click to any button.
The Rule Machine and CoRe are deprecated. I use webCoRE and no succes with the button +4 trick.

Is there any way to make it work with double clicks?

THX.

Hi, thanks for your work.

I managed to install the DH and it works ok.

What I can’t figure it out is how can you set up a certain button to a task in Core. I can choose button and the device I want but how can I choose which button from the 4 to use?

I also can’t figure out how to choose which button is used for a task. Looking at the logs it defiantly sees the different buttons pressed, but when adding the button to Core or Smart lighting it only gives the option of a single button which is always button one. Am I missing something?

Got the Devolo switch working well with this dth. Although I am getting the following error in the log-

3c8b7caa-b5aa-4998-9eb5-9a51a03675ae ‎08‎:‎10‎:‎43: error groovy.lang.MissingMethodException: No signature of method: script_dth_651a78a2_bef2_4079_bbe4_3e2f27c1648d_ver_0_4.zwaveEvent() is applicable for argument types: (physicalgraph.zwave.commands.wakeupv1.WakeUpNotification) values: [WakeUpNotification()]
Possible solutions: zwaveEvent(physicalgraph.zwave.commands.basicv1.BasicReport), zwaveEvent(physicalgraph.zwave.commands.batteryv1.BatteryReport), zwaveEvent(physicalgraph.zwave.commands.centralscenev1.CentralSceneNotification), zwaveEvent(physicalgraph.zwave.commands.sceneactivationv1.SceneActivationSet), zwaveEvent(physicalgraph.zwave.commands.securityv1.SecurityMessageEncapsulation), zwaveEvent(physicalgraph.zwave.commands.switchmultilevelv1.SwitchMultilevelGet)

Does anyone know what this means and what I need to tweak to stop the error?

Hi Adam (or anybody else that can help),

I disparately need black frames and paddles for Z-Wave.me wall switch controllers. I am looking at this site schalterversand.de and I completely lost (in this German site) how to choose the frames and paddles, to know for sure that will fit with those Z-Wave.me controllers.
Can you tell me how do you search for those frames + paddles. What is the standard/criteria that I should take in consideration when I order?

Thank you very much.

For example if I want to fit this cover with this rocker will they fit with Z-Wave.me controllers?

So I can only say for the combination that you have chosen that it is very likely that the frame will fit (and even if does not fit exactly you could probably cut the plastic on the back so that it does) - however it is unlikely (but I cannot rule it out as I have never purchased these) that the rocker switch will fit.

Here is a combination that is very similar, that I’m pretty sure will fit:

Frame
Rocker

Depending on which type of wall controller you have (there are two versions) - you may still need to cut plastic to make it fit exactly… depends which version you have

2 Likes

Using this handler ( [Release] Z-Wave.me, Popp, & Devolo Wireless wall Controller & Key Fob (EU) ) with my new Devolo Wall Switch https://www.uk-automation.co.uk/devolo-home-control-wall-switch-z-wave/

Its doing the job well, but the Battery report is not working… it dropped from 100% to 1% within 1 hour of first activating.

Its been in and working for 8+ days now and its still reporting 1% so its not a battery drain issue as it would be dead now. Just constantly reporting 1%. Any idea how to fix this niggle please?

Thanks

This is a device related issue.

This is the issue:

  1. if you use the device a lot it starts incorrectly reporting the battery as low. Of course, when you first get the device you have to press the buttons a lot during the setup and configuration so it reports low battery almost immediately.
  2. Then it doesn’t update the main controller (smartthings) about its battery for a few weeks at a time
  3. This can be changed in the configuration - for e.g. I could set up the configuration that it reports battery once a day. However, the act of sending out a battery report does drain the battery a little

I could update the device handler to let the user decide how often the device reports battery… but as a generalisation the less often the better.

2 Likes

Thanks AdamV

Would be great if you could please so id have a little control over it. Annoying seeing the Black Dot of low power in the Android App lol. Appreciate your work on this handler, great work

Hi @AdamV
Thank you so much for this DH - works just PERFECT with the smart app…!! :+1:
But i wonder if i have paired it correctly. If i use the official Smart Lighting app, i can only set an action for button1? Maybe i’m not doing it right?
1: I choose a bulb
2: Select trigger (here i choose “Button”)
3: Which button? (here i choose my Devolo Wall Switch - it only turns up once in the list of buttons)
4: From here i can only choose “Next”.
5: The summary shows the Automation name: “Turn Bulbxx on & off when Devolo Wall Switch button1 pushed”

I can’t choose the other 3 buttons in the official Smart Lighting app. Is this normal?

Don’t know if this matters, but if choose the Devolo from the Things list, and look under the “Recently” tab, all activity is listed twice?
If i e.g. push button1 it shows these three lines:

**Devolo Wall Switch**
Devolo Wall Switch status text2 is Battery:
2 days and 07:29:03 Double tap to reset

**Devolo Wall Switch**
Devolo Wall Switch button 1 was pushed

**Devolo Wall Switch**
Devolo Wall Switch button 1 was pushed

Is this normal behavior? :thinking:
(i also get double entries for double clicks and hold-actions)

Battery reporting and all features in the smart app seems to work as expected though…
And thanks again - just wanted to chip in with some feedback… :slight_smile:

I am using several Z-WAVE.me controllers with this great driver (now version 1.7.5) . Big thanks to the developers!
The issue that I have is that with the old ST app with “SmartLighting” I could attach the buttons to actions and everything worked well.
However with the new ST app I cannot find these devices anywhere in the listing of the automation/add condition.
(How) Can I fix this?
Cheers, Ronald

Don’t use the new ST app - it’s not fit for purpose IMO

Have you installed the inside part behind existing wall plates? Or is it a picture of the actually devices that you bought out of the box?

Hi! I´have installed a z-wave Devolo wall switch using this DHT (thanks for that!). I am experiencing 5 seconds delay (most of the time) between pressing the button and having the lights on. The switch controls 3 zigbee bulbs. Is there some settings to change to improve the delay? I don´t have delays on different automations on these lights. I am experiencing as well 1% battery notification.

@AdamV

Thanks for the DH and App. If you ever make any further changes I relly think the App needs seperate ON and OFF sections as opposed to just a Toggle. For example, with the the Devolo or Popp 4 Button Switch you are not able to set one of the toggles to be ‘up’ for on and ‘down’ for off as no ability to set a switch to be either On or Off. hope that makes sense. I have reverted back to the Button Controler Plus App which does allow this but would be great to be able use your App with ‘your’ dimming setup but as mentioned I really think it woudl benefit from seperate ON/Off sections for the each button.

Thanks!

Lately I am experiencing problems with my Zwave.me wall controllers using this DH!
Several operations on my 5 devices are no longer executed and when I look in the Andoid ST clasic app I can no longer find or set the “button number” in 4 of 5 devices: the configurations just ends with the general device name where formerly -and also still in the working device!-the button number configuration was next shown.

I tried several basic things in the ST IDE such re-selecting the DH and re-saving the devices, copied the DH to new name DH and updated the devices but with no improvements.

I have some questions:
a) Is the 1.7.5 DH still the latest one (for the EU)? I searched but cannot find a newer version.
b) what is an effective method to make sure that the DH is definitely reloaded/updated?
c) Do you have any idea what causes my problems and how to fix it?
d) what is meant to happen with the “configure” button in the Android app? I see nothing happening

And out of curiosity…
e) I am not a programmer so forgive me my ignorance: I assume everybody prefers to have any button processed locally. Is it not possible to write a DH for this -or any- controller to emulate buttons of another controller that is actually locally processed by ST?

Cheers, Ronald

Hi Everyone,

I have just bought this zme_wallc_s branded Schwaiger. Unfortunately the DH created by AdamV doesn’t work well in my case (ST V3, new app). I have tried with classic app, everything works as expected but I only see one button and no options to control devices.

Is there an updated version of this DH?
This wall switch is great and cheap, I really want to avoid sending it back :slight_smile:

Hi Adam, is there an update of the dh for the latest ST app?
Thanks, Luc