[RELEASE] YouLess LS110 and LS120

dth_powermeter

(CopyCat73) #1

A simple handler that communicates with a YouLess meter. IP address can be set in preferences. The LS110 version displays P1 value and total kWh. The LS120 version displays P1, S0 and total kWh. LS120 is mostly used to measure both smart meter and solar panels.

LS110:

LS120:


(Peke) #2

Oh **** you make me happy, i was looking for a way too integrate my power and gas into smartthings.
Ive yet not have this product but its relative cheap and works in (dutch power/gas meters) so im definitly gonna buy it sometime.
What does it read, power? gas? does it need to be polled?


(CopyCat73) #3

It’s a pulse counter. I’ve only built watt/kwh measurement but let me know if you need anything more. It’s a network device so it doesn’t need to be polled, the DTH accesses the Youless built in api every 60 seconds. I have a very old Youless device, the newer ones have some extra options.


(CopyCat73) #4

You may also be interested in this one: https://community.smartthings.com/t/release-p1-monitor-client/

I use the youless for solar power monitoring and the P1 DTH for incoming/return power.


(Peke) #5

Nice work! it is possible for gas readings?
I still need to buy one.


(Doebe) #6

Hello copycat.

i have added this in the device handler…
changed ip adress in preferences, but nothing happens.

any ideas on whatg could be the problem ?

i have youless

Model: LS120
Firmware versie: 1.3.4-EL

(CopyCat73) #7

Can you check this url in your browser:

http://youryoulessip/a?f=j

What output do you get?


(Doebe) #8

Hello, i am getting the following info:

{“cnt”:" 2820,246",“pwr”:839,“lvl”:0,“dev”:"",“det”:"",“con”:"",“sts”:"",“raw”:0}


(CopyCat73) #9

That is the correct api output. This is probably the famous hubcommand issue where no response is received back to the hub… Can you check if there’s any “received values” mentions in the log?


(Doebe) #10

Hello,

i do not Recevie anything, only if i change IP something is logged.

16d 09:14:49: debug Updated with settings: [deviceIP:192.168.0.103]
16d 09:14:33: debug Updated with settings: [deviceIP:192.168.0.104]


(Ben Erkens ) #11

Hi CopyCat73,

Now there is a new YouLess LS120 adapter with a P1 port, better then counting pulses.

New energy measure device via smart meter P1


(CopyCat73) #12

I know, but as long as it works I don’t want to buy another :slight_smile:


(Ben Erkens ) #13

Hi CopyCat73,

When I buy the new YouLess LS120 with the P1 port, I can readout both my smart electricity & gas meter?

That is not implemented in your DH (yet)?

Now I have a P1 readout with an Enelogic.com P1 adapter.

Grtn Ben


(CopyCat73) #14

The enelogic is different in function and has no local api. The new enelogic device is an LS120 youless. I have added an LS120 DTH.