SmartThings Community

[RELEASE] Yamaha Network Receiver Basic Integration

smartapp_av
dth_av
zone

#21

Not sure as I can’t find any protocol specs on that model… you may try the following and see if it works:

  1. In yamaha-receiver.groovy change line 35 from:
    input name: "receiverZones", type: "enum", title: "Zones", required: true, multiple: true, options: ["Main_Zone","Zone_2","Zone_3","Zone_4"]
    to:
    input name: "receiverZones", type: "enum", title: "Zones", required: true, multiple: true, options: ["Main_Zone","Zone_B","Zone_2","Zone_3","Zone_4"]
  2. Delete the Yamaha zone devices and then go through the SmartApp setup again and select Main_Zone and Zone_B.

See if that works and if it doesn’t we can figure something else out.


(Karl Knechtel) #22

Got this up and running through and works great. Anyone using this with Alexa? I’m trying to get voice control but its only showing as a switch. I can turn on off but that it.


#23

I think that’s the limit of capabilities right now via Alexa.


(Jim Archer) #24

Hi All…

I have a RX V-2700… Yeah pretty old but it does have an ethernet connection and I have streamed music to it in the past. Long ago I lost the remote, and I don’t recall if I left it to use DHCP or assigned an iP to it manually. I have been searching for its IP.

Can anyone tell me if it answers pings?

Any tricks to find the IP or reset the machine to factory default so it will get a new one?

Thanks…


#25

Try installing the free smartphone app Fing. Then, while on your home Wi-Fi run a scan and it will return all devices, including wired. You should be able to fathom it from the returned results.

Ping should also work.


(Jim Archer) #26

Thanks, I did an IP scan of the entire range to see what answered pings, then I tried to connect to each IP I didn’t recognize that answered port 80. No joy.


#27

Maybe try a reset?

https://www.manualslib.com/manual/340468/Yamaha-Rx-V2700.html?page=153


(Jim Archer) #28

Perfect, thank you! I’ll try that when I get home this evening. Hopefully it will come up and acquire a new IP via DHCP and I’ll find it.

A new remote is over $80. I found a compatible remote on Amazon for about $40 but even then, I’m probably replacing this receiver and hate to spend more on it before I do. I have used it for years without the remote!

UPDATE: Actually it can just reset the network parameters. I’ll try that first.


#29

Have you tried the Yamaha app from the app store?? Does it not find it on the network? You could also use a UPNP scanner…


(Jim Archer) #30

Didn’t even know there is a Yahama app, I’ll try it thanks.

UPDATE: Sadly, it does not list the V-2700 as being compatible. I’ll try though.


#31

There’s also browser access but you need the IP address. Not sure if it works for the V-2700.


(Kmmanley) #32

Thanks redloro - tried that - no dice. Haven’t had much time to play around with it, but if I figure it out I’ll let you know.

Cheers


#33

@kmmanley well that sucks… you may want to try the following and report back:

TYPE: HTTP POST
URL : http://<RECEIVER_IP_ADDRESS>/YamahaRemoteControl/ctrl
BODY: <YAMAHA_AV cmd="GET"><Main_Zone><Basic_Status>GetParam</Basic_Status></Main_Zone></YAMAHA_AV>

Let me know.


#34

UPDATED ICONS
Just a note that I’ve updated the icons in the Device Handler… some of them will take automatically but others will require that you update the Device Handler code… just pull the latest from GitHub and your screen should look like this:


(Benjamin Sell) #35

So, I have this working with my RX-V671. Power, mute, and inputs work. What doesn’t work well is volume. When it does respond, it does so seconds later. The Yamaha store app is instantaneous, however. Anything you can think of that I might have done wrong?

Ok so an update… I have this connected through google home. When I tell it to turn up the volume, it does so immediately. Im wondering if the delay is through the UI??


(Matthew Budraitis) #36

How do you have google home controlling volume? I’ve been using ifttt, but it doesn’t support dimming control. I assume like this? https://support.smartthings.com/hc/en-us/articles/214837343-How-to-connect-Google-Home-with-SmartThings


#37

No… but I did something wrong :slight_smile:

I ran into this issue before I published and fixed it, but somehow the fix didn’t make it into the repo… in any case, to fix the volume problem, update line 153 of the device handler. Latest device handler is in github.

Let me know.


(Matthew Budraitis) #38

Nice. I was wondering why the volume control was sketchy. Looks like you had to get rid of the decimal points.

I’m using this to control my receiver using voice commands with Google Home. One oddity, probably from google treating this as a dimmer, is if I tell it to increase volume, it cranks it to 100%, so that’s not very helpful. I set the volume limiter on the receiver to a reasonable level so that it doesn’t destroy anything, but I’m thinking I can do better.

If I tell Google Home to set the volume to 40%, 45%, or 50%, those are good volume levels, so I’d like to set he highest level to 55%.

It looks like “value * 9 / 5) * 5 - 800” is doing that scaling. If I want to give this volume control a limit of 55%, do I need to adjust this equation? Is there a better way?


#39

Easiest would probably be to add a couple lines above that like so:

if (value > 55) {
  value = 55
}

So then no matter what, the volume level will never be increased past 55%.


(Daryl Figge) #40

Is there a way to decrease the time it takes for the app to recognize a change in the receiver? If I turn off the receiver the it still shows that its on in the app. I would like to use the receiver turning off to trigger other events.