SmartThings Community

[RELEASE] Xiaomi Sensors and Button (beta)

dth_motionsensor
dth_remotes
dth_sensors
(Not Dexter) #711

Do you use the v1 or v2 hub?

0 Likes

Xiaomi Aqara Zigbee Switch DTH--help needed
(Steve ) #712

It’s a version 2 hub

0 Likes

(Rinke) #713

I have joined my Aqara sensor since 4 days now, still going strong (at 0%) no dropoffs.

Since it shows 0% (and a warning in the app) i changed the devicehandler to use item 30 from cluster.data (which is 100).
This is just a wild guess, but since the device is new, the battery might be 100%. But i have no idea.

0 Likes

#714

WiFi can drown out Zigbee.

If “right next to the SmartThings hub” also means “very close to the WiFi router,” then that can sometimes be the area of the greatest Wi-Fi interference.

Siting your devices always involves a lot of local factors. Signal can bounce off of metal or mirrors back towards itself, creating interference patterns. The position of the nearest repeater may make a big difference. The traffic on both networks matters. So The fact that one person’s system works just fine when it’s sitting a foot away from their Wi-Fi router doesn’t mean that yours will.

Best practices say to position the SmartThings hub at least 3 m away from the Wi-Fi router and any Wi-Fi access point. And of course to position the hub centrally in the home, both vertically and horizontally.

If yours is working fine in a different position, that’s great, you don’t have to worry about it. But if you’re having problems with dropped messages, it’s usually worth Trying moving the hub to see if it helps.

BTW, even the furniture matters. I’ve told this story before, but one time we went into an office building where there were complaints that a system wasn’t working on a particular floor. Got there, and found that the access point had been put in a conference room inside a red lacquer Chinese cabinet.

As it happens, red lacquer has a high percentage of iron in it, which can definitely scatter signal. We put the equipment on top of the cabinet, and all the network problems went away.

“All home automation is local.” :wink:

4 Likes

(Steve ) #715

Thanks for that I am planning on moving the hub as it is right near my WiFi,tv,Bluetooth soundbar etc and it’s also sat behind the tv in the corner if the room :frowning:
Luckily I have no big red cabinet :slight_smile:
I’ve got a ST plug upstairs so that should cover upstairs.
Do the ST plugs repeat the zigbee network as well as z wave
Cheers

0 Likes

#716

SmartThings brand plugs are zigbee. Zigbee devices only repeat for zigbee, Z wave devices only repeat for Z wave. For more details, see the FAQ:

That said, the Xiaomi devices are not ZHA certified and are idiosyncratic as far as what repeaters they work well with. Others can say more about that.

2 Likes

(Tim Raynor) #717

has the battery cluster.data change worked for you ? It’s annoying me to keep getting the SmartThings warning for zero battery.

0 Likes

#718

Unless it’s a Zigbee Iris Smart Plug with Z-wave repeater :smirk:

0 Likes

#719

It’s still zigbee only repeating for zigbee and Z wave only repeating for Z wave. It’s just that that plug has two radios inside it, one of each. It will show up in your things list as two different devices. :sunglasses:

2 Likes

(Eddy) #720

Just got 6 of those sensors, tried 2 so far and both of them is reporting 0% battery…
fk!

0 Likes

(Steve ) #721

Hi thanks for the suggestions yesterday I thought I would try pairing it again upstairs away from the WiFi but near the repeater in my bedroom, before I try moving my hub.
And it’s finally stayed paired :slight_smile: :slight_smile:
Woke up this morning and it’s been reporting all night and the battery % has just started to be reported so it looks to have worked.
Cheers

1 Like

(Rinke) #722

Yes, it changed to 100%, but this could easily be the wrong value and stays 100% forever…

1 Like

(sapstar) #723

I have recently added a number of Z wave devices to my smartthings. I see they respond much slower than their zigbee counter parts. At the same time, I started experiencing a significant lag with my xiaomi sensors which previously used to turn on lights instantly. Is this an expected behaviour?

0 Likes

(Rinke) #724

Same here.
I only have Xiaomi and Zwave devices. The xiaomi devices are much faster than the Zwave devices.
But i don’t see any lag so far.

1 Like

(sapstar) #725

Strange. For me it feels like the whole smartthings experience has slowed down after introducing the z-wave devices… I notice them with the xiaomi motion sensors especially.

0 Likes

(Rinke) #726

Have you moved the Zwave devices around after joining?
Then you might need to do a zwave repair to rebuild their tables

0 Likes

(Eddy) #727

How did you do this again? the 0% battery is annoying lol

0 Likes

(Rinke) #728

I made a copy of the devicehandler, called it something like "Aqara Sensor"
then i made the following change in the parseCatchAllMessage method:
//resultMap = getBatteryResult(cluster.data.get(23))
resultMap = getBatteryResult(cluster.data.get(30))

So now it uses item 30 instead of 23

Then change the device handler for your Aqara sensor to this new one.

Again: this could be 100 forever. You might even hardcode it to 100% lol.

1 Like

(Eddy) #730

That would do until we find another fix, thanks alot!

0 Likes

#731

New findings regarding Xiaomi devices:

  1. Xiaomi device seemed try to update its Zigbee ID when some unknown condition met, wish I could know better, I believe this caused widely observed drop out.

  2. Briefly clicking the pair/reset button after you paired the device seemed also trigger catchall message and the ID inside the message also is valid so you can update your existing device with this ID.(it stays the same until you long press, A.K.A reset/unpair device).

  3. Now it make me wonder if we can somehow update the device entity automatically when a device had dropped, then we kind of insecurely re-add the device back to hub.

  4. But what if multiple device dropped at same time? wonder how Xiaomi’s own hub handle these…

3 Likes