SmartThings Community

[RELEASE] Xiaomi Mi Cube / Magic Controller

dth_remotes

#24

My hub is v2, US customer Rev E. No disconnections in the last 3 weeks.


(Pizzinini) #25

Same here, V2. Stable for 48 hrs.

CoRE integration works great and impresses the kids, friends and neighbors. :wink:

Thank you!


(Fernando) #26

I guess Ill need to switch to V2 then :frowning:


(Michael) #27

Thanks again for this DH. My cube has worked perfectly for a week now and thanks for enabling CoRE. I used a few virtual switches and had them activate the CoRE rules originally. I’ll be simplifying this weekend by removing the virtual switches.


(Yi Nagel) #28

I’m new here. Can anybody please show me a screen shot where I can see the catchall/Network ID?


(Paul) #29

Try the instructions here:


#30

How long did you guy’s order take? I’m going on 29 days now.


(Yi Nagel) #31

I followed the instruction. But I can not see anything with catchall. Please see the screen shot. I pressed and held the botton at 10:56 and pressed again few time at 10:57.


(Paul) #32

I think they state 29 but normally arrive in less than 2 weeks. If you want them quicker try eBay and filter from the UK. You might get a hit!


(Paul) #33

What device are you trying to pair?


(Yi Nagel) #35

Xiaomi Motion Sensor


(Paul) #36

Motion Sensor will pair without you using the log…

Get yourself a cup of tea or something stringer…
Add a thing using the ST app
Then press and hold the reset button
when it start flashing press it a couple of times
Keep doing that until it pairs (it will).

Be prepared to be patient and sit near the hub when doing it! It can take a while!


(Yi Nagel) #37

Thanks for the tips. I’ve tried it the whole day already… But I will try it again.


#38

I ordered mine on Dec 30 to be shipped to the US and I’m still waiting for it to arrive. They did say up to 25 business days so I’ll give them another week.

Update: Just received my Magic Cube on Jan 28 so it took about 1 month to get here. :slight_smile:


(Yi Nagel) #39

Just tried another hour sitting next to my ST Hub with no luck. I pressed and holded the reset button till the LED blink 3 times and kept pressing every 15 seconds. But nothing was showed on ST App-Add a thing. Is there another way to find out the network ID? I have the Xiaomi Gateway and I enable the developer mode to find out the device ID. But it’s useless here, right?


(Paul) #40

I’m not sure if you can add it manually if you have the signee id, maybe someone else will know. Alternatively you just try it using the instructions above?


(Yi Nagel) #41

Am I looking at the right place? Why I don’t see any catchall.


(Goran Kochov) #42

Thats a big delay between clickung (15 sec). Try clicking on every 3-5 secs.


(Yi Nagel) #43

Thanks. It’s working now. I tried to click very fast.


(S Çağlar Onur) #44

I just got my cube yesterday and it works great! Thanks @DroidSector

I ended up changing Matt Frank’s code a bit to adopt it to Mi Cube and also added for dimmer/color temperature support. If anyone is interested, it lives at Mi Cube Controller