SmartThings Community

[RELEASE] Would you like to use any ST connected temp & motion sensors with Ecobee?

Hoping someone can help clear up my confusion/problems. I am trying to get non-ecobee sensors working with my ecobee3 lite, I have the My Ecobee Device installed and working and have installed the remote sensor app and device handler using https://github.com/yracine/device-type.myecobee/blob/master/smartapps/readme.ecobee3RemoteSensor

However, none of my ST devices ( i.e. Aeon Multisensor 6 ) that report temp and motion, show up when start up the ecobeeRemoteSensorInit app. I just get a blank page.

The readme referenced above mentions: "If you have a blank page in ecobeeRemoteSensorInit or “a unexpected error occurred” while
executing the smartapp:


d) Make sure that you have the latest ecobee firmware (at least v3.6) at the tstat as motion sensors
are not detected prior to that firmware version.

And, of course, make sure that all your remote sensors are actually reporting to the physical thermostat…
In some cases, remote sensors may have some connection issues with your physical thermostat, and my code is not able
to detect them.
"

I have confirmed firmware but I’m confused by the “actually report to the physical thermostat”. How do I get the aeon multisensor to report to the physical thermostat? Is this done thru the ecobee app? In my ecobee app, I have no remote sensors listed which is what I would expect since I don’t have any ecobee remote sensors. Am I misunderstanding the functionality of the remotesensor app???

Hi @mmaniaci,

You’re using the wrong smartapp. ecobeeRemoteSensorInit is used only to expose your ecobee3 or ecobee4’s proprietary remote sensors to SmartThings as indicated at the ST community wiki:

http://thingsthataresmart.wiki/index.php?title=Ecobee3RemoteSensorInit

To use any other ST connected sensors (ex. Aeon MultiSensor, SmartSense or Iris Temp/Motion Sensors, etc), refer to the 1st post of this thread:

[RELEASE] Would you like to use any ST connected temp & motion sensors with Ecobee?

For your use case, the smartapps to be used are either MonitorAndSetEcobeeTemp (at my github) or ecobeeSetZoneWithSchedule (which has many more features, ex. zones & schedules and it’s available at my store).

For more details about both smartapps, refer to the ST community wiki:

http://thingsthataresmart.wiki/index.php?title=Category:Unpublished_SmartApps
Regards.

Thanks so much for the response and getting me straightened out. I assumed ( incorrectly ) that after clicking the first link, which brings users automatically to the readme, that was what I needed to do… after adding MonitorAndSetEcobeeTemp.src as an app, I got things working.

Hi! Can i use the Blink xt to replace the ecobee 3’s motion sensor?

Hi, yes, any connected ST temp/motion sensors can be used. It’s a one way integration which means that the temp/motion values will be used to adjust the setpoints under SmartThings, but you won’t see the sensor’s values at the ecobee portal or the app, just the setpoints adjustment (as a hold).

For more details, refer to the ST community wiki:

http://thingsthataresmart.wiki/index.php?title=MonitorEcobeeTemp

If you want to have more granular control of which connected ST sensor(s) you’re using at a given period of the day, I’d recommend to use ecobeeSetZoneWithSchedule, which is a far more advanced smartapp at my store.

www.ecomatiqhomes.com/store
It brings much more features… Refer to:

http://thingsthataresmart.wiki/index.php?title=EcobeeSetZoneWithSchedule

Regards

Thanks for the reply! Do i need to install a lot of smartapp to use the sensor of blink, control hrv erv, conditionning and heat pump? Use the follow me… What do i need?

Hi, please refer to the 1st post of this thread. All the use cases are detailed with the name of the smartapps to be used.


Regards.

Hey folks…Hopefully quick question. I recently added a second remote sensor to my setup and now I am having issues where my remote sensors are not functioning accurately in ST. Both sensors work great in Ecobee but they don’t match in ST. I tried re-adding them to ST and that didn’t help.

I am not seeing motion reported at all in ST and the temp seems to be stuck at the same temp even though it is reporting every 5 minutes. Do I need to go all the back to the beginning by removing the smart apps and device handler from IDE?

Thanks, John

Hi John,

Just to be sure, you’re talking about some ecobee’s proprietary sensors?

Could you check that your Ecobee device responds to request by doing a refresh?

Also, you’re on an older version. I sent you an email about the update procedure to be followed.

Please reply to my email.

EDIT: Back in August, I sent out a new version that allows to rename your ecobee’s proprietary remote sensors under ST. If you have renamed them, that would be the problem.
Regards.

I am talking about the proprietary sensors. I did a refresh and it does
seem to be communicating regularly.

I thought I was on a newer version. I just received an email recently,
wednesday perhaps?

I did change names so you might be onto my problem there. Do I need to
change them back?

Thanks, John

No, you don’t need to change anything. Just update to the new code.

Regards.

I have updated the code, and published, and the sensors are operating the
same… Here are the versions I am using. I also noticed my away and
resume smart apps don’t seem to be working as they should. I’m wondering
if I mucked something up. Thanks

myecobee device Version 5.9.9n
myremotesensor v1.1.3

Well, send me some logs at services@maisonsecomatiq.com. Click on My ecobee device in the upper section of the screen:

http://thingsthataresmart.wiki/index.php?title=My_Ecobee_Device#Issue_.239:_I_want_to_get_more_tracing_in_the_IDE

Regards

Yup, I mucked it up… But I fixed it… I backed it all out and put it
all back in and now it seems to be working. Thanks for all your help.

My setpoints are always too low… if I manually raise the temp, it just reverts back to the setpoint that’s too low again. How do I adjust the temperature to be warmer?

Do you mean when you use MonitorAndSetEcobeeTemp?

As indicated at the ST community wiki, this smartapp doesn’t allow manual overrides. You need then to increase your setpoints using the ecobee comfort settings in the ecobee app or at the ecobee portal.

See the prerequisites section:

http://thingsthataresmart.wiki/index.php?title=MonitorEcobeeTemp

However, if you often change your thermostat setpoints manually, I’d recommend to contribute to ecobeeSetZoneWithSchedule as this paid smartapp has the logic to allow manual overrides (and much more using the concept of “zones”):

http://thingsthataresmart.wiki/index.php?title=EcobeeSetZoneWithSchedule
Regards

Hello. I am having troubles getting this to work. I may have done it wrong considering I was following the instructions for setting up the EcobeeremotesensorInIt while trying to set up the MonitorAndSetEcobeeTemp. I’m thinking I may have missed a step in all of this. My error code looks like this:

java.lang.IllegalArgumentException: Command ‘resumeThisTstat’ is not supported by device f38dac74-75bc-4bab-af9d-744f753e1564 of type ‘Ecobee Thermostat’. Supported commands: [refresh, setHeatingSetpoint, setCoolingSetpoint, off, heat, emergencyHeat, cool, setThermostatMode, fanOn, fanAuto, fanCirculate, setThermostatFanMode, auto, setSchedule, ping, generateEvent, resumeProgram, switchMode, switchFanMode, lowerHeatingSetpoint, raiseHeatingSetpoint, lowerCoolSetpoint, raiseCoolSetpoint, poll] @line 259 (initialize)

Hi, you’d need to use My ecobee Device for both smartapps, not other ecobee implementation.

The ecobee thermostat you’re using now is probably the ST stock device which doesn’t support the extended commands & capabilities that My ecobee Device has.

In the prerequisites section for the installation of My ecobee Device , it’s recommended to remove any other ecobee implementation to avoid confusion and some future errors.

See the README instructions:


Regards.

I don’t understand. I’m using a regular Ecobee 4 and a regular ST version 2. I’m trying to get the ST Sensors (multi-purpose specifically) to work as a Ecobee temp sensor so that I don’t have to buy a Ecobee sensor for every room.

Yes, you can do this with My ecobee Device only, not the ST stock ecobee thermostat.

What I’m saying here is that you’re trying to use my smartapps at my github against the ST stock thermostat, this won’t work, you have to install My ecobee Device and remove the ST stock device under ST as obviously you’re confused between the 2 different ecobee implementation.

In brief, you need to follow all the instructions in the README including the step to remove any other ecobee thermostat under ST prior to installing mine. To do so, click on EcobeeConnect under Automation/Smartapps in the ST Mobile app and click the Remove button at the bottom. If you have any errors, it means that you have to unselect the ecobee stock thermostat from all smartapps and routines before clicking Remove (including the Amazon echo smartapp if you have it installed).