[RELEASE] Visonic Powermax Alarm

Great stuff. Is there a mqtt notification to look out for for when the alarm is going off so I can get HA to set up alerts for that?

just tested monitoring the MQTT and didn’t see any topic activity for anything other than armed/door open/shut/disarmed. nothing to show that the alam had been triggered. is there something i need to configure in the control panel so that it sends some kind of notification like it does for other things?

So everything is working but the alarm message isn’t appearing correctly? I’m sure I simplified that so it should just be “alarm” but I’ll need to refresh my memory in the source code later.

well, i mean i’m not seeing ANYTHING come up in the logs when i monitor MQTT and the alarm is triggered. so i didn’t know if it was something which needed configuring on the unit itself.

And you are waiting until the alarm actually sounds? After checking the source code, all the types of alarm that I can think of are sending a ‘triggered’ message to the alarm/panel topic. What do you see the alarm status as, in the activity log of the ESP? And what status does it show on the /status page of the ESP when the alarm is triggered? I assume not one of the states shown in the screenshot below…

yes, the alarm is sounding and i left it doing so for about 10 seconds (much to the neighbours annoyance).
I’ll have to do it again when i’m able to see what the ESP is showing it as doing at that point as it is no longer in the logs.
(unless there is a way of setting the alarm off ‘silently’?)

Not unless you disconnect the battery from the external siren, but I’m really not sure why you wouldn’t see the triggered message…

ok i tried it again.
here are the MQTT logs from within HA. (also using a MQTT explorer which shows the same)

Message 13 received on alarm/problem_report at 10:52:
No problems detected
QoS: 0 - Retain: false

Message 12 received on alarm/panel at 10:52:
disarmed
QoS: 0 - Retain: false

Message 11 received on alarm/zone3 at 10:52:
Violated (Motion)
QoS: 0 - Retain: false

Message 10 received on alarm/zone3 at 10:52:
Violated (Motion)
QoS: 0 - Retain: false

Message 9 received on alarm/problem_report at 10:51:
No problems detected
QoS: 0 - Retain: false

Message 8 received on alarm/panel at 10:51:
armed_away
QoS: 0 - Retain: false

needless to say that there was a trigger event happening between message 11 and 12.

also within the wemo logs

#0	2021-08-24 09:52:39	Disarm
#1	2021-08-24 09:51:39	Arm Away
#2	2021-08-24 09:51:30	Exit Delay

I think the alarm doesnt trigger an alarm message as soon as the siren goes off, it typically waits for ~20s to be confirmed and then to trigger the external siren (at which point it sends the message). That said I would still expect something in the logs as I no longer get the delay since I added the extra alarm types, and it works perfectly for me.

Im not entirely sure why you are not having the triggered event, what zone type is the zone that is triggering? (e.g. perimeter/internal/…) Might be useful to send me your /status page by PM which has all the zone types and configuration.

I have PowerMaxPlus (US) and have been using it with Smartthings and Cj’s Wemos and Arduino boards for the past four years. Everything has been working quite well for me even with the changes to the Smartthings app. Last week I changed my router from Verizon to TP-Link Deco x60 mesh. Now the Wemos doesn’t find my WiFi SSID. If I connect to the Wemos board using a USB cable, do I have to disconnect all of the wires from the Wemos to my PowerMaxPlus or can I just disconnect power to the Wemos and PowerMaxPlus? I don’t see “VisonicPowermaxBridge” broadcasting while it is connected to the PowerMaxPlus.

It will probably only re-broadcast the VisonicBridge AP after a power cycle (unless you specifically set it to do so whenever wifi drops). Normally it should reconnect automatically if you create a WiFi network with the details of your old network.

If you want to change the WiFi details you can follow the reset process (power cycle the device >5x with about 1-1.5s of ‘on time’ for each cycle (you can have unlimited ‘off time’ as the Wemos doesnt know how long it is off for). To do this you will need to pull the power cable out of the Wemos (multiple times)

Thanks for your fast response. I got it back on the network. I can Arm Home and Disarm from the webpage. Smartthings doesn’t seem to change the status. I can Arm Strobe but I can’t Disarm from Smartthings. Until a few weeks ago it worked fine. I haven’t updated the Firmware for the Wemos since I received it in 2017. Should I try that?

I suggest that will be because of IP address changes. You can update them individually (in ST and in the Wemos config page) or you can update them in ST (but you will probably need an updated firmware).

Sorry to be a pest, but is PowerMaxEsp8266.ino.bin the New Firmware file on GitHub that I need to download? Then I just use the “Dashboard for esp8266 controlled Visonic Powermax” to update it right? As always, Thanks for all of your help!

Yup that’s right