[RELEASE] Visonic Powermax Alarm

Its not complicated, but it needs another platform to talk to the ESP.

In theory you could set up a VPN to your router, and then the ESP does not need to be exposed to the internet. But it wouldnt be able to notify you, it would rely on you checking it.

Hi,

I have a Powermax model S-5452-B Rev 1.

Would be this model suitable for this integration? If possible what hardware configuration do I need?

How does this work in the new app. please post some screens. I don’t care if I need to do some stuff in webcore.

I am in Spain and I would like to purchase you all the items.

Thank you.

I dont believe that model accepts Serial commands from what I can tell online, as it is so old, so sadly will not support this integration. It is often possible to keep the sensors and just buy a second hand panel (e.g. Powermax panels on ebay go for £20-50), but that would be something for you to investigate.

The main parent device does not work great in the new app due to some bugs with Smartthings’ programming tools, but it does create all children for each zones, so they are easy to use in automations/webcore/… and I have just added a feature where it also creates child devices for arming/disarming, so it is easier to do that in automations aswell.

1 Like

Wow it’s a shame. Thank you Charles.

Is there some other way to connect my alarm to Smartthings with a relay just to know and change its state?

You could either connect some little Fibaro UBS/Implant device (or another contact sensor) and measure the state of the sounder/siren - that would tell you if the alarm is going off.

Otherwise you’re welcome to test it out and see how you get on, perhaps they didnt disable the serial pins on your alarm (it seems from more Googling there is a small chance of this - depending on who resold it and exactly what version it is).

Hello folks,
Does anyone have a solution to integrating the alarm into Google Home, at least for Arming I would like to be able to tell Google to do it…
Tnx!

I used to have this running with a simple virtual switch that I linked to the alarm through Webcore, whenever the switch was pressed it would trigger the alarmArmAway function. However I did add some code a few months ago which should auto create some child devices, and these could be turned on by google home. Might be a simple option to test this feature (feedback appreciated), though due to the ST-GH integration not allowing you to filter the devices to show you might need to rename the disarm child so it is as good as invisible to google home.

Thanks very much, I tried looking at the device handler code and noticed the 3 new child devices you added. After running the [Create Child Zones] in the device web interface, it indeed created 3 new buttons - Alarmarmhome, Alarmarmaway and Alarmdisarm.
Thankfully other child devices were not recreated and the existing ones I had stayed intact (phew :wink:
Alas, the buttons don’t seem to work correctly - when clicking any of the arms, first they don’t actually do complete the arm action, and second, they don’t change state either, and stay off.

Tried looking through the IDE debug panel and it does look like the right functions are called, eg.:

9:25:29 PM: debug uri /armaway
9:25:29 PM: debug armaway()
9:25:29 PM: debug Arming Alarm Away
9:25:29 PM: debug childOn(alarmarmaway)

Which is similar debug to when I arm from the main alarm panel in ST (which does work successfully)…
but still, it doesn’t complete the action successfully…

Have made a couple of small changes to the device handler, it would be great to know if they have fixed this issue (it seems like the actual get request to the alarm is not made and I have seen this issue before with some temperamental behaviour). All you should need to do is update DTH and hopefully it starts working, but if not I’ll need to debug what could cause the delay and probably queue the commands better as opposed to just calling all the commands sequentially.

I am afraid your recent changes broke something… I updated the DTH with your changes, but found that the whole arm/disarm is not working anymore - neither the new buttons nor the tiles from the main panel work.

Hello, CJ, I’ve just found this topic and I’m very interested in buying your solution. I’m from Spain and I’ve got a Powemax Pro, I don’t know exactly which model. Here I attach some pictures. Could you help me to indentify the model and the things I need to buy to set it up?

Thank you in advance

You can get power from the expansion board (+12V and GND) and then get comms (Rx/tx) from the pin header labelled PC.
To find more information specific to Powermax Pro pin connections then this thread has some good details.
https://www.domoticz.com/forum/viewtopic.php?t=11134

Ok thank you. Do I need both, Wemos and Arduino?And it works with the new app?

Hard to tell with super old models, but I’ve not seen a European Pro model that needs Arduino, so should be fine with just Wemos.

Thank you, I guess I always could buy an Arduino later in case.

I read in the GitHub guide it works only with the old app. Is it still true? Could your last improvements make it work with the new app?

Thought I had updated that comment. The new app is still a bit of a step back from the old app in terms of functionality, but it does work, for automations related to the sensors and for control of the alarm (needs a small fix).

It’s all possible through automations like webcore, just the display of information in the app is a bit weak. I did try to fix it but there were just too many bugs with their new CLI functionality and I haven’t had time to look again yet.

Hi CJ,
you’ve got a new online order from me :wink:

Cool, will get that posted.

@cjcharles hi, i’m french and i have a powermax pro since 2012.

Do you think your system are ok for it ?

What did i do to buy it ??. Directly on your website ? With Arduino or juste wemos ? If all are ok, do you have a installation, configuration setup ?

Regards

Hi, again me. I read all your topics on github.
Incredible !!!

But i have some questions. The api link is :https://graph-eu01-euwest1.api.smartthings.com/ or https://graph.api.smartthings.com/

Another question, is it a obligation to have a hub ?

i try all of this. I just waiting about your answer if i must buy arduino when i pass order on your website

Thanks