[RELEASE] Visonic Powermax Alarm

Believe I found the right place to plug in this board being the PC/IP port (based on other photos here and the web) and after plugging it all, at least the main system still behaves correctly and isn’t burnt which is a good start :slight_smile:

Looking at the Wemos webpage, the status shows the status of the alarm correctly, but I am unable to arm/disarm and no zone names are showing. The zone function just shows 32 generic zones…

Will try tomorrow some more, if you have a tip till then that would be great!

I would suggest upgrading the firmware from my GitHub and then checking if you have any settings configured which stop the Wemos enrolling on the settings page.

You might have a really old panel that doesn’t enroll, this has a small reduction in features but pretty minor. Perhaps start by changing the PIN to be one of your user pins, that might unlock most features successfully. Alternatively check in the Powermax menus to see if there is an option to enroll a Powerlink module?

ok, I upgraded the wimo to the latest firmware, and I tried pretty much everything - reset the wemo’s a good number of times, changed pins in the settings to both user and admin, unfortunately I can’t get the board to sync .
There are no zones detected. I can arm, but not disarm.

this is what I see in status:
{“stat”:0,
“stat_str”:“Disarmed”,
“lastCom”:468,
“panelType”:-1,
“panelTypeStr”:“16”,
“panelModelType”:0,
“alarmState”:0,
“alarmStateStr”:“None”,
“alarmTrippedZones”:,
“flags”:5,
“flags_ready”:true,
“flags_alertInMemory”:false,
“flags_trouble”:true,
“flags_bypasOn”:false,
“flags_last10sec”:false,
“flags_zoneEvent”:false,
“flags_armDisarmEvent”:false,
“flags_alarmEvent”:false,
“enroled_zones”:}

There are no zones detected. I can arm, but not disarm.
Note in one of my attempts I managed to get the boards to sync and I saw the zones and much more info… but I don’t know if I did anything special and haven’t been able to succeed in this since.

I don’t have a powerlink option in my administrator options, the installer manual states the board is supposed to try to sync when you exit administrator mode, but unfortunately this didn’t work either.

Any other suggestions?

How long are you leaving it when testing? If you got it to show full info once then unless it crashed for some strange reason it should have been fine to leave it in that mode.
If you did get it to pull full enrolling info then I suggest putting it back to defaults and it should be best placed to enroll. The only time you could change settings is when your panel doesn’t support enrolling a Powerlink2

FYI for everyone else here with an old powermax pro (mine is an old panel from Israel, with no powerlink sync option in the installer mode) -
Charles uploaded a new firmware a few hours ago, and at least for me it immediately solved all problems - the Wemo synced after 15 seconds of flashing the new version (with the Adruino) - I didn’t need to change any configurations - pin stayed the default which is neither my user or installer pin.
All working great now (thus far :wink:
Thanks a bunch cjcharles for your support!

A few additional questions:

  1. Any way to integrate the arming into SHM?
  2. How can one rename the zones in the Visonic device tiles? Even if I rename the individual devices from the “things” page, I still see the old names in the alarm zone tiles…

Yes, for everybody else struggling to get enrolled, Ive added an extra pause during the process which seems to massively improve enrolling for older panels. I expect this should mean that virtually all panels should now enrol automatically, and a minimal number will need to update the PIN.

Hey cjcharles,

Is there supposed to be any notification from smartthings (or can it set up to do so) when an alarm triggers?

Today incidentally the alarm triggered and I didn’t see any alert / notification in the app.
In addition, the wemo seemed to be in a state where it wasn’t possible to disable the alarm. When I got home (after disabling physically the alarm), the status of the wemos showed the following:

{
“stat”:5,
“stat_str”:“Armed Away”,
“lastCom”:19742,
“panelType”:4,
“panelTypeStr”:“PowerMax Pro Part”,
“panelModelType”:51,
“alarmState”:1,
“alarmStateStr”:“Interior Alarm”,
“alarmTrippedZones”:[
0,
1,
2,
3,
4,
5,
6,
7,
8
],
“config”:{
“installer_pin”:“8888”,
“masterinstaller_pin”:"----" (scratched off),
“powerlink_pin”:“3622”,
“user_pins”:[
“----” (scratched off)
],
“telephone_numbers”:[
“455441”,
“25951973”
],
“serial_number”:“0217322971”,
“eprom”:“J-701461 C13.808”,
“software”:“JS702070 C13.808”,
“partitionCnt”:1
},
“flags”:35,
“flags_ready”:true,
“flags_alertInMemory”:true,
“flags_trouble”:false,
“flags_bypasOn”:false,
“flags_last10sec”:false,
“flags_zoneEvent”:true,
“flags_armDisarmEvent”:false,
“flags_alarmEvent”:false,
“enroled_zones”:[
{
“zoneName”:" ����� ���",
“zoneType”:4,
“zoneTypeStr”:“Delay 1”,
“sensorId”:149,
“sensorType”:“Magnet”,
“sensorMake”:“Visonic Door/Window Contact”,
“signalStrength”:0,
“lastEvent”:4,
“lastEventAge”:28967,
“stat_doorOpen”:false,
“stat_bypased”:false,
“stat_lowBattery”:false,
“stat_active”:true,
“stat_tamper”:false
},
{
“zoneName”:" ���� ���",
“zoneType”:8,
“zoneTypeStr”:“Perimeter-Follow”,
“sensorId”:227,
“sensorType”:“Motion”,
“sensorMake”:“Visonic PIR”,
“signalStrength”:0,
“lastEvent”:5,
“lastEventAge”:29567,
“stat_doorOpen”:false,
“stat_bypased”:false,
“stat_lowBattery”:false,
“stat_active”:true,
“stat_tamper”:false
},
{
“zoneName”:" ����",
“zoneType”:8,
“zoneTypeStr”:“Perimeter-Follow”,
“sensorId”:227,
“sensorType”:“Motion”,
“sensorMake”:“Visonic PIR”,
“signalStrength”:0,
“lastEvent”:5,
“lastEventAge”:29560,
“stat_doorOpen”:false,
“stat_bypased”:false,
“stat_lowBattery”:false,
“stat_active”:true,
“stat_tamper”:false
},
{
“zoneName”:" ����",
“zoneType”:7,
“zoneTypeStr”:“Perimeter”,
“sensorId”:227,
“sensorType”:“Motion”,
“sensorMake”:“Visonic PIR”,
“signalStrength”:0,
“stat_doorOpen”:false,
“stat_bypased”:false,
“stat_lowBattery”:false,
“stat_active”:true,
“stat_tamper”:false
},
{
“zoneName”:" ������",
“zoneType”:12,
“zoneTypeStr”:“Interior”,
“sensorId”:227,
“sensorType”:“Motion”,
“sensorMake”:“Visonic PIR”,
“signalStrength”:0,
“lastEvent”:5,
“lastEventAge”:19811,
“stat_doorOpen”:false,
“stat_bypased”:false,
“stat_lowBattery”:false,
“stat_active”:true,
“stat_tamper”:false
},
{
“zoneName”:“Custom 2”,
“zoneType”:12,
“zoneTypeStr”:“Interior”,
“sensorId”:227,
“sensorType”:“Motion”,
“sensorMake”:“Visonic PIR”,
“signalStrength”:0,
“lastEvent”:5,
“lastEventAge”:29246,
“stat_doorOpen”:false,
“stat_bypased”:false,
“stat_lowBattery”:false,
“stat_active”:true,
“stat_tamper”:false
},
{
“zoneName”:" ����",
“zoneType”:7,
“zoneTypeStr”:“Perimeter”,
“sensorId”:228,
“sensorType”:“Motion”,
“sensorMake”:“Visonic PIR”,
“signalStrength”:0,
“lastEvent”:5,
“lastEventAge”:29419,
“stat_doorOpen”:false,
“stat_bypased”:false,
“stat_lowBattery”:false,
“stat_active”:true,
“stat_tamper”:false
}
]
}

The wemos could communicate with the alarm correctly (clicking on arm did nothing at this point) and it only worked after resetting it…

You probably needed to press disarm or something, comms won’t change due to an alarm condition, especially if the webpage still loads.

Notifications aren’t possible from any devices, as far as I’m aware, you need to configure them through a smartapp. Follow instructions like the ones a couple of posts above.

I am interested in displaying the current status of the zones in the new app.

One way I was able to do this, was to change the type of the sensor for the child from Open/Closed Sensor to Smartsense Open/Closed Sensor. The problem is that after sometime, the sensor shows offline because there is not status change. If there is no status change, the Wemo does not send an update.

Would it possible to add all the zones to the CheckInactivityTimers() section? This way the current status is updated every minute or so?
Unless there is another way to do this?

Thank you

I wouldnt want to modify anything on device side, but it would be easy to set a timer on the parent device and automatically send a ‘keep-alive’ message to the child, hence it would show as online (though really it shouldnt matter…)

I havent really done much experimenting with the new app as it was so bad when I last used it that I gave up… Does this mean it is usable now?

Yes it has come a long way. If it would be possible to add the keep-alive message that would be awesome.

Thank you for the great work!!!

Hi cjcharles…I know I should just download the .bin and flash it to the Wemos, but I’m hard-headed. I checked the ESP-PowerMaxESP8266 and it looks like the issue w/ the Powerlink_PIN_Code not declared in pmax.h was corrected, but Powerlink_SlowComms and Powerlink_ListenNotEnrol appear to have been recently added are now throwing an ‘undeclared’ error. Should they also be present as long in pmax.h? Thanks, Jonathan.

Cjcharles, is there a list of all different status messages sent over mqtt? I’m asking because I’m thinking of setting up automation triggered by the alarm going off. I noticed that the message sent out upon alarm triggered depends on the trigger type, interior or external, delayed entry etc.

Curious. It’s easy to fix in Smartthings with a bit of Regex (though I’ll actually publish an updated release to do it properly as I’ve only just realised how many types of alarm there are). However I guess for mqtt you can’t do Regex, so I’ve pasted a list of the things that I think might trigger an alarm below.

“Interior Alarm”, “Perimeter Alarm”, “Delay Alarm”, “24h Silent Alarm”, “24h Audible Alarm”, “Tamper”, “Control Panel Tamper”, “Tamper Alarm”, “Communication Loss”, “Panic From Keyfob”, “Panic From Control Panel”, “Duress”, “Confirm Alarm”

Excellent. Thank you. Now my house lights up if the alarm is triggered. :wink:

For everybody else, Ive published an update to the device handler which should respond when the alarm goes off much earlier. Rather than waiting for a ‘Confirm Alarm’ message to change state, it now does so immediately as soon as any kind of alarm is triggered. Should be a 30second quick update to copy the updated device handler into your Smartthings IDE.

Did you solved this issue? I’m facing the same problem.

Just use flash download tools from expressif and flash the bin, easier and saves me constantly updating all the library files
https://www.espressif.com/en/support/download/other-tools

Mariete, no I haven’t. Understood on flashing the bin, but if you’re asking the question above you’re probably like me and like to ‘raise the hood and understand the engine’. Over the next day or so I’ll give the bin that cjcharles recommends below a try and once that is running I’ll circle back around to see if I can figure the compiling issue out. I’m speculating that it’s a few variables that need to be declared as public in the pmax.h, but that’s purely speculation on my part.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.