SmartThings Community

[RELEASE] Visonic Powermax Alarm

Been running for 12 hours now, no MQTT issues so far.

1 Like

Same for me, MQTT is stable so far with the latest debug firmware.

1 Like

Hi cjcharles, I have bee trying to make my PowerMax Plus work but no luck, I’m using NodeMCU (CH340) and I’m also using Arduino Uno in between PM+ and NodeMCU. It seems like there is no communication between PM+ and NodeMCU. If I go in Installer Setting -> Define PowerLink and then Install, I get ‘Line Failure’ error. and after hitting ‘Away’ on keypad to go back to home screen on LCD, I start getting message on LCD ‘ICT - TEST’, it doesn’t go away untill I disconnect one of the wire from RX or TX on NodeMCU or Arduino Uno. Could you please help me with this?
(Oh… also I’m using standard USB power to run NodeMCU and Arduino Uno)

Hi, I hope you can help… I have a vision Powermax with powerlink1 external addtion. I want to get this into Apple HomeKit, I already run this plugin https://github.com/tonesto7/homebridge-smartthings-tonesto7 to allow Smartthings devices to appear into HomeKit… so as. I can’t find a way of getting Visonic directly into HomeKit I wanted to use your method to get it to smart things, then use my existing link from Smartthings things to HomeKit… Question… does your code work directly with powe link? or do I need this module you mention… if I use the module do I need to remove the power link as it may use the same connection to powermax? Can I buy the module from you pre coded so I don’t need to do any firmware coding, just the code into Smarthingsd IDE? sorry if this is a bit confusing, I’m not a coder, but am techie enough to manage to get most things integrated into HomeKit one way or other by playing… look forward to comments, suggestions or if I can buy a solution from you.

Hi, to answer a few of your questions:

You do need the module to link into ST as that is what sends the days to ST. You need to remove Powerlink at the same time, but I’ve slowly been adding most Powerlink features into my module.

If you buy one pre programmed then you don’t need to flash it, just copy ST code and plug in module. Depending on your exact alarm it can sometimes take some fiddling, but with my most recent code changes everybody should get there now, you just need to upload new firmware on the modules webpage when it arrives in a couple of clicks.

I’m not sure about the consequences of homekit integration as I don’t use it, but if the integration works with custom devices (i.e. devices where you have manually added a device handler yourself) then it should be all good.

@matharoo have you connected the grounds together if you’re not following instructions about using Powermax power? Also is the Arduino flashing to confirm it is receiving data, should happen fairly often, especially if you trigger one of your zones or arm the alarm.

1 Like

@cjcharles Many thanks, you show multiple modules on your shop page, which one do I buy?

You have a Powermax+ so would need the arduino and wemos module. Its a tight fit, but can possibly be popped in an external box in the worst case. If you want to be able to trigger the alarm from ST then you would also need the relay module but that is totally up to you (people use it to link other sensors into their Powermax system).

What is the box next to your alarm? Is it a siren?

Thanks, yes I do want to be able to turn the alarm on and off, so I’ll buy the lot :slight_smile: the box next to the main alarm box is the original Powerlink, it used to be external rather than an internal module… Annoyingly if I has the powerlink2 internal module I could link it to HomeKit directly as someone has written code for that on home bridge.

Sorry to be clear, do you mean that the relay is to trigger the siren, or to be able to set the alarm mode “Home” Away" etc? all I need is to be able to set the alarm remotely, I want to use geofencing to turn the alarm on and off.

Sorry you’re right I mean trigger siren rather than trigger alarm mode changes.

I’ll drop you a message directly now.

Hi cjcharles, I have bee trying to make my PowerMax Plus work but no luck, I’m using NodeMCU (CH340) and I’m also using Arduino Uno in between PM+ and NodeMCU. It seems like there is no communication between PM+ and NodeMCU. If I go in Installer Setting -> Define PowerLink and then Install, I get ‘Line Failure’ error. and after hitting ‘Away’ on keypad to go back to home screen on LCD, I start getting message on LCD ‘ICT - TEST’, it doesn’t go away untill I disconnect one of the wire from RX or TX on NodeMCU or Arduino Uno. Could you please help me with this?
(Oh… also I’m using standard USB power to run NodeMCU and Arduino Uno)

I have uploaded some new firmware to Github, this allows you to use relay modules which are active high instead of active low, plus has some improved processing options for Powermax/Powermaster modules which do not allow pairing. You can find a ‘Slow comms’ mode and ‘Dont Enrol’ mode at the bottom of the settings page.

@matharoo It looks like you have just posted the same message as before without any other response to my questions or advice?

Been running for 12 days + now, no issues with MQTT. Thanks. Only thing I noticed is that if I arm the alarm and then during the pending phase disable it again, status does not change from pending to disarmed in Home Assistant. I guess no MQTT is sent in that scenario. Result is, I can not arm or disarm via Home Assistant until I change alarm status manually on the panel, then status is updated again as expected.
Great work, I’m very thankful. How can I donate?

Yes, the Wemos relies on the Powermax to confirm that the alarm has changed state after going to pending, but if you cancel the change then the Powermax never sends another update.

I actually just had a brainwave about how to deal with this situation properly (even though it happens very rarely IMHO), hence have updated the code on Github and it should fix this.

If you are willing and able to donate then very much appreciated, the link is in the first post. Thank you.

Tried it but still doesn’t behave properly.
If I arm home from home assistant (over MQTT) , then realize the cat is still outside and disarms (either from web interface or by MQTT) to let her in during pending, then the alarm disarms but doesn’t ack over MQTT, leaving home assistant in pending (forever).
If I then send disarm a second time from the web interface it acks over MQTT and thus home assistant shows the proper status. Trying to send a second disarm over MQTT does makes the alarm ack again but no MQTT ack (home assistant stuck in pending).

edit I noticed now that ‘pending’ is sent over MQTT if disarming during pending. That’s clearly not right.
Also, if sending a second disarm when alarm is already in disarmed mode, ‘disarmed’ is sent immediately followed by ‘pending’ leaving status stuck in pending…

Ah, I forgot your commands were coming from mqtt. I’ve uploaded another update and I’m pretty confident it will be good this time!

You commented that doing it by web interface was the same as mqtt, but I’m pretty sure in the previous firmware the web interface was right. Anyway, now they should both be ok if you cancel the arming signal.

Almost there… :slight_smile:
If disarming during pending I have to disarm twice to get the acknoledge over MQTT and correct status in Home Assistant.

I can confirm using a MQTT client that with the first disarm sent over MQTT the alarm disarms, but no status is sent over MQTT. If one more disarm is sent over MQTT the alarm confirms (voice) and MQTT status message is sent.

@Fredrik_P Think Ive got it this time, now sends it if the status is ‘exit delay’.

I think MQTT works as expected now! Gonna do some more testing and will let you know. Great work!

1 Like

I don’t know what you mean by “Power” as I mentioned I have PowerMax+ and the only power (if thats what you meant) I have is 9V adapter. And to answer your second question I would say. when I click the ‘Arm…’ link on browser nothing happens (NodeMCU does indicate that it has received the command but does not pass that on to Arduino). I’m also using MQTT server and when I power ON the NodeMCU I do get message that NodeMCU connected to MQTT but after that nothing happens.

Hello Chris,
Would love some help as I seem to be hitting issues similar to others here.
I connected the Wemo + Adruino to my Powermax+ (fairly recent version bought in Israel, probably the last one produced for this market) and after powering on the Adruino and syncing the powerlink, after a minute or so the message “ICT - TEST” appears, the device is totally unresponsive to any key, and this won’t go away until cables disconnected. After which the memory seems nearly totally erased, I lose all the alarm configurations, all zones and other settings are reset, and the device is in a bit of a weird state, I managed to reprogram and it seems to work ok, but there are visible artifacts - specifically in my case the Hebrew RTL is a bit messed up and the numbers and inputs start showing on top of labels which was not the case before.

Is there a way to reset the device completely?
Any known solution to this?

Here’s photos of my setup in case something isn’t correctly plugged:
tnx.