SmartThings Community

[RELEASE] Visonic Powermax Alarm

dth_security
dth_sensors
requires_server
project_security
project_sensors

(Haden Cruickshank) #243

Hi all,

I want to buy a Visonic Powermax Express E from Amazon UK but I’m slightly confused about compatibility now with your solution - will this brand new kit experience the problems a few other are facing or is the Express E definitely compatible?

My other worry is that I don’t currently have a phone line and don’t want to fork out the extra cash for a gsm upgrade which obviously means no phone alerts but your solution doesn’t rely on this functionality does it so I can use without?

Finally, I just wondered how long it usually takes for delivery of the Wemos given I live in West London and would make the order straight away on getting a reply to this post lol?

Cheers for your help - I’m really looking forward to getting this all set up!


(cjcharles) #244

A few points to respond:

Visonic have some really strict rules about country compatibility, and buying one that is unofficial can make buying accessories quite difficult (e.g. Some sellers on eBay will be flogging a non-uk version as it could be cheaper to buy for them, and it will be get hard to buy extra sensors). Hence I’d suggest you send me the Amazon link to confirm it comes from a good seller rather than a noname unofficial third party seller.

I bought an Express E system from the uk to test (from SapphireSecurity) and it worked for me, but took some time to enroll, however I am aware of one user with a Dutch Express version which doesn’t work and I don’t yet know why. The other people with problems are Powermax Pro in the USA I think. Put simply if it’s an official version then you’ll be fine I’m sure. Complete is another option which works very reliably, and they have basically the same features (complete has more features but they are fairly redundant now compared to when it was first released), but don’t know how pricing compares (I bought my complete from MAP security and they were one of the lower prices, but there are plenty of sellers out there).

Phone line functionality is fairly useless with this integration since you can do the same and so much more with Wemos and Wi-Fi. The Wemos works like an internet module instead of the GSM module hence they are totally separate. Imho, GSM is only useful if you are worried somebody is going to cut your internet connection (but if worried about that then you probably need a better alarm system).

As for the Wemos I ship first class and normally within a day or so depending on my work, so pretty quick.


(Haden Cruickshank) #245

Thanks so much for getting back to me so quickly! This is the Amazon link for the ExpressE that I was hoping to get:

Visonic PowerMax Express E Professional Grade Wireless Intruder Alarm Kit https://www.amazon.co.uk/dp/B00XEYYO2Y/ref=cm_sw_r_cp_apa_n4zsBb5TASTJV

Does that look legit?
Thanks again!
Haden


(cjcharles) #246

Probably would be fine as it is sold as a kit, though Ive not heard of them. Given it is the same price and you can avoid giving money to Amazon I’d probably order from MAP who are specialists in the area and its next day delivery too, but up to you course thats just me! - http://map-security.com/visonic-powermax-express-wireless-alarm-compact-professional-kit-pwrmaxexpr.html


(Endor) #247

Hi, @cjcharles
Can you please share the fix you did for esp serial in source and if you have a link to the issue it would be interesting to see some more details? :+1:


(cjcharles) #248

They are linked with the following issues on the Github tracker:
https://github.com/esp8266/Arduino/issues/3869 and there is a collection of related issues to this
Plus here with adding a circular Serial buffer:
https://github.com/esp8266/Arduino/issues/3737
But mainly it was related to the ordering and timing with which the serial connection is opened and initiated, so that it avoided too much data being received before it reached loop state (and hence was able to process the data)

I will share source if it actually helps make the integration work better! Otherwise its just my thoughts of what could be wrong!!


(Endor) #249

Ok. I have forked your code and built a proof of concept with mqtt for using with mqtt alarm in home assistant.

It is here https://github.com/endor-force/powermax-mqtt

It’s still in a early stage with uncleaned code.

It is behaving oddly and stops communicating
and fail to enroll after being in use for a while (days).
I’m beginning to think that the communication with the alarm is causing it to crash.
If I can help test your fix in this code it might be useful for you as well.


(cjcharles) #250

Damn, Ive already built an MQTT integration myself! Coded and done in parallel with the normal integration (you can swap between them). In fact the firmware I linked above includes the MQTT code in it, and you can hopefully find some instructions above about how to enable it. Perhaps that will behave differently?

I’ll try and have a look at your code later this week and then can see what is going on with a test of my own!


(Haden Cruickshank) #251

Hi @cjcharles,

I received the Wemos really quickly thank you, but I just wanted to check something on the installation with you before I plug it and find out I’ve fried the board!! As you can see in the pics below, I’ve soldered the positive wire onto the capacitor as instructed, but I’m just wondering where to put the ground wire? Is there any reason why I can’t just put onto negative terminal of the capacitor? Otherwise, I was thinking of soldering onto the point marked -ve that you can see in the pic?


Thanks mate,
Haden


(cjcharles) #252

You have a DC power supply, just splice onto those cables before it even reaches the Powermax. It’s easier and tidier IMHO, plus probably interferes less with the actual Powermax board. That said if you had to, yes the other leg of the capacitor would be best, or gnd point maybe fine too, but better to take from capacitor as it will create less noise on the board.


(Haden Cruickshank) #254

Thanks for reply, I’ve connected it all up and followed your guide to first get wemos a static IP assignment while connected to microusb and then after a fair amount of acrobatics managed to close the unit with everything inside (is there a specific location/layout that u normally recommend?,) I only ask this because when I turn on the alarm to check pairing etc, it doesn’t appear on the network and I can’t access the admin panel. When I open then PM case and turn on power, the wemos seems to have power (2 LEDs lit) but not on network. What’s strange is that if I remove the battery backup and then power up via mains, the wemos works as expected so I’m hoping that this will give you a clue as to what I have done wrong here because I’m really not sure what else to do now? I’ve attached a screenshot of the admin panel status page and the wemos functioning as expected with the battery backup not plugged in.

Thanks again!


(cjcharles) #255

How strange, I’ll drop you a private message and can talk through a few options. Can you reliably re-produce it when the battery is connected vs when the battery is not connected?

Thanks,


(cjcharles) #256

So it looks like the battery was fairly flat on arrival, hence when the battery was charging it was preventing the Wemos from booting. If you connect the Wemos first, and then after it has booted and connected to WiFi then connect the battery it works fine. All working now and alarm control fully working.


(Gil Hoffman) #257

Hi.

Once in a while the wemos loss sync with the Visonic and cause strange stings.
Sometimes I cannot arm/disarm the alarm and sometimes I just don’t get events from the Visonic sensors.
Most of the times a simple restart to the wemos does the trick, and sometimes I have to remove the Visonic from ST and reconfigure it.
For the simple times of simple restart I suggest you to add an option for a day&hour to auto restart of the Wemos of for refatching the data from the Visonic, a lot of electronic devices uses this feature like routers, DVRs, NVRs and more.
Another request is to add an option to use the virtual devices in a different way (I don’t have a specific idea yet) for those that the Visnoic comes with a specific regional firmware and the areas names are not in English…


(cjcharles) #258

For the people who are having problems pairing (mainly the USA Powermax Pro versions but possibly one or two European Pro models) I have finally finished some cool debug firmware that prints out all comms onto a secondary Serial port. Hence if you have a USB-Serial adaptor and you connect the GND and RX pins on the adaptor to the GND and D4 pins on the Wemos, then you should see a load of debug messages on a serial terminal such as Termite. Can you PM me the contents of these logs and hopefully that will identify what is missing to get Powermax paired.

This is the firmware HERE
And this is an example output from Termite (57600bps and otherwise default settings):

@Gil_Hoffman Im not sure Ive ever experienced a crash, and removing from ST and re-adding would definitely not be needed in any case. Can you try and work out what causes the issue and send me a message. It might be related to certain commands, or certain events due to the hebrew characters on your alarm.


#259

I’m using the Visonic alarm interface for a couple of months now, and I am very pleased with it. The only annoying thing is that it’s not possible to assign a fixed IP to the Wemos. It switches IP and then I can’t control my alarm through Smartthings. I have a modem/router from my ISP which doesn’t allow to assign fixed ip’s.


(cjcharles) #260

I have been wanting to add static IP configuration for many months but have so far not found the time or motivation as there are things that give more benefit at the moment… Sorry!
I’ll see how I get on over the next couple of weeks and will see if I can add it, but I’ll need to change quite a lot of code to implement it in a nice way


#261

Thanks for looking into this. I understand there are more important things because it’s a specific situation.


#262

Hi @cjcharles appreciate this may be a little off tangent, but looking for some guidance. I’ve a UK Powermax all working fine, I have a powerlink 2 module with subscription to a remote monitoring service, provides emails, sms and remote app access etc, all good. I’m also running a z-wave domoticz system (running on a nas with usb z-wave stick) and would like to integrate the 2.

I’m fascinated by your work here but don’t have any ST kit, nor experience. using the kit listed in your shop is it possible to somehow use IFTTT to link to 2 together? I’m not looking for every function but things like if powermax triggered, fire to domoticz and send pics etc.

I’m sure i’m missing some basic principles here somewhere but would appreciate the guidance before i order your device and find this approach just ain’t gonna work etc. many thanks.


#263

Hi @cjcharles, I tried to build the latest ESP sources code (I want to experiment with it) but it failed because of the Pmax_ALARM being not defined. I noticed that the libraries have not been updated with your latest April change.
Is the latest change only related to MQTT?
Can I use it or should I use the code you submitted a year ago?