SmartThings Community

[RELEASE] Visonic Powermax Alarm

dth_security
dth_sensors
requires_server
project_security
project_sensors

(cjcharles) #222

That’s interesting, do you have any other links? What firmware version do you have in settings?

I have found a bit of information online that says if you have an old model which does not even mention Powerlink in the settings/installer options then this integration may not work (based on other smart home integrations not working in the same circumstances), but you never know. The problem for me is testing changes, but I have bought a few new bits for a new test rig which will allow me to sniff comms without interrupting them, so I can hopefully check out some improvements this weekend.


#223

Hi,

In the powermax+, where do I take 12V ?
I have +12V blue connector, but no GND arround.
I tried to take GND from the pins but its not working


(cjcharles) #224

Hi @Chura

Do you have the Arduino connected if using a Powermax+ ?

I will check again for good ground locations tonight, but I think there are several and it shouldnt matter which one you use


#225

@cjcharles Thanks for the reply.
I’m using Wemos D1R2 board, already loaded with firmware.
It iwon’t connect to my WIFI when using USB power. is that ok ? I taught maybe when using USB its on config mode.


(cjcharles) #226

That’s strange, USB power should still boot normally, unless you use programming software (like download tool or ESPEasy) to put it into programming mode.

Does it just keep booting with its own access point running? Have you completed the configuration once already? How do you know it doesn’t connect to the Wi-Fi?

p.s. There is a ground connection on the screw terminals which are used for zone 29/30, that is the best place to get it connected to ground, though it should still work through the pin header where serial connections are.


#228

Just wrote again, and now its connected :slight_smile:
I’ll try TX+RX and USB power to make sure we’re on the right track, because i’m not having too much luck with USR-TCP232-E :frowning:


(cjcharles) #229

Yes you need to connect to the RX/TX on the board, rather than the serial module which is designed to talk to a computer (at higher voltages). Hopefully no damage caused and it was fine all along!

As an update for others:
Ive been playing a lot with a Powermaster panel to see what is going on and why… Hopefully giving some insight about why some Powermax Pro boards dont work properly. I have managed to get it to control the Powermaster as it seems to use some really funky pin code and authentication processes where the numeric pin has to be set to AAAA (will then need to think about how to make it automatic). I will also need to then get the zone download/enrol part working.
Im not convinced this is very relevant to Powermax Pro either as it is all custom Powermaster stuff, so I might start looking to pick up an old US Powermax Pro panel for testing.
On another note, I have sadly not found any benefit of changing the serial speed as that kills everything, so it must be super recent panels where they have changed the serial speed!!!
Will keep going!


#230

I tried to connect TX-RX and even the opposite, i get nothing when I try to Enroll (long beep)
I’m using usb to power the device and RX+TX+GND from the 10pin connected.

What I’m missing ?


(cjcharles) #231

And the Arduino is powered from the Wemos right? Just checking it is powered from Wemos and sitting between TX of Powermax and RX of Wemos.


#232

Arduino ? I only have the Wemos D1 now, I understood is standalone. isn’t it ?


(cjcharles) #233

Have a read of my first post or the Github instructions, if you have a Powermax+ then you will need an Arduino in order to fix the TX from Powermax. Otherwise it is standalone, except the situations where Visonic have developed dodgy Serial interfaces on their alarms.


#234

Found it :slight_smile:
I can’t figure out whats the Arduino part in the process. Is it necessary when using USR-TCP232-E ?


(cjcharles) #235

Isnt the USR-TCP232-E a serial to ethernet module? If it is then I dont think that has a benefit in this implementation without some major rework of the codebase… The Arduino is there because the TX of the Powermax is really dodgy and works with very few RX pins, but the Arduino seems to be tolerant of it, hence can forward the information on to the Wemos.


#236

Ok
connected Arduino Uno written serial_echo.ino.eightanaloginputs.hex

still nothing, even nothing when debug on, even nothing on direct :frowning:
bummer


(paulhorti@hotmail.com) #237

Hi, it may have been asked already but … is it possible to trigger the alarm? I would like to add some z-wave sensors but to trigger the powermax alarm when they detect moment.
Thanks,
Paul


(cjcharles) #238

In answer to your question:

  1. I have spent countless hours trying to trigger the alarm through the existing serial connection to the alarm but failed as I tested every command up to 255 (the max byte allowed) to see what it did, but all I could trigger was a test alarm. The test alarm sounds for about 3/5 seconds before requiring a disarm message to take the alarm out of test mode and do anything else, in other words fairly useless…
  2. I ended up coding something that works with a separate bit of kit, where the hardware costs about £2, and it basically emulates a PIR that is controllable through the existing integration. If you look on my Github you should see a folder relating to the relay module, which you need to buy (for about £1.50 and then a couple of 220ohm resistors on top) plus how to connect it to Wemos. After that is set up then you can trigger an alarm by calling “both()” on the alarm panel ST device, through CoRE/webcore. If you set that wired zone as panic then it will trigger irrespective of whether the alarm is armed, but if you set it as a PIR/contact then it will only trigger when armed as home/away depending on setting.
    Hope that make sense but if you have any questions then feel free to ask more, as I developed it for somebody who was asking and hence don’t think many people are using it.

(paulhorti@hotmail.com) #239

I’ll have a look, many thanks.


(paulhorti@hotmail.com) #240

Hi, I ordered the relay and the resistors and was about to set them up …on your GitHub it said they should be 2.2k but above you say 220 ohm, which is correct?

Also, last Friday my SmartThings integration stopped working i.e. I’m not getting updates from the alarm and I’m not able to arm/ disarm it. I had problems with my router so that may be the issue. I’ve checked the ip addresses (ST and wemos) and they seem to be ok ( I assume that the network name for the Wemos is ‘Gateway’ + last 6 characters of the mac address), I’ve tried the refresh and configure buttons… Any other ideas?

Thanks,
Paul


(cjcharles) #241

Github will be correct, my comment above was from memory.

If the integration stopped working I would expect that the IP address has changed (probably of the Wemos but maybe also for ST), that would explain everything stopping, including the control messages (arm/disarm…) which are super simple. To get things back you just need to update ST with the new IP for Wemos (in device properties), and you can get the Wemos IP address from Windows under the ‘Network Devices’ folder. Without that address being correct then the refresh/configure buttons wont do anything, but should be those two buttons to fix it after updating the IP. I would also suggest trying to give the devices fixed IP addresses in the router config pages.


(cjcharles) #242

For anybody struggling to get the Powermax paired with Wemos I have been working on some potential fixes, mainly for the people who find the Wemos doesnt boot when connected to the Powermax (Im pretty confident this should fix things - there is a bug in an ESP8266 library that is scheduled to be fixed next month but I am trying a workaround). For users where it doesnt pair at all (mainly the Powermax Pro I think) then I dont think this release will help (but feel free to give it a go), but Im going to keep trying on that front and have now setup a bit of a test rig, which should help.