SmartThings Community

[RELEASE] Visonic Powermax Alarm

dth_security
dth_sensors
requires_server
project_security
project_sensors

(Saurabh) #182

Tried that a few times, but still not working. What’s weird is that when I disconnect power to wemos+Arduino and connect it back, I cannot access the website. It only works after I click reset on the wemos. I tried that a few times and waited 20 mins, but the zones are still not enrolling.

Is there a way to see the logs and figure out what’s happening?

Thanks


(cjcharles) #183

Thats strange, how long do you leave it on the first boot (i.e. before pressing the reset button)? Can you try leaving it in that state for a bit, since it clearly shouldnt happen and perhaps that will give us clues about the next step. Maybe check if the web dashboard loads every 5mins for 15mins and I would expect you should see something!! Also just after turning on the Wemos/Arduino you should see a light on the Arduino flash for a bit (it will flash, then do nothing for a bit, then flash a bit again before settling down).

You have comms to the alarm panel (hence you are able to arm the alarm), but the comms from the alarm to Wemos arent working at the moment - hence disarm is not allowed, and you do not get the zone list (the enroled_zones section at the bottom of the status page that you sent me). Do you have no ‘Enrol Powerlink’ in the Powermax Pro menu? I know every model is different and I have never tested with the Pro myself, but know plenty of users have it working well.


(Saurabh) #184

Thanks @cjcharles

Tried disconnecting and reconnecting the power last night. Checked multiple times and waited all the way until this morning. Still can’t access the website. The Arduino did not flash as you mentioned. One of the LEDs always stays on, while the other one stays on for a few seconds and then off for a few seconds.

And no enroll powerlink option in my panel. Reading through the entire thread, I think others had similar issues (not enrolling, no powerlink enrollment option). I wonder how they fixed their systems.


(cjcharles) #185

Will pm you and can discuss some options to investigate further


(Saurabh) #186

Sounds good. Thanks


(Thomas Lockyer) #187

I accidentally removed my zone devices and now they won’t recreate. Using the latest code for the device handler. Any ideas?

Edit: Nevermind - not sure what it does exactly but the test_function seems to have fixed it.


(cjcharles) #188

Yes, ST has quite a few bugs sadly, one of them is creating children and it gets stuck. The test function creates a single child (rather than multiple) and that seems to reset ST and allows working children creation again. For the benefit of others, if you have problems with child creation creating nothing (and there are no logs in the Web IDE) then you should:

  1. Remove all children (confirm that they are all removed in the app)
  2. Create a test device using the test_function (uncomment it in the device handler)
  3. Verify that it has created a test device in the app called Alarm Test Device or something very similar to that.
  4. Remove all children (confirm that the test child device is removed in the app)
  5. Now create children again.

Ive reported this to ST several times, but I think they have bigger things to focus on atm!


(Mr Garry Plowman) #189

First post :slight_smile:

I purchased the WeMos kit via cjcharles before my SmartThings hub had even arrived with the intention of migrating from a VeraLite.

For others here with PowerMax Complete boards I am pleased to report a complete success, though with a little perseverance! Credit where due, this handler is fantastic and I’m glad I decided to support the developer by going through the web shop - 5 star service!

This is how I managed to get it working:

  1. Followed the instructions and joined the WeMos to my home wifi network.
  2. Connected the RX and TX as per provided instructions.
  3. Connected red wire to positive SRN terminal on panel.
  4. Connected black wire to GND on WeMos board.
  5. Waited a few minutes for board to boot.
  6. Opened PowerMax dashboard via local IP and confirm connection.
  7. Added /reboot onto URL to perform a reset, for example; http://x.x.x.x/reboot
  8. Waited a few minutes for board to reboot.
  9. Reconnected to dashboard and connection to panel was established!
  10. Continued to follow instructions for SmartThings integration.

A day has passed and my Visonic door sensors are triggering flawlessly.

Hope this helps!


(paulhorti@hotmail.com) #190

My system has been running without any problems for about 9 months but suddenly stopped at the weekend. Looking at the logs I’m not getting anything but I can see that the wemos is on the network and the alarm device has the right IP address. I did notice on the Alarm device it says ST IP Addr. 192.168.140 (which I assume should be my Smarthings hub) which when I look on my router is not assigned. I did unplug my smarthings box at the weekend, could it have been assigned a new IP address and the wemos hasn’t reset it.

Any ideas?
Thanks, Paul


(cjcharles) #191

Yes, if ST changed IP address then the Wemos will be sending data to the wrong place.
Press refresh in the alarm device and you should see the correct IP address populated, then press configure.
That should sort things.


(lllll) #192

it seems that you are only one who still work on visonic smart home integration, thank you.
Is it possible somehow to use your work with domoticz?


(cjcharles) #193

It’s certainly possible. Ive built the device so it could be ported to another smart home platform, at a future date if needed. I dont know Domoticz at all though, so couldnt suggest how this might be done. All you need to do is parse some simple JSON messages about zone/alarm status (e.g. disarmed/armed away or motion/closed/open…) and make a few simple HTTP requests in order to change the alarm status. The hardest part is parsing the zone names, but even that is probably only 20 minutes work for somebody familiar with the Domoticz platform…


(Brandon Tinsley) #194

Greetings,

First of all thanks for helping us get a little more smartness into our alarm panels, but I am having an issue with integrating.

I have the wemos and arduino kit. When I connect them to my powermax +, I don’t get any chance to enroll. In addition, the wireless sensors seem to disconnect at random times.

I certainly may have the wiring incorrect, but I was trying to be pretty meticulous while following the instructions.

Thanks!


(cjcharles) #195

@Brandon_tinsley
Do you have the enrol option in your installer menu? Normally if you select that it will give a happy beep or a sad beep based on whether it was able to enrol the Wemos/Arduino. A quick photo is probably the best way to check the wiring, since the power connections can mess with other alarm sensors (or the serial comms), while the RX/TX connections will only mess with the serial comms (though some users have found that even this can affect other alarm sensors).


(Brandon Tinsley) #196

The option to enroll is there, but sad beeps is all I get. I will admit, I am a little unclear on where to ground within the panel.


#197

I’ve been reading this post, and hope this is the solution for me trying to find a way to easily integrate my Powermax panel into my home automation. (Currently using Home assistant, Smartthings not yet available in the Netherlands).

If I understand this correct, the Wemos itself offers a web-interface that lets me arm/disarm my panel and see the status of all sensors? It shouldn’t be a problem to integrate this into another solution than Smartthings, right?

Even if this wouldn’t work, it would offer me a way to arm/disarm my panel remotely (trough VPN) by just using the Wemos webinterface. Is this correct?

Regards,

Oliver


(cjcharles) #198

@Brandon_tinsley - the easiest place from memory is using the actual power cables which go into the Powermax itself (from the psu), though there are some alternatives. I can’t remember off the top of my head and ask away from my pc, but do feel free to add a pic and I can guide, or wait until I can check tomorrow.

@opaulzen - the web page does indeed provide arm and disarm options, plus allows you to see the status of all zones (though it’s not a nice interface for the zone status as it’s not currently built for that). It would be easy to send the Powermax data to another device (almost certainly home assistant would support small json messages), it would just mean you need to process the json messages into HA. I’m sure somebody has already done an HA integration though? (Though perhaps with more moving parts).
Also, as a side point, I’ve shipped a couple of devices to the Netherlands for users there, and all the UK SmartThings kit works well in Holland. Though that can sometimes be quite a change to switch platform!


#199

Ok tnx for the quick reply… so the Wemos actually can push information to another device? I thought I would have to query the data on an interval basis…so I could use mqtt for this?

changing platform is kind of a big deal Indeed…homeassistant currently offers integrations for every platform I’m running, except my alarm panel…and it’s rockstable for me…

Maybe I’m going to give smartthings a try in the future though…Or if i cant get this to work, i might consider using a mqtt bridge between ST and HA, this is already available…

ps: You do ship your pre-configured kits to the Netherlands I presume?


(cjcharles) #200

Yes, it is fully configurable so you can send it some simple requests to configure the IP and port to send the JSON messages to. For HA it looks to support this based on this page - https://www.home-assistant.io/developers/rest_api/ - and hence port 8123, though that is just a quick search. It is possible the Wemos may need one small tweak to auto-login to the HA API, but it may be possible to configure on the HA side too. Im also vaguely tempted to put the JSON messages inside MQTT since that would make it easier to consume from HA - and would be a small firmware update to the Wemos. As for writing the handler Im afraid I dont have time for that at the moment, but I’m 100% positive that the handler for ST will give you everything you need for HA!

And yes Im happy to send them anywhere, but I think there is a couple of quid premium for postage or something (and takes 4-5 days).


#201

Tnx, just ordered a pre-configured Wemos!

I will see if i can manage to change the body/headers of the POST, so i can use the Home assistant HTTP sensors…