[Release] Vehicle Remote Start (SmartStart) Integration

Does anyone know what the colt.calamp website is for? Just trying to learn something about it and if it is something that relates to my Smart Start integration with Smartthings.

Ken if you look at the device handler code that’s the website that it makes the call to.

@guarddog13, Ryan you are correct. Thanks for pointing that out. “def getServerUrl() { return “https://colt.calamp-ts.com” }” I take it this is the section you’re referring to? So my question is this: I’ve never used that website before, when I initially set up this integration from the piston you made for me, why is it needed now? The existing older module was changed out for the newer DSM550 module which is far more reliable than the older one as it functions on 4G/LTE cellular instead of the older 2G. What happened to the truck name on Smart Start? My biggest question is how do I get this module recognized? Either by IFTTT or webCore or colt.calamp or whatever one is the issue? If it is colt.calamp, then how do I add my module? I have no clue how to do that, I’ve walked through the whole site over and over and tried everything to no avail. Even the new site “lenderoutlook.calamp.com” has no option to add anything. I don’t get it. How did it even let me make an account with my AirID and ESN from the module when it kept telling me it was invalid? I just tried to log in with an email address and selected forgot password and it sends me a new temporary password, even though at the setup page it kept telling me the info I was entering was invalid. This is quite confusing to say the least. I would absolutely love to get this thing functioning again, after tweaking that piston you gave me, I used it all the time, it just wasn’t very reliable because of the old 2G module, that’s why I upgraded to the 4G/LTE module. If I can get that module and vehicle name to be recognized again I’d be quite the happy camper! Lol. Sorry for the long article, I’m just hoping to get somewhere with this issue. Thanks!

The only thing i can think of is that the 550 uses a different API than the older modules do.

Ok, I suppose that’s possible. Do you have any knowledge on how to fix that? Is an API something you can create? If not, are aware of anyone who has that ability?

I wouldn’t know where to start with something like that. Rob was the one who created this device handler. I only have utilized that.

See when i created an account on the colt webpage my vehicle was already listed. My understanding of this page is that it is where installers activate your device. It also serves a secondary purpose of housing the API for the device (where it makes it cloud calls). On this page under the dashboard tab I see my vehicle’s device. If i make changes to the device here it updates in the Viper app. If the smartthings name of the device doesn’t match to this webpage then smartthings will fail.

What my thought is that the 550 is housed on a different dealer webpage and thus their cloud for that device sits on a different part of the internet. Someone would need to figure out where that is…that can unpack apps and know and read code. I’m definitely not that technical.

I appreciate all your help Ryan. I hope I can get this thing working again! I’ll check with my installer and see if he can tell me where he activates the module. Maybe that’ll help. I also sent an email to tech support at colt.calamp. Thanks again. If you can come up with anything else please let me know.

@guarddog13 so apparently my installer registers the modules and setups at a site called directechs.com. Ever heard of them? Looks like a direct activation site for Directed SmartStart systems. I’m wondering if I can change the device handler to report from this site instead of calamp? Can’t seem to get ahold of Rob on here yet. I guess he’d probably know better as it was his device handler as you mentioned.

@rleonard55 Hi Rob, is there anyway you can help out with my issue listed above in my comments to Ryan? I’m using your DH from smart start 2.0, but it doesn’t work anymore with my new DSM550 module. I don’t know if that’s because it was set up on directechs.com or what the issue is. Do you have any input for this issue? Thanks

Here are my findings, I hope this helps the thread out… I recently upgraded to the DSM550 and like others found that the colt API commands stopped working. I logged into the colt dashboard and found that my car was no longer listed in their system. This makes sense because the 550 is super quick compared to the older unit i had - I think colt was the bottleneck here so Directed decided to go another route.

After nearly my entire Sunday - I looked through the Android .apk and found the new API endpoints (looks to be hosted by directed). There are more than the below, but this is all I needed. Also - I don’t mean to be rude - but I have spent a fair amount of time gathering this info and then updating my own custom DTH/Smartapps. Their code was convoluted and contained misnamed classes to the colt api (when really it was their new api); All this to say I’m pretty burnt out on this right now and probably am not going to answer many questions beyond this post.

  • Login/Authorization

    • POST to https://www.vcp.cloud/v1/auth/login

    • Username and password as “x-www-form-urlencoded”

    • The JSON response contains an Access Token (JWT), that must be included in any other responses in as an “Authorization: Bearer XXXXXXX“ header. The token does expire and it doesn’t look like they offer a refresh token.

    • Curl Example (I just let postman build this – I don’t know cURL well and cant verify syntax)

      • curl --location --request POST ‘https://www.vcp.cloud/v1/auth/login’ \
        –header ‘Content-Type: application/x-www-form-urlencoded’ \
        –data-urlencode ‘username=USERNAMEHERE’ \
        –data-urlencode ‘password=PASSWORDHERE’
  • Listing “Devices”

  • Get Device Info

  • Sending Commands

    • POST to https://www.vcp.cloud/v1/devices/command

    • Authorization Header contains JWT

    • Provide a json body like so

      {
      “deviceId”: {deviceidhere},
      “command”: “{commandFromList}”
      }

    • The possible commands are as follows (not all work commands are compatible with all cars)

      • arm
      • disarm
      • remote
      • aux2
      • aux3
      • panic
        *trunk
        *locate
        *read_active (returns some data about the car)
        *read_current (returns the rest of the data about the car; don’t know why its split)
        *req_runtime
        *extended status
        *enable_starter
        *disable_starter
    • Json responses vary with what command was sent. But they all follow the same structure.

    • Curl Example

      • curl --location --request POST ‘https://www.vcp.cloud/v1/devices/command’ \
        –header ‘Content-Type: application/json’ \
        –header 'Authorization: Bearer XXXXXXXX \
        –data-raw ‘{
        “deviceId”: {idgoeshere},
        “command”: “request_current”
        }’

Does this solve the break in Smartthings? I’d be tempted to upgrade now, if it does. I know absolutely nothing about coding though so likely still won’t, cause I’ll end up spending 4 months figuring out your post and I get not wanting to answer questions lol. The one I have now is reliable and with it being automated I don’t really need the extra speed.

Yes, although I made my own DTH/SmartApp to integrate with SmartStart, this allows the newer upgraded units to continue work with SmartThings.

I didn’t read through this thread, but the DTH at the top would have to be updated with the new API calls I posted. Based on what I saw in the APK, older units would continue to work. I think the SmartStart API proxies requests to the Colt API if they have an older unit.

Not impossible to update the DTH, but there is gonna be a learning curve if you’ve never written Groovy DTH/Smartapps

Yeah I’ve never written any type of code unless you consider webCoRE pistons to be coding lmao. I’ll stick with what I have. Its has a 99.9% success rate over the last 18 months, so I’m good.

So I have my own smart app I made through Alexa, is this something I will use in this fix? Or do I need another DTH? Do I need to use coltcalamp? Or do I need to use directechs.com? I’m not Sue exactly what the steps are in order to get my remote working again with Smartthings. May help would be hugely appreciated. I am even willing to make a donation for someone’s time to help walk through this process.

Hello All,
I recently upgraded my viper smart start in my jeep to the 4g DS4 module and I have lost the ability to automate starting my car (just like many on here), and I really want it back. I found and altered a python script on Github that connected to the colt.calamp url, and although it was slow, it worked. I see that people are getting close to dissecting the new url to the new server which is the vcp.cloud. I’m following but wanted to ask has anyone gotten closer to finding the exact urls and can convert to python? I am interested if so, and will donate.

EDIT: I finally gotten this to work with a PHP script I found on github. I set up a raspberryPI as an Appache webserver and installed the script. I can now run the script from any browser inside my network. With the dedicated URL I can now integrate it with the voice assistants (Alexa) and get to control my vehicle by voice. Please take a look at the end results here: Alexa, Warm Up My Jeep - YouTube

Is there a “for dummies” post for most current / best solution? I read through the conversation, but got easily confused. I’d LOVE to implement this. I have a Viper Smart Start, Amazon Echo, and SmartThings hub. I think all i need is ability to put these brilliant things to work the way you guys have!

Ian

@john159753 Hey John, I’m wishing right now that I could understand Greek lol. Your post you made recently with all the coding…was that the solution to what I’ve been searching for? To make my Viper DSM550 work again with Smartthings? If that is true, what would it take to convince you to set up a DTH or whatever is needed, to get this working? I would definitely pay for your time if that is what it would take to get my Smart Start integration back to how it worked before my module upgrade. I just don’t know how to read what you tried to set out in your post. I applaud you for having the ability to figure these things out, but I don’t seem to be able to get sequences like that transferred into a working code. Coding is not my forte. Please help me out. Thanks in advance.

If you get this let me know. I refuse to update from my 3G device until I know there’s a solution. I’m also willing to pitch in and pay whoever figures this out…as I’ve received many good deals from directed for their newest device. They really want everyone off those devices don’t they? Lol

I’ll take a look, guys.

I have my own server/api that acts as a middleware between 3rd party services (like Viper)/My home brew things and Smart things API. So I cant really share my exact code or device handlers because it wont just work for you guys.

I’ll need to open up this DTH at the top of this thread and see how I can make it work with the new Viper API