[Release] Updated Open Source Ecobee Device Type and SmartApps

Thank you, that is what I was missing

Safe to assume the “When Hello Modes(s) changes to” is the ST Location Mode? Seems like it, just wanted to confirm.

I created to 2 new routines, one for Night Time and One for Home and since I use ST Location Mode as Nite and Home, thought this would work out quite well.

I do have schedules setup in the ecobee app to trigger Home, Night and sleep in case we don’t leave meaning the ST Location mode only goes between home and nite

Am I thinking through this correctly?

Rick

I guess you are. I’m not sure I understand what is your question. I think of it like this: Ecobee’s schedule is primary, because it is more reliable. I use SmartThings to intervene only when there is an exception. I use the routine execution as a trigger, not the mode change because I have more than one routine that change the mode to the same value.

I’m getting this error:

“Error Saving Page”

Also here’s the log:

java.lang.NullPointerException: Cannot get property ‘c714d052-4e8f-445d-abd3-a1761613d763.411992023159’ on null object @ line 1155

This shows up when I;m trying to add the devices after doing the SmartApp authorization.

Any ideas what could be wrong?

Is it possible to switch on the ‘smartaway’ mode at all? When i leave the home i wanted to trigger the smartaway instead of away (not sure why yet but it seems to make sense).

There is no API available from Ecobee that allows an outside app to set to
the “smart” settings (away or home), unfortunately.

Understood. Great work on the devices and smartapps BTW. All i really wanted was to be able to change ecobee modes away and home. Very strange the ‘official’ does not allow this.

I do have a further question, the modes, when the ecobee changes a mode itself it is different to when the smart app does. The smart app will make the ecobee ‘hold until 11:30pm’ where as the ecobee itself will not ‘hold’

Is that right or am I doing something wrong?

You can select whether you want to change the mode “until next program” or “until I change”. When you do it “until next program” then it will show this “hold until 11:30pm”.

ah i didn’t realise that. If it is on ‘until I change’ I assume the next ecobee program will not be able to change it though? Just interested in how it is working

Yes, until you change means hold indefinitely. You will need another event to change it back if you don’t want it to get stuck. I like the use the “resume program” action when the event triggers. So for example if I change to Away, when I go out, the reverse action is not to change it to “Home” because I don’t know at what time it may happen, if I use “resume program” then it will change to the appropriate mode in Ecobee depending on the time of day and it’s schedule.

1 Like

That is interesting. I use smartthings geofences so i like the idea of the thermostat changing to ‘home’ and heating before i get home (walk from subway exit to house). Using ‘resume’ I suspect would not do this for me as I suspect it would then need motion to trigger heat.

Yes, you are correct.

Using geofences is a bad idea in my opinion. If you have ever looked at the history of your location that your phone generates you will see how it has these jumps like you have been teleporting from one place to another even when in reality you have been sitting in one place. I don’t understand why people insist on using something so unreliable.

I would agree with you for my girlfriends iphone (i have now given her a fob) but to be honest my s7 edge is super reliable and it hasn’t jumped around like her phone. There is also a 10 minute window before the system switches after determining we are all not home.

Each to their own but this solution works perfectly for me. I just wish her iphone could be relied on to use geofences.

Once again thanks for the work, I have made a few tweaks to suit my personal taste but great work :slight_smile:

I am having issues where all of my ecobee sensors are displaying as inactive in smartthings now, including the thermostat. What caused this to happen and how do I get them to be active again? Thanks!

Please share your tweaks, @boreddead - if I can general-purpose them, I will!

@krusej23 -

There should not be any problem with these devices showing as “INACTIVE” - they should continue to work properly.

Although SmartThings has said that integrating custom DTH’s with the new activity monitors is not yet “released”, my next update will in fact integrate so as to avoid this issue. It also includes better handling of “offline” thermostats that lost their connected to the Ecobee cloud. I hope to post these updates today or tomorrow (thermostat and sensor devices only).

FWIW, I am referencing the branch I have made from @StrykerSKS’ version, which is available here: [RELEASE] The Best FREE Ecobee DTH and Helper SmartApps - Now with Ask Alexa Message Queue Support, and an Enhanced User Experience!

I’ve had this version of the ecobee3 installed for about a week now, and there are a few things I noticed. Not sure if these issues are specific to me or not, but here goes. When the tile says “heating to…” it is always an inaccurate number. The motion reporting function is always off. I think I saw that already mentioned here, that when there is no motion, it is reported in the app as there having been motion. That being said, the only thing that really frustrates me is the open contacts child app. It flat out doesn’t work, and I really want it to.

@Andy_Armijo -

Since you’re not using my version, I can’t help a lot, but here goes what I can offer:

  1. Not sure what you mean about “Heating to” an inaccurate number. What number does it show, and what number is set in the Schedule/Hold (as seen in the Ecobee App on your phone or on the web)?

  2. “Motion” is weird - it takes up to 15 minutes of activity for the Ecobee sensor to decide it has seen motion (occupancy), and another 15 minutes of inactivity before it decides that motion has stopped. This is the way the sensor works (which is very different from most SmartThings motion sensors).

  3. What is the specific problem with Open Contacts - what are you setting, and what isn’t happening?

Also, are you using iOS or Android?

I’m pretty sure I am using your version, which is why I posted here, unless there is an updated version somewhere that is ridiculous to find throughout all the various versions. The Heating to number is displayed underneath the main number within the device, and for instance it says 68, when the program has it heating to 70. I’m using an iphone, and the open contact sensor is set to turn off hvac after my backdoor has been open for ten minutes. It wasn’t showing anything in the log after those ten minutes, so I tried to uninstall the reinstall. Now it does show up in the log for ecobee, saying “open contacts handler,” but I still don’t think it is adjusting the hvac. I noticed I had that childapp unpublished, vs having the other child apps published. I’m sure I did something wrong there and was just going to check what the documentation says.