[Release] Updated Open Source Ecobee Device Type and SmartApps

No worries, I understand entirely.

Thanks again! :slight_smile:

Is this the correct device type?

The reason I asked is because I installed it with the connect however I am not seen the comfort profiles in CoRE

The comfort profiles are not standardized so you have to enter them manually.

1 Like

Thanks (Sean),

Do you know what this error is about? I get it when I try to say the SA settings after I select my thermostat

6:59:55 PM: error refreshAuthToken(), General Exception: java.lang.NullPointerException: Cannot get property ‘xxxxx’ on null object.

error pollEcobeeAPI(): General Exception: java.lang.NullPointerException: Cannot get property ‘value’ on null object.

I see that the same issue happened here: https://github.com/StrykerSKS/SmartThingsPublic/issues/73

I will open a ticket there for you. Thanks!

@StrykerSKS can you look into my issue please?

This is an intermittent SmartThings platform issue. Not sure that there is anything I can change in the code to prevent it. You just have to try again (as others did in the previous report)

@bboy486 unfortunately SmartThings just hiccups periodically causing one to look at the smartapp/device handlers as the issue when in fact the platform has messed up the execution. I am having issues not only on this device but on others as well like some of my other WiFi devices H801 and SmartCam Pro.

1 Like

Any idea if the Ecobee 3 Lite is supported?

Once adding it requests me to chose my thermostat, which I do.
Then under sensors it shows 0/?.

From here I cannot save as it errors out. If I remove my thermostat it allows me to save.

Seems like the lack of sensors is possibly causing a failure?

The ecobee3 doesn’t include support for its wireless room sensors. Not positive how the device handler treats that but I can’t imagine it is nothing more than an annoying display of 0 for the sensors? Tagging @StrykerSKS for clarity on why it won’t save

It’s on the to do list to investigate. I’ve been on the road for
Work so haven’t been able
To investigate. And since I don’t have a Lite thermostat to test with I have to rely on data dumps from others. I have data sitting in my Inbox that hopefully will lead to an answer

2 Likes

Same for me.

Please Ignore.

I am new to ST so I may just be missing a setting here. I have noticed in Home IQ that when my ST sets my 2 ecobees to “Away” via geofence trigger, HomeIQ shows the mode still as ecobee’s home mode with a hold status but the setpoints change as directed for the away mode.

Is anyone else seeing this?

Sean,

I posted the same basic issue on the github issues page. I searched around and found this one as well, so I’m following both.

I’ll do as you say and continue to keep trying to add the thermostats until it works.

I have just posted a significantly updated and enhanced version of the Open Source ecobee device created by @StrykerSKS . You can find the discussion for it here

Just saw that. Guess I should have gone through all my alerts before responding :slight_smile:

Hi thank you for your smart app! I was wondering if there is a proper way to cancel smart away? I’m trying to use resumeProgram with no parameters but it doesn’t seem to cancel it. Some other ideas are to just set a specific temperature and/or program I’m assuming a pass a string of the mode name from the Ecobee site.

Hey @StrykerSKS,

Just installed your ecobee SA/DTH and I am struggling with how to set as follows
I would like ecobee to go into sleep mode when ST goes into sleep and Home mode when ST goes into Home mode

Currently I have Sleep and Home as comfort settings with their respective temps

I am also trying to setup a CoRE Piston to do this, think I have the sleep figured out but not the home

What am I missing?

Rick

@StrykerSKS a couple questions on the Smartapp and I’ll preface them by saying that I’m fairly new to the SmartThings ecosystem and this is my first attempt at using a smartapp, so bear with me.

I have my families two phones setup as presence devices that change the mode to away by using a routine when they both are out of my geofence. When this happens, I have an Ecobee Connect routine handler run which will set my ecobee to Away.

When a single phone arrives, the Home routine runs and I then have the Ecobee connect routine handler run to Resume the ecobee.

Last night when we left my ecobee went to away, but when we arrived it was still set on Away and holding. Not sure if I have something setup wrong, as this is the first time it’s happened. I verified through the smartthings notifications that the mode was set to home when we arrived, so I’m not sure what happened.

One last question, is it possible to get all the LastPoll and humidity notifications removed from the notifications page, it spams it up quite a bit and makes for a lot of scrolling if you are trying to find something in the past. I set the debug level to 0, but that didn’t seem to help.

@Toy4Rick, start your Ecobee (Connect) app, click on Helper SmartApps, Create new Routines Handler. You can use Mode change or Routine execution as triggers. You don’t need CoRe for that.