[Release] Updated Open Source Ecobee Device Type and SmartApps

If my door opens it turns air to 85 so I don’t cool the outside then sets to 74 when closed.

Would like to know how to do several things.
1: turn off air instead of set to 85 to stop it.
2: turn on air when closed instead of set to 74.
(Turning mode on and off allows me to keep the current temp instead of forcing it to 74).
3: only trigger action if door is open for more then say 90 seconds (the goal is to kill ac if door is left open not each time door is opened)

This situation (on/off vs temp change) should be able to be handled through the open contacts child smartapp within the ecobee (connect) parent app. Have you had a chance to check it out?

Exactly what the Contacts & Switches Helper SmartApp does - including the time delay. You can create an instance from within Ecobee (Connect) - Helper SmartApps - Create New Contacts & Switches Helper…

You have a link to this app?

Thanks

The link to Barry’s version is at the bottom of the first post, under Popular Links — “… BEST Free Ecobee …”

https://community.smartthings.com/t/release-the-best-free-ecobee-dth-and-helper-smartapps-now-with-ask-alexa-message-queue-support-and-an-enhanced-user-experience/81616

After hours of trying and trying in all different ways this app still doesn’t work right. If I use the github repo, I always get {“error”:true,“type”:“java.lang.reflect.UndeclaredThrowableException”,“message”:“An unexpected error occurred.”}

If I install manually, it looks like this:

OATH, routines, device handlers all there.

Any fix?

Finally got it to work but had to install everything manually. Why would it not work when installing from github? Why would it not work if it is partly installed manually and partly through github?

From the screen shot provided, it seems clear that you aren’t running either @StrykerSKS nor my version (link immediately prior to your post above) so it is unlikely you will get any help on this thread.

In the post you quoted, I specifically said that I got it to work properly and how I did it. Your rude answer doesn’t even answer the question you quoted.

I don’t think Barry was being rude. He was stating a fact.

When you say that you got “it” to work, what is “it” since it isn’t the version that this thread is about. That is what he was trying to point out.

Perhaps you posted on the wrong thread?

2 Likes

@hawtboi1 -

My sincere apologies, I did not intend to insult you.

My point here is that you aren’t using either of the DTH versions discussed this thread, and so it is doubtful anyone reading this thread will be able to answer your questions. You should probably post a new/separate thread that is specific to the DTH version you are using.

FWIW, both @StrykerSKS and my version of the Ecobee DTH cannot be installed manually. Everything must be installed and configured using the Ecobee (Connect) parent SmartApp that each of our versions supplies. I generally find that people who have problems with sourcing their code from Github have extraneous copies of other Ecobee DTH and/or SmartApps existing within their IDE, have made local changes to the copy in their IDE, and/or they have installed to an IDE running on shard that is different from the one their SmartThings hub has been assigned to.

1 Like

I thought it is obvious that I am using everything from StrykerSKS and that I would not post in the wrong thread.

Isn’t this StrykerSKS github repo?

That same page says that anyone can manually install everything manually instead of using GitHub Integration that SmartThings offers with their IDE.

I have other apps using GitHub Integration that do not have any problems.

So that goes back to the original question: why would GitHub Integration not work and work fine manually and only for StrykerSKS?

Yup, that’s his repo.

But his DTH suite doesn’t look like the screenshot you posted above. His UI is described here:

https://github.com/StrykerSKS/SmartThingsPublic/tree/StrykerSKS-Ecobee3/smartapps/smartthings/ecobee-connect.src#features-therm-ui

Note the extreme differences from your screen shot.

Hence, our collective confusion…

All I did was install the DTH using GitHub Integration according to instructions at https://github.com/StrykerSKS/SmartThingsPublic/tree/StrykerSKS-Ecobee3/smartapps/smartthings/ecobee-connect.src#install-using-github-integration-recommended-method.

I then installed the smart app manually according to instructions at https://github.com/StrykerSKS/SmartThingsPublic/tree/StrykerSKS-Ecobee3/smartapps/smartthings/ecobee-connect.src#install-manually-from-code-1.

I installed the smart app manually because the instructions at https://github.com/StrykerSKS/SmartThingsPublic/tree/StrykerSKS-Ecobee3/smartapps/smartthings/ecobee-connect.src#install-using-github-integration only produces this error: {“error”:true,“type”:“java.lang.reflect.UndeclaredThrowableException”,“message”:“An unexpected error occurred.”}

In the end, I decided to try to install DTH manually using instructions at https://github.com/StrykerSKS/SmartThingsPublic/tree/StrykerSKS-Ecobee3/smartapps/smartthings/ecobee-connect.src#install-manually-from-code and the smart app using instructions at https://github.com/StrykerSKS/SmartThingsPublic/tree/StrykerSKS-Ecobee3/smartapps/smartthings/ecobee-connect.src#install-manually-from-code-1. Lo and behold, it worked!

But it didn’t work. It should look like the screenshots!

My best guess is that you either have some other DTH installed too or pulled from a very old version of mine.

In the code in the IDE what version does the headers say it is?

Making a mistake setting up GitHub Integration seems impossible to me when looking at this:

Capture

Here’s the other DTH’s I have:

Capture

Capture

Delete the device, delete the device handlers, delete the smart app, make sure you don’t have any other EcoBee devices anywhere and start from scratch. Something is very wrong with your install.

You are using the wrong branch. Don’t use “master” use the one specified in the instructions please.

Thanks. I will try that. Did not think that was possible.