Update and try now. Make sure the “Number of Bulbs” is not 0. I changed the default value. Make the number of bulbs equal the number in the group.

Tried new code with a new device, with number of bulbs being set right. I had the same issue. Only difference was that now Log Level is a required field. But even with it and the others filled in, still getting the “Please fill out all required fields.”

I don’t know. It might be an issue with the ST app. I can’t seem to find the issue. I have a new android tablet. I can debug tomorrow. For now you can setup via the IDE?

Yeah, thanks for your efforts. I’ll keep checking this thread to see if you can fix it. :slight_smile:

Is there any possibility of adding support for scenes from LIFX as opposed to creating them in the device itself for those lights? For instance I have a group of 7 lights in my addition called “Addition”. I set up a scene in the LIFX app called “Green” that turns those 7 lights to green at 100% brightness. I’d like to create a separate device for that scene similar to how you would normally create a device for a group. When I turn it on, it will activate that scene and turn the lights green. When I turn it off it will return them to their previous state, whether that be off, a different color, etc.

If you haven’t checked out CoRE yet, it supports Lifx scenes.

Is it possible to control individual bulbs? I currently use the stock Lifx connect which seems to be unstable some times.

Yes. SmiartThings supports LIFX or you can use my device handler.

Thanks Eric. I already use the SmartThings LIFX connect. Having problems with this sometimes being unresponsive. So looking for alternatives. I will try your app.

@whoismoses I have installed the ST-Better-LIFX-BULB device type. I have configured this with the 1 lifx bulb I have. Can you please clarify what are the schedule start and end numbers? I removed these, but when I go back to preferences, they change to 7 and 23 automatically. I already have automations created for my lights and don’t want a seperate schedule.

I have just noticed that the colour wheel doesn’t work in my installation. Can you please help me fix this?

I also have a question on adding new LIFX bulbs. I have one more arriving next week. Can you please confirm the following steps are accurate?

  1. Create a new device in the IDE and select ST-Better-LIFX-BULB as device type.
  2. Goto ST app and configure with the same API key I used earlier, but the bulb name I have entered in the Lifx app.

This might help.

Once you have installed the device handler do the following to add the device to ST.

Login to ST IDE.
Click "My Devices"
Click “+ New Device”, top right corner.
Fill out the information. For “Device Network ID” give it a unique id. I do something like my initials with a long sequential number. Maybe “PTC000001” in your case. If you create another device increment the number, “PTC000002”.
Don’t select a group or enter a zigbee ID.
Hit Create.
Once you have done this, the device will appear in your ST app.

Find the device in the ST app.
Once in the device, click the configure button (cog).
Take a look at the settings options.
There are two critical fields. “Bulb Name” and API Token.

The bulb name should be exact (case-sensitive) to what it is called in LIFX.

Follow the instructions here to get your API token.

1 Like

These are required. Since LIFX does not send ST updates on the bulbs status (on / off) the schedule will query the LIFX api for a status update. That way if you turn the bulb off using the LIFX app and not ST, ST will know it changed. The fields are required. If you won’t want it to use the schedule just turn off the use schedule switch in the settings, right about the start / end values. It doesn’t hurt to leave it on, LIFX gives you something like 100,000 calls a day, 12 times an hour isn’t going to hurt.

You are the second person to tell me this. I don’t know why it wouldn’t work as it is just calling the API. Are you sure they are the color version of the bulb? When you change the “Color Temperature” slides does that do anything?

Thanks for the clarification. The bulb I have is the LIFX colour 1000 which is indeed a colour bulb.

Colour temperature works fine.

What button controller are you guys using with your Lifx? It looks like the Button Controller - Enhanced Lighting might be the most flexible - best candidate?

I have a Lutron Pico remote with 5 buttons that I’d like to use to control a group of 8 Br30 bulbs. I’d like to have the top button turn on to soft white, the bottom bottom button to turn off, the middle buttons to dim whatever color is selected and the center button to rotate colors (randomly). Looks like the button controller support core integration, which I’ve not used, so perhaps a combination of the two works best?


I use a minimote. A minimote in combination with CoRE. CoRE has an integration with lifx. You can push a button on the minimote and trigger a lifx scene that your created through the lifx app.

Doesn’t look like this would allow for dimming if the button is held? It looks like scenes only allow a single color/dimming level to be activated.

I guess you could program a hold to dim the current settings.

But if you’re looking for a hold to dim them for as long as it’s being held, then you don’t want to use a minimote.

I’m not using a button controller for my lights. I use the Cooper RF 9500 to control them manually, however we have migrated to allowing ST to decide if the lights should be on or not based on time, motion, contact sensors… We rarely touch switches or buttons anymore.

I’m not sure how long this has been happening but I noticed the following in my logs this morning. It’s showing for both my configured lights every 3 minutes or so.

Can you set your log level to debug and capture some logs for me?