[RELEASE] [Universal] Foscam Camera Device Handler with Discovery, Live Video Streaming, Motion Sensor/Alarm Integration - SD (FI89xx), HD (FI98xx, FI99xx), Cx, Rx, Ex, Fosbaby


(www.rboyapps.com - Make your home your butler!) #147

Added the following enhancements to the Foscam Motion Alarm Monitor SmartApp

  1. Ability to select Modes for Monitoring for Alarms (when in a mode that’s not selected it will not disable the Alarm Monitoring on the camera but will not report it to ST)
  2. Enabled option for Push Notifications for SD cameras, there’s an option provided to use Alternative Method of Alarm Detection (i.e. disable Push and use Poll instead). Use this if your SD camera is not able to send Push notifications for whatever reason
  3. Added option to Start/Stop the camera cruise when an external alarm is set off (so when coupled with enabling the monitoring this can act like a recording device for your house when an external alarm goes off. Make sure you configure your other SmartApps to turn on the camera alarm monitor when the external alarm goes off)

Key point to note for SD camera’s, if the default Push Detection for Alarm is not working, Enable the option for Alternative Alarm Detection in the SmartApp


(www.rboyapps.com - Make your home your butler!) #148

Fixed an issue with SD camera’s not reporting the Motion Alarm. Use the latest device and SmartApp. Make sure you refresh the device and then re initialize the smartapp in that order after updating the code.

(www.rboyapps.com - Make your home your butler!) #149

Finally managed to get Push Alarm notifications working for cameras that support it (MJPEG/SD). Updated the Foscam Motion Alarm Notification SmartApp. Make sure you have a valid DNS settings on your camera for this to work.


Created Device type Foscam IP Camera
Created Device “Office Cam” for my Foscam 18918W camera
In the ST “Things” page, tested camera features such as “Up”, “Down”, “Take Picture”. All work fine
Loaded the App “Foscam Motion Alarm” selected the Office Cam., turn on light when motion
Tried to exit and app crashed. "Failed to save page"
Tried both on Samsung S6 and Ipad 3…

No idea where to go from here.


Going from bad to worst :rage:

I installed the “Trigger to take picture” app and it works fine. Unfortunately, I had this idea if I were to starts from scratch I might have better luck with the “Foscam Motion…” app. I uninstalled one of my cameras, recreated the camera device then tried to take Picture. Nothing… It also does nothing in the “Trigger…” app. I can however, move and/or reboot the camera. I compared setting with one of the other cameras (also Foscam IP Device type) and cant see any difference other than IP (& network ID)… I have rebooted the camera but nothing…

(www.rboyapps.com - Make your home your butler!) #152

Okay so it’s always good to hear about issues it helps figure out where the instructions aren’t clear. As dev’s we tend the repeat the process so often it becomes second nature for us.

First up, I’m pretty sure you’ve read through the thread to realize that the not saving issue is a ST app/platform problem. It’s not an app crash but a rending issue/metadata saving issue… You would have also read that the picture not showing up is a communication issue between the camera and the hub. If either one runs slow it times out and hence no picture. The best bet is to reboot the camera / hub. It is also highly likey it’s a corrupted installation in which case you need to change the IP address/port (and NO reinstalling the device will NOT work, see below for details, ST platform has a memory so you need change the IP address/port).

However in our testing here at the labs we found that the SD camera’s firmware are more unreliable than the HD camera’s and tend to freeze/lock up/lose connection with WiFi every now and then.

Having said that I decided to try it over from scratch and follow the exact instructions written on the website. I realized there was a missing step and also updated the website. So check out the website, however I’ll walk you through a few things.

  1. Make sure you’re running the latest code for both the SmartDevice and SmartApp. Both are currently at version 2.1.4 (it’s written at the beginning of the code)
  2. Start with the Camera, once you have installed the latest device code, click on Refresh first to load the settings
  3. If your camera movement works (up/down) then the setup is correct. If not check your username (case), password, IPaddress and port. If there are still issues it could be to do with the communication speed/stability as mentioned above. Also ensure your camera and hub are on the same network and accessible to each other. Usually a reboot fixes these issue. I’ve found that the 9810 doesn’t seem to like one of the routers we use here in our lab, it works great with the other. So check it out, use a lan cable to rule our WiFi issues.
  4. Change your camera ipaddress or port. IMPORTANT STEP. As pointed out in a few posts above we’ve seen that once in a while an installation gets corrupted (god know why like many thing on this platform), but the important thing is that ST has some sort of a memory. It remembers the IP address/port combination for a particular device. As long as it remembers that unique combo the device will ALWAYS remain corrupted until you change the IP Address or Port of the device. A typical symptom of this issue is the motion (up/down/cruise) works but the Take Picture does not and neither does motion alarm!. Looks like you are facing this issue, so go ahead change the IP address or port of the camera (any one is fine) and then change the settings in your device preferences page (you don’t have to reinstall it). That usually fixes the image issue and other seemingly “random” issues like I cannot turn on the Alarm Monitoring features.

After starting clean I following the above steps (AND BTW I ran into the SAME not taking image issue, change the port and IP address and it worked perfectly after that! Then I checked the Foscam Motion Alarm SmartApp and enable the motion alarm and walk past the camera and I got a notification.

Hope this helps!


I did that for the 1 camera I had re-installed and would no longer take a snapshot. With the new address the snap picture worked however, I remember having the same issue months ago when I first added these cameras to ST. Wouldnt work at first, next day all was well. Go figure.

Reluctant to re-assign a new ip to this camera I set it back to its original address. This morning I decided to try snapshot again and like several months ago, it worked. First I tried the “Trigger to…” app and it worked. After that I review the setup for the Foscam motion… App and realized I had not enabled “OAuth” option. Once I did my problems disappeared. Now all that is left to do is figure out what these app will/can do and how I will use them :smile:

(www.rboyapps.com - Make your home your butler!) #154


Foscam Device Type v2.1.5, added option in preferences to compensate for sudden light changes for SD camera’s to reduce false motion alarms due to sudden changes in lights

(www.rboyapps.com - Make your home your butler!) #155

Added option to turn off lights after X minutes in Foscam Alarm Motion Detection SmartApp
Also improved push notifications and status updates for SD camera’s


These cameras + ST = too much headache.
Today I noticed that one ST Foscam IP device, which worked fine in the past, had not sent “Intruder” event for sometime even though the camera had detected and uploaded images. The ST Device was unresponsive and attempting to make any changes via preferences “failed to save page” error.
Rebooted hub + camera. No diff.
I deleted the device, recreated it and gave it a new ip/port. No diff.

Current device type version: Foscam IP Camera, v2.1.6
Smart App Foscam Motion Alarm Monitor, v2.1.5 (not using it in this scenario)

(www.rboyapps.com - Make your home your butler!) #157

Yeah we have also seen issues in the lab since the platform upgrade but most if them get resolved just by re initializing the smart app or rebooting the hub. However yesterday we did some issues with the hub dropping communication with the camera (as in between the hub and camera). I became okay after a few hours. I guess the platform was runnin slow.

Start by ensuring the settings are correct after you’ve set it up again. See your live logging. When you hit refresh check your settings and if you’re seeing blue messages. Post back what you see.

(JC) #158

I there a way to the foscam ip device type to work with Smart Home Monitor App?

(www.rboyapps.com - Make your home your butler!) #159

Not yet. It needs a Few things

  1. V2 hub
  2. ST support - they haven’t exposed the API yet to the community
  3. ST support - they need to support the video streaming methods of Foscam

(Preston S) #160


I have had both using both ST and Foscam for a while but never integrated them. I want to now. Would you recommend that I wait until I have my V2 hub? Or will it not make a difference and I should just dive in now?

(www.rboyapps.com - Make your home your butler!) #161

You can go ahead and use it with V1, I don’t expect any major changes with v2 for the current device. Video is still some time away and local processing probably longer. It would be good to use local processing especially for the newer HD cameras but until ST provides a way to choose processing engines it will still work in the V1 way.

(www.rboyapps.com - Make your home your butler!) #162

Updated the Foscam Motion Alarm Monitor SmartApp to be compliant with new platform guidelines for push notifications (for SD Camera’s).

(Patrick Musselman) #163

@RBoy With the v2 Hub I am often getting image distortion. I have included two examples so that you can see what I am talking about. However there are times when the images come out correct. On my v1 Hub I did not have image issues like this. Maybe something has changed with the v2 that is causing the issue? Is anyone else seeing this issue?

(www.rboyapps.com - Make your home your butler!) #164

haven’t got my v2 hub yet :frowning: When did you order it?

(Patrick Musselman) #165

On 8/18 from ST. Hopefully you get your soon.

(Kevin) #166

I have the same image distortion issues on my V1 hub. I haven’t switched over to my V2 yet.