SmartThings Community

[RELEASE] Universal Enhanced Z-Wave Plus Lock Device Handler: Schlage, Yale, Kwikset, IDLock, DanaLock, August Pro, Samsung, Locstar, Delaney, KeyWe, Philia Locks and Popp Z-Wave Keypad with Alarm Control, Notification, RFID, Door Sensor

Is there a demo/way to test before buying? I’m not 100% sure if it will work or not.

I ended up just paying :slight_smile:

I set up a new device handler using the ‘code’ option.

I got it set up in the new smartthings app, but I don’t see the door open/closed options. I went into the settings and turned on DPS.

Hi there. If the lock is reporting the door / close status it will show up at the tile below the auto lock tile. You can find a screenshot in first post of what it looks like.
But first the configuration needs to be successfully activated. Make sure your lock is within 20ft if a repeater and then open the preferences page and tap Save, you may have to do this a few times before it takes effect depending on your mesh quality. This forces a configuration update on the lock, once it activates, the sensor state should start showing up when you open/close the door (make sure the magnet sensor is aligned).

If you’re having trouble with the feature activation you can send our support desk an email and I can look into your device live logs and see what’s going on with your lock/mesh.

Hi there. Thanks. I sent in an email and included the screenshot from earlier and the live logging from the SmartThings website.

I have two of the schlage connects working fine using this device handler until one of them started to act up.

Its been showing unavailable and locked but its not.

Aside from removing/excluding and pairing it back, is there another way to fix this?

I have tried z-wave repair but this did not fix the problem.

Thanks

I’m looking into getting a Kwikset 888 deadbolt. Kwikset 888ZW500-15S Smartcode 888 Electronic Deadbolt with Z-Wave Technology https://www.amazon.com/dp/B07BLJ38SJ/ref=cm_sw_r_cp_apa_i_bjh7Cb5F4GEQA would this work?

Yes it’ll work but you want to be aware of a few things about this lock:

  1. It uses certain plastic components internally (rather than metal)
  2. It’s okay for casual use, if you’re planning on using it for rental property with automatic code generation apps like RLA, because it shares numbers on buttons, the lock can’t tell the difference between 1234, 2134, 1144, 1233, 1243 etc (thousands of numbers are unavailable to use across the 5 buttons) and so programming will fail in these cases. See this post.
1 Like

Thanks for the response. I’m replacing a monoprice deadbolt, so this should be an upgrade right? My monoprice deadbolt just stops responding sometimes and I need to power cycle it to get it working again.
To be honest, I’m more interested in the convenience than the security of it, I have other locks and cameras in place for that.

I sent in the requested logs and also a screenshot showing that “Contact” only appeared in the events list 5 days ago. There are no events for “Contact” or “ContactX” anywhere else.

For anyone with a Yale YRL226, the device handler won’t work with the August door sense.

I’ve tried support and also Yale. Yale says there is no way to get the zwave module to work with door sense.

From Yale:
The door sense is only designed to work with the August app.

EDIT - Model is YRD226 not YRL226

Has anyone used this on the Kwikset 888 series? I didn’t see it as a supported device, but was wondering if it worked anyway and if there was an advantage to using this over the defaults DH.

Universal Enhanced Z-Wave/Plus Lock/Keypad Device Handler - Version 04.04.01

  • Added support for Schlage (ZP series) and Yale Z-Wave Plus locks
  • Auto enable DPS on Yale locks when detected
  • Added option to enable Eco mode on Yale Z-Wave plus locks (when supported)
  • Added option to select vacation/privacy/passage mode when code entry is disabled for Yale locks
  • Added support for Kwikset Z-Wave Plus locks and 8xx series
  • Kwikset 888 features
    • Remotely enable/disable Auto Lock
    • Configure Auto Lock timeout (30,60,90,120,180 seconds)
    • Remotely enable/disable Audio

Schlage Lock Alarm Mode and Sensitivity Change and Monitor - Version 02.02.00

  • < no changes >

NOTES:

  • The Yale Eco mode switches the locks to low power mode with reduced sound and LED brightness (supported by some newer Z-Wave Plus modules)
  • The newer Kwikset Z-Wave Plus 8xx series supports remote control of AutoLock and Audio features
  • The Kwikset Obsidian (954) Z-Wave Plus and other Kwikset 9xx models which have DIP switch controlled features only support reporting AutoLock and Audio status (not changing remotely)

It helps to add a buffering device/repeater within 20ft of your lock for best performance

You need a SmartApp like Lock User Management (LUM) , Rental Lock Automater (RLA) or SmartLocks to program user codes, create actions for locking/unlocking/user codes and notify you.

Refer to the first post for more details and on how to enable Real Time Dashboard with SmartLocks

We have compiled a comparison of different lock model features on this link to get started with buying locks

NOTE: You should be on DTH version 04.03.00 or newer to be compatible with the new 25.x firmware for V2 and V3 hubs

I just installed the new Zwave Plus Schlage lock BE469ZP.

Is it normal that the security level shown is not S2 but S0?
I have a lot of Zwave plus repeaters around

image

Yes that’s normal. ST doesn’t support S2 yet.

1 Like

I just installed & fitted a Yale Keyfree with the latest Z-Wave 2 module (blue). I bought this DH last night and have been able to successfully create a user code from the associated SmartApp but this morning when trying to enable passage mode or turn off audio I get an error logged in the lock

AutoLock feature not supported MSR 0129-0600-0000

From other people in the thread it looks like this feature should be enabled and is what the Yale interprets as Passage mode.

Any ideas?

Hi there. That message is printed because you tried to operate a feature that your lock reported isn’t supported. I will need to see your IDE Live Logs to see specifically what your lock is returning on the discovery request, it could be incomplete discovery request or possibly your model doesn’t support it. You may want to check that you lock is within 20ft of a buffering device to aid with the discovery request.

I will send your the instructions via PM.

FYI when I change the Yale z-wave module to be the original type (had to get via ebay) rather than the new Z-wave 2 module things worked as expected.

I have 2 Yale YRD220 locks with the V1 ZWave module. I am having issues with current state and notifications in general. It last worked about 9 months ago. I reset lock to factory settings, Removed the Rboy App and DH. Rebooted smartthings and then set it all up again. Then recently I bought another YRD220 and zwave module hoping it would resolve the issue.
Below is breakdown of behaviour

Unlock from Keypay = Lock will unlock, but will not send a notification nor will the Lock Status change to unlocked

Unlock from ST App = Lock will unlock and status changes to unlocked, but after 180 seconds when autolock activates the lock will lock, but the status remains unlocked

Adding/changing users from the app = No issues here, just takes a little time to process

Rboy SmartApp version “07.06.06”
Rboy DH version 04.02.02
Yes I know they are a little out of date, but dont want to spend anymore money on this issue unless I know it will work as expected
I have also tried using the generic DH within ST Z-Wave with and without codes

Both locks are within 15ft of the smartthings

Anyone have any ideas what I could try
In live logging I noticed this, not sure if related

10d9f00a-ae24-4e65-b83a-6e057f84a117 13:30:04: warn Ignoring command from A Lock: NotificationReport(eventParametersLength: 0, eventParameter: , zensorNetSourceNodeId: 0, v1AlarmType: 22, reserved61: 0, notificationStatus: 0, sequence: false, event: 0, notificationType: 0, v1AlarmLevel: 1)

ST had made changes to the hub firmware which is why we work hard to keep the apps and DTH’s up to date with the environment. See this release. You should also consider adding a repeater close to your lock.

Thanks for that. Both seem to be working now. Just a little slow. Will give it time to settle down and do all its syncing.