SmartThings Community

[RELEASE] Universal Enhanced Z-Wave Plus Lock Device Handler: Schlage, Yale, Kwikset, IDLock, DanaLock, August Pro, Samsung, Locstar, Delaney, KeyWe, Philia Locks and Popp Z-Wave Keypad with Alarm Control, Notification, RFID, Door Sensor

I updated, but my BE469 lost all tiles associated with sound, autolock, etc. The only tiles are Lock, Unlock, and battery (which seems to be wrong).

Sounds like your lock is using/reverted the stock DTH and not the custom DTH.

Nope. Checked and verified that I’m using the new app. Anything else to try?

1 Like

I was seeing the same thing, I ended up removing completely using exclusion process to try to pair it again. Unfortunately now the lock doesn’t show up on SmartThings classic app even though the lock sometimes shows join event on backend. I also tried to manually add (with universal rboy dth) using the device network id in the join event but I’m back to the screen you’re seeing and can’t control lock.

Any ideas @RBoy
??

the SmartThings platform has gone to :toilet:

Blank tiles on the BE469 means your lock is having trouble communicating with the mesh and the hub (the responses aren’t reaching the hub or vice versa)
Tap the refresh tile at the bottom of the page a couple of times. If you don’t see any tiles show up then try to reboot your hub, add a repeater within 20ft of the lock and do a Z-Wave repair. Some folks have been seeing issues with the network/cloud latency in the past few days causing timeouts/delays, usually rebooting the internet modem and hub helps reduce the latency but if the ST server is running slow not much you can do other than report it to ST to investigate.

EDIT: You may also want to open the IDE and check under My Devices -> Click on your lock -> MSR, if that’s blank, incorrect or corrupted it can explain why the tiles disappeared. Your IDE Live Logs will show unknown MSR when you tap refresh. One person had a similar issue recently where this information was corrupted which was causing issues. You will need to exclude the lock and re pair it again to fix the corruption.

1 Like

Does it make sense that my Monoprice Z-Wave lock is showing up as Yale?

I seem to be having the same issue with ONE of my Schlage locks. (100% positive DH is installed on both - both now show ‘Cloud’ in the IDE)

Front door only shows Lock, Unlock, Battery
Back door shows all - appears to be working as expected.

Front door - Replaced batteries. Rebooted hub. Did a Z-wave repair. No luck

The back door lock is located about 8ft away from the hub.
The front door lock is located about 30ft away. (but not many obstructions/walls)

Looking in the IDE, I noticed something odd. I thought that the two locks were identical, but according to what I see in the lock Data, there’s a difference.

Back door (working):
MSR: 003B-6349-5044
endpointId: 0
fw: 128.22

Front door (not working)
MSR: 003B-6349-5044
fw: 60.178
manufacturer: Schlage

So there appears to be a firmware difference, but also one shows “endpoint” and the other shows “manufactuer”. Why?

Is there a way to update the firmware on these?

I’ve picked out a wall outlet Z-wave extender to put by the front door if there’s nothing else to try.

Yale Z-Wave locks are on sale for $149 to $199 on Amazon and ZWaveProducts if anyone is interested:

https://www.zwaveproducts.com/shop/z-wave-security/z-wave-door-locks

I have the August Lock Pro and I’m not using the Door Sense. I have DPS turned off but my lock is reporting has open. How can correct this?

Thanks

Have now installed a range extender about 10ft from the front door lock.
Still only seeing the lock/unlock/battery tiles.

Try to reset your lock or exclude and re pair it. Blank tiles means that the lock isn’t responding (which should be fixed by the buffered repeater) or the pairing is corrupted and the platform is not returning the correct identification for the lock.

@smwein the August lock should ideally be used with the DPS sensor otherwise it can return a random state.

I did a reset of the lock…no luck. (Hold down Schlage button while reconnecting batteries)
I did a factory reset…still no luck.

When attempting to exclude the lock, after the last step of hitting the ZERO on the keypad, I always end up with the red X. I understand this to mean that it wasn’t successful.
Even held the hub right next to the lock a few times.

[EDIT] Finally got it. I had to completely remove the lock from Smartthings. As soon as I did that, the app went into exclusion mode and then I repeated the process on the lock…and it was excluded. Then rejoined.
Lock now has all the tiles.

1 Like

Im just about ready to take the plunge and get the SCHLAGE FE469.

the thing that has been holding me back is, knowing how smartthings/hub can get finicky. so what happens if it losses connection? is there a manual override? how do i get the lock to open/close? im assuming there is a key to use? (still?)

I don’t have this particular lock. However, it appears that there is a key. Also, if it’s like my lock (Kwikset 912) , even if the hub is offline, the key pad will still work with local control for your codes, etc.

2 Likes

I just installed one last weekend… think of it as double redundant. If the hub is down for whatever reason, the codes will still work as @lflorack said. If the hub is down and the batteries have died for the keypad, the key still works the outside of the lock.

2 Likes

groovy.lang.MissingMethodException: No signature of method: script_app_metadata_0227f12c_f49b_4d96_84b6_fbeec862bde5.metadata() is applicable for argument types: (script_app_metadata_0227f12c_f49b_4d96_84b6_fbeec862bde5$_run_closure1) values: [script_app_metadata_0227f12c_f49b_4d96_84b6_fbeec862bde5$_run_closure1@1cf16d4d]
Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

Hi @Brian_Rener,

Your post only has some error code. Are you having problems setting up this DTH? Did you accidentally try to use DTH code for a smartapp? How and when did you get this?

1 Like

@RBoy,

I just installed a Kwikset 910 lock and did not install any user codes on the lock itself.

I’ve updated the DTH to your universal one and installed the lock manager application. If I look at the Recently tab within Smartthings, I’m getting alot of activity that doesn’t make sense to me.
It keeps adding and deleting the 2 users I’ve setup within the application. This morning it notified me that user 1 is a duplicate code and to please clear extra codes from your lock. Not sure where user 1 is coming from and as I said earlier I didn’t create any codes on the lock itself.

What should I do to correct these issues?

Thanks
Angie

Hi Angie,

It sounds like you have two (or more) apps connected to your lock which are conflicting with each other. One is adding while the other is deleting. If you click on the SmartApps tab on the device page on your Classic app it will show the apps which are connected and using the lock (for example LUM or RLA). There should only be one app connected to the app. Tap the other apps and uninstall them.

That should solve your add / delete loop you’re seeing in the activity tab.