SmartThings Community

[RELEASE] Universal Enhanced Z-Wave Lock, Schlage, Yale, Kwikset, IDLock, DanaLock, August Pro, Samsung, Locstar, Delaney, KeyWe, Philia Locks and Popp Z-Wave Keypad Device Handler with Alarm Control, Notification, RFID, Door Sensor and advanced features

smartapp_alerts
dth_locks
smartapp_security
smartapp_locks
rboyapps
(Goose) #140

First off, RBoy has been awesome and very helpful and I love the app!

My lock is the Schlage Connect (FE469NX)

I’ve noticed since the last ST update, the lock is sometimes slow, or doesn’t even tell me via the ‘messages’ on the ST app if the door was locked or unlock or who used their code. Sometimes it works and registers, but sometimes it doesn’t. It worked fine on Thanksgiving day, as I’d show my family how it would respond and how I could unlock from my phone. As of today, it does not unlock/lock from my app, or its very slow in doing so (more like 10% chance it will work).

Now we did have power shut off during a storm after Thanksgiving (when the lock became worse and worse in responding), so I did the following:

Unplugged my STv2 Hub for 5 or so minutes and waited until steady green to do the following:

Removed/Reinstalled the lock app
Removed/Reinstalled lock from my Z Network

Now for today, I reinstalled the app with the newest version, and the codes were sent and all is well. When I used one of the codes, it worked, but ST did not see it as it happened. It just unlocked the door and the activity did not show that it was unlocked, and in which, did not tell me via SMS that it was unlocked.

I just tried it again after a few minutes since the last time I tried, and it worked and show me via the app and SMS. But I tried to unlock the door from the app and it did not work. If I manually lock it, it thinks its still unlocked. I have the Schlage lock to auto-lock after 15 seconds, I’m not using any App to do so, could that be the cause?

I know I rambled on, but I’m fairly new to all HA, and don’t know the best way to explain myself.

Thoughts?

(www.rboyapps.com - Make your home your butler!) #141

The most likely cause is the distance between your lock and hub is too far and it causing communication issues. Looks like you’ve covered the rest of the stuff. If you can’t move it closer then try to get a powered Z-Wave repeater device (like a Z-Wave power outlet) in between that will help the communications.

(Goose) #142

Copy that. It’s probably 50 feet away or so from the hub. Through walls too.

(www.rboyapps.com - Make your home your butler!) #143

Added a patch to the code to speed up first time install initialization of feature states.

(Goose) #144

Unsure where to put this update.

I installed the new app yesterday. Everything was great. The coded deleted yesterday at 5PM.

The code was not sent today at 8AM, didn’t try or anything.

Thoughts? Same issue for the past week. I resent all the codes again and it of course works, but even with the updated code, it still doesn’t send the code in the morning.

(www.rboyapps.com - Make your home your butler!) #145

This one belongs on the other thread Goose:

I had answered this questions yesterday in the above link / last 2 posts, please report it to the link I had posted on the above post. It’s due to the platform timers dying that ST is looking into.

1 Like
#146

Got this error tonight…what do now?

Oh No! Something Went Wrong!
Error
500: Internal Server Error
URI
/device/update
Reference Id
7b31795b-761d-4691-8e2d-a6d72065c74d
Date
Sun Dec 06 02:05:46 UTC 2015

(Benji) #147

I think the ST cloud is having some issues tonight.

(www.rboyapps.com - Make your home your butler!) #148

Please report it to support@smartthings.com otherwise they won’t know/fix it.

(www.rboyapps.com - Make your home your butler!) #149

On request from users, added code to expose capabilities for a Switch (on -> lock, off -> unlock). However this has been commented out to avoid confusion. You can un comment the code out to enable it. Look for the words “Dummy code”

(Tolik) #150

Just setup this device type. Was using Garyd9’s code previously

Couple of things…

  1. I’m not sure how or why but all my user codes got deleted… (my wife was not happy coming home =)

  2. Whats the point of having the icons for Lock/Unlock if the pressing on the green circle basically does the same thing.

  3. On my Note 5 you can see how the “code entry on” is overlapping the icon (not a big deal just pointing it out)

1 Like
(www.rboyapps.com - Make your home your butler!) #151
  1. Wrong thread :smile: nothing to do with the device code. https://community.smartthings.com/t/door-lock-user-code-management-create-delete-and-schedule-codes-with-automatic-lock-unlock/ . This is the app behavior, if there are no codes entered for a slot it will delete the slot as a safety so ensure that you’ve entered usernames and codes for all slots you want programmed, please see the instructions on the thread first post

  2. Just for clarity not everyone realizes you can click on the green circle, plus it’s an explicit command to send. I’ve seen cases where ST doesn’t update the status and just to be safe I click on lock to ensure it’s locked.

  3. It’s a ST phone app rendering thing, can’t control it from the code. Report it to support as a bug, it shows up fine on some phones and not on others.

(Jarett) #152

Edit: wrong thread…

1 Like
#153

Hello Rboy,

Just grabbed the device and app tonight. I am finding it very useful so far. Unfortunately for me I have the Schlage FE599 model which apparently does not support the autolock feature. Any idea how I can perform an autolock function with the Schlage FE599 model without having to purchase an open/close sensor?

Thanks!

Scott

(www.rboyapps.com - Make your home your butler!) #154

Not impossible but will require some software hacking, you will need to write custom code in the device handler to send a lock signal ‘X’ seconds after you receive the unlock notification. Best of luck :smile:
Probably easier to buy a sensor and just use the Multi User Lock Code manager i’ve written and enable the option to lock the door automatically upon closing.

(www.rboyapps.com - Make your home your butler!) #155

Update the base code to improve setup time and battery.

(Daniel) #156

I also have the Schlage FE599. If you unlock it with a code, it relocks itself after about 5 seconds.

(www.rboyapps.com - Make your home your butler!) #157

Version 2.4.0

This is major update, there are some bugs in the Stock ST Z-Wave Lock which have been fixed. This device type now works with all Z-Wave Locks (Yale, Kwikset, Monoprice etc) and for Schlage locks it adds on some enhanced features like Alarms, Keypad control etc.

(Derrek Krasnicki ) #158

Do I have to update the code in ide?

(www.rboyapps.com - Make your home your butler!) #159

Yes take the latest code from the server.